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Product Overview

Design and implement motor control algorithms

Motor Control Blockset provides Simulink® blocks for creating and tuning field-oriented control and
other algorithms for brushless motors. Blocks include Park and Clarke transforms, sensorless
observers, field weakening, a space-vector generator, and an FOC autotuner. You can verify control
algorithms in closed-loop simulation using the motor and inverter models included in the blockset.

The blockset parameter estimation tool runs predefined tests on your motor hardware for accurate
estimation of stator resistance, d-axis and q-axis inductance, back EMF, inertia, and friction. You can
incorporate these motor parameter values into a closed-loop simulation to analyze your controller
design.

Reference examples show how to verify control algorithms in desktop simulation and generate
compact C code that supports execution rates required for production implementation. The reference
examples can also be used to implement algorithms for motor control hardware kits supported by the
blockset.
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Model Configuration Parameters
Update the configuration parameters for a Simulink model that you create, before simulating or
deploying the model to the controller.

In the Simulink window, click Hardware Settings in the HARDWARE tab to open the Configuration
Parameters dialog box and select the target hardware in the Hardware board field.

Solver Configuration
In the Solver tab of the Configuration Parameters dialog box, for a fixed-step discrete solver, type
auto in the Fixed-step size (fundamental sample time) field.

ADC Interface Configuration
If you connect analog inputs (current or voltage sensors) to the hardware board, configure the related
ADC parameters in the Configuration Parameters dialog box by using these steps:

1 Open the Hardware Implementation tab.
2 Set the ADC clock prescaler and check the ADC clock frequency. Ensure that the displayed ADC

clock frequency is less than the maximum value specified in the device datasheet.

This example shows the ADC configuration for LAUNCHXL-F28379D board. The maximum operating
frequency of ADCCLK for TMS320F28379D targets is 50 MHz.
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PWM Interface Configuration
If you connect PWM outputs from target device to the inverter, configure the related PWM
parameters in the Configuration Parameters dialog box by using the following steps:

1 Open the Hardware Implementation tab.
2 Set the ePWM clock divider to SYSCLKOUT/1.
3 Update the following PWM pin assignment fields.

ePWM pin settings Property
PWM1A pin assignment Gate pulse for Phase-A high-side transistor
PWM1B pin assignment Gate pulse for Phase-A low-side transistor
PWM2A pin assignment Gate pulse for Phase-B high-side transistor
PWM2B pin assignment Gate pulse for Phase-B low-side transistor
PWM3A pin assignment Gate pulse for Phase-C high-side transistor
PWM3B pin assignment Gate pulse for Phase-C low-side transistor

 Model Configuration Parameters
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Hall Sensor Interface Configuration
If you connect a Hall sensor to the hardware board, configure the related parameters in the
Configuration Parameters dialog box by using the following steps:

1 Open the Hardware Implementation tab.
2 Select the eCAP group under Hardware board settings > Target hardware resources.
3 Update the following ECAP pin assignment fields:

ECAP pin assignment field Field value
ECAP1 pin assignment Hall A
ECAP2 pin assignment Hall B
ECAP3 pin assignment Hall C

2 Model Configuration Parameters
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The following example shows the eCAP configuration for a Hall sensor connected to DRV8312 board
with a F28069 Piccolo MCU control card:

Quadrature Encoder Interface Configuration
If you connect a Quadrature Encoder sensor to the hardware board, configure the related parameters
in the Configuration Parameters dialog box by using the following steps:

1 Open the Hardware Implementation tab.
2 Select the eQEP group under Hardware board settings > Target hardware resources.
3 Update the following EQEP pin assignment fields:

EQEP pin assignment field Property
EQEP1A pin assignment Quadrature Encoder Channel A
EQEP1B pin assignment Quadrature Encoder Channel B
EQEP1I pin assignment Quadrature Encoder Index

The following example shows the eQEP configuration for a quadrature encoder sensor connected to a
LAUNCHXL-F28379D board:

 Model Configuration Parameters
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Serial Communication Interface Configuration
If you are generating code and using serial communication between host and target Simulink models,
configure the related parameters in the Configuration Parameters dialog box by using the following
steps:

1 Open the Hardware Implementation tab.
2 Select the SCI_A group under Hardware board settings > Target hardware resources.
3 Update the following SCI_A settings:

SCI_A settings Property
Suspension mode Serial suspension mode
Number of stop bits Stop bits
Parity mode Parity

2 Model Configuration Parameters
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SCI_A settings Property
Character length bits Data bits
Desired baud rate in bits/sec Serial communication baud rate
Pin assignment(Tx) Output pin for Serial Transmit
Pin assignment(Rx) Input pin for Serial Receive

For example, use the following SCI_A configuration for a Hall sensor connected to a F28379D
LaunchPad board:

 Model Configuration Parameters
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Estimate Control Gains from Motor Parameters
Perform control parameter tuning for the speed and the torque control loops that are part of the
Field-Oriented Control (FOC) algorithm. Motor Control Blockset provides you with multiple methods
to compute the control loop gains from the system or block transfer functions that are available for
the motors, inverter, and controller:

• Use the Field Oriented Control Autotuner block.
• Use Simulink Control Design™.
• Use the model initialization script.

Field-Oriented Control Autotuner
The Field-Oriented Control Autotuner block of Motor Control Blockset enables you to automatically
tune the PID control loops in your Field-Oriented Control (FOC) application in real time. You can
automatically tune the PID controllers associated with the following loops (for more details, see “How
to Use Field Oriented Control Autotuner Block”):

• Direct-axis (d-axis) current loop
• Quadrature-axis (q-axis) current loop
• Speed loop

For each loop that the block tunes, the Field-Oriented Control Autotuner block performs the
autotuning experiment in a closed-loop manner without using a parametric model associated with
that loop. The block enables you to specify the order in which the block tunes the control loops. When
the tuning experiment runs for one loop, the block has no effect on the other loops. For more details
about FOC autotuner, see Field Oriented Control Autotuner and “Tune PI Controllers Using Field
Oriented Control Autotuner” on page 4-25.

3 Estimate Control Gains from Motor Parameters
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Simulink Control Design
Simulink Control Design enables you to design and analyze the control systems modeled in Simulink.
You can automatically tune the arbitrary SISO and MIMO control architectures, including the PID
controllers. You can deploy PID autotuning to the embedded software to automatically compute the
PID gains in real time.

You can find the operating points and compute the exact linearizations of the Simulink models at
different operating conditions. Simulink Control Design provides tools that let you compute the
simulation-based frequency responses without modifying your model. For details, see https://
www.mathworks.com/help/slcontrol/index.html.

Model Initialization Script
This section explains how the Motor Control Blockset examples estimate the control gains needed to
implement field-oriented control. For example, for a PMSM that is connected to a quadrature
encoder, these steps describe the procedure to compute the control loop gain values from the system
details by using the initialization script:

1 Open the initialization script (.m) file of the example in MATLAB®. To find the associated script
file name:

a Select Modeling > Model Settings > Model Properties to open the model properties
dialog box.

b In the Model Properties dialog box, navigate to the Callbacks tab > InitFcn to find the
name of the script file that Simulink opens before running the example.

 Estimate Control Gains from Motor Parameters
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2 This figure shows an example of the initialization script (.m) file.
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3 Use the Workspace to edit the control variables values. For example, to update Stator resistance
(Rs), use the variable pmsm to add the parameter value to the Rs field.

4 The model initialization script associated with a target model calls these functions and sets up
the workspace with the necessary variables.
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Model Initialization Script Function Called By Model
Initialization Script

Description

Script associated with a
target model

mcb_SetPMSMMotorParame
ters

Input to the function is motor
type (for example, BLY171D).

The function populates a
structure named pmsm in the
MATLAB workspace, which is
used by the model.

It also computes the
permanent magnet flux and
rated torque for the selected
motor.

You can extend the function
by adding an additional
switch-case for a new motor.

This function also loads the
structure motorParam,
obtained by running
parameter estimation, to the
structure pmsm. If the
structure motorParam is not
available in the MATLAB
workspace, the function
loads the default parameters.

mcb_SetInverterParamet
ers

Input to the function is
inverter type (for example,
BoostXL-DRV8305).

The function populates a
structure named inverter
in the MATLAB workspace,
which is used by the model.

The function also computes
the inverter resistance for
the selected inverter.

You can extend the function
by adding an additional
switch-case for a new
inverter.
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Model Initialization Script Function Called By Model
Initialization Script

Description

mcb_SetProcessorDetail
s

Inputs to the function are
processor type (for example,
F28379D) and the Pulse-
Width Modulation (PWM)
switching frequency.

The function populates a
structure named target in
the MATLAB workspace,
which is used by the model.

The function also computes
the PWM counter period that
is a parameter for the ePWM
block in the target model.

You can extend the function
by adding an additional
switch-case for a new
processor.

mcb_getBaseSpeed Inputs to the function are
motor and inverter
parameters.

The function computes the
base speed for PMSM.

Type help
mcb_getBaseSpeed at the
MATLAB command window
or see section “Obtain Base
Speed” on page 3-14 for
more details.

mcb_SetPUSystem Inputs to the function are
motor and inverter
parameters.

The function sets the base
values of the per-unit system
for voltage, current, speed,
torque, and power.

The function populates a
structure named PU_System
in the MATLAB workspace,
which is used by the model.

3 Estimate Control Gains from Motor Parameters
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Model Initialization Script Function Called By Model
Initialization Script

Description

mcb.internal.SetContro
llerParameters

Inputs to the function are
motor and inverter
parameters, per-unit system
base values, PWM switching
time period, sample time for
the control system, and
sample time for the speed
controller.

The function computes the
Proportional Integral (PI)
parameters (Kp, Ki) for the
field-oriented control
implementation.

The function populates a
structure named PI_params
in the MATLAB workspace,
which is used by the model.

See section “Obtain
Controller Gains” on page 3-
16 for more details.

mcb_updateInverterPara
meters

Inputs to the function are
motor and inverter
parameters.

The function updates the
inverter parameters based on
the selected hardware and
motor.

This table explains the useful variables for each control parameter that you can update.

Note You can try starting MATLAB in the administrator mode on Windows® system, if you are unable
to update the model initialization scripts associated with the example models.

Control Parameter Category Control Parameter Name MATLAB Workspace Variable
Motor parameters Manufacturer’s model number pmsm.model

Manufacturer’s serial number pmsm.sn
Pole pairs pmsm.p
Stator resistance (Ohm) pmsm.Rs
d-axis stator winding inductance
(Henry)

pmsm.Ld

 Estimate Control Gains from Motor Parameters
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Control Parameter Category Control Parameter Name MATLAB Workspace Variable
q-axis stator winding inductance
(Henry)

pmsm.Lq

Back emf constant
(V_line(peak)/krpm)

pmsm.Ke

Motor Inertia (kg.m2) pmsm.J
Friction constant (N.m.s) pmsm.F
Permanent Magnet Flux (WB) pmsm.FluxPM
Trated pmsm.T_rated
Nbase pmsm.N_base
Irated pmsm.I_rated

Position decoders QEP index and Hall position
offset correction

pmsm.PositionOffset

Quadrature encoder slits per
revolution

pmsm.QEPSlits

Inverter parameters Manufacturer’s model number inverter.model
Manufacturer’s serial number inverter.sn
DC link voltage of the inverter
(V)

inverter.V_dc

Maximum permissible currents
by inverter (A)

inverter.I_trip

On-state resistance of MOSFETs
(Ohm)

inverter.Rds_on

Shunt resistance for current
sensing (Ohm)

inverter.Rshunt

Per-phase board resistance seen
by motor (Ohm)

inverter.R_board

ADC Offsets for current sensor
(Ia and Ib)

inverter.CtSensAOffset

inverter.CtSensBOffset
Maximum limit of automatically
calibrated ADC offsets for
current sensor (Ia and Ib)

inverter.CtSensOffsetMax

Minimum limit of automatically
calibrated ADC offsets for
current sensor (Ia and Ib)

inverter.CtSensOffsetMin

Enable Auto-calibration for
current sense ADCs

inverter.ADCOffsetCalibE
nable

ADC gain factor configured by
SPI

inverter.ADCGain

3 Estimate Control Gains from Motor Parameters
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Control Parameter Category Control Parameter Name MATLAB Workspace Variable
Type of inverter:

1 — Active high-enabled
inverter.

0 — Active low-enabled inverter.

inverter.EnableLogic

Type of current sense amplifier:

1 — Non-inverting amplifier

–1 — Inverting amplifier

inverter.invertingAmp

Reference voltage for the
inverter current sensing circuit
(V)

inverter.ISenseVref

Output voltage of the inverter
current sensing circuit
corresponding to 1 Ampere
current (V/A)

You can compute this parameter
using the datasheet values of
current shunt resistance
(inverter.Rshunt) and
current sense amplifier gain of
the inverter.

inverter.ISenseVoltPerAm
p = inverter.Rshunt ✖
current sense amplifier gain

inverter.ISenseVoltPerAm
p

Maximum measurable peak-
neutral current by the inverter
current sensing circuit (A)

inverter.ISenseMax

Processor Manufacturer’s model number target.model
Manufacturer’s serial number target.sn
CPU Frequency target.CPU_frequency
PWM frequency target.PWM_frequency
PWM counter period target.PWM_Counter_Perio

d
Reference voltage for ADC (V) Target.ADC_Vref
Maximum count output for 12-
bit ADC

Target.ADC_MaxCount

Baud rate for serial
communication

Target.SCI_baud_rate

Per-Unit System Base voltage (V) PU_System.V_base
Base current (A) PU_System.I_base
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Control Parameter Category Control Parameter Name MATLAB Workspace Variable
Base speed (rpm) PU_System.N_base
Base torque (Nm) PU_System.T_base
Base power (Watts) PU_System.P_base

Data-type for target device Data-type (Fixed-point Or
Floating-point) selection

dataType

Sample time values Switching frequency for
converter

PWM_frequency

PWM switching time period T_pwm
Sample time for current
controllers

Ts

Sample time for speed
controller

Ts_speed

Simulation sample time Ts_simulink
Simulation sample time for
motor

Ts_motor

Simulation sample time for
inverter

Ts_inverter

Controller parameters Proportional gain for Iq
controller

PI_params.Kp_i

Integral gain for Iq controller PI_params.Ki_i
Proportional gain for Id
controller

PI_params.Kp_id

Integral gain for Id controller PI_params.Ki_id
Proportional gain for Speed
controller

PI_params.Kp_speed

Integral gain for Speed
controller

PI_params.Ki_speed

Proportional gain for Field
weakening controller

PI_params.Kp_fwc

Integral gain for Field
weakening controller

PI_params.Ki_fwc

Sensor delay parameters Current sensor delay Delays.Current_Sensor
Speed sensor delay Delays.Speed_Sensor
Delay for low-pass speed filter Delays.Speed_Filter

Controller delay parameters Damping factor (ζ) of the
current control loop

Delays.OM_damping_factor

Symmetrical optimum factor of
the speed control loop

Delays.SO_factor_speed

Note For the predefined processors and drivers, the model initialization script uses the default
values.

3 Estimate Control Gains from Motor Parameters

3-12



The model initialization script uses these functions for performing the computations:

Control Parameter Category Function Functionality
Base speed of the motor mcb_getBaseSpeed Calculates the base speed of

PMSM at the rated voltage and
rated load.

For details, type help
mcb_getBaseSpeed at the
MATLAB command prompt or
see section “Obtain Base Speed”
on page 3-14.

Motor characteristics for the
given motor and inverter

mcb_getCharacteristics Obtain these characteristics of
the motor.

• Torque as opposed to speed
characteristics

• Power as opposed to speed
characteristics

• Iq as opposed to speed and
Id as opposed to speed
characteristics

For details, type help
mcb_getCharacteristics at
the MATLAB command prompt.

Control algorithm parameters mcb.internal.SetControll
erParameters

Compute the gains for these PI
controllers:

• Current (torque) control loop
gains (Kp, Ki) for currents Id
and Iq

• Speed control loop gains (Kp,
Ki)

• Field weakening control
gains (Kp, Ki)

For details, see section “Obtain
Controller Gains” on page 3-
16.
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Control Parameter Category Function Functionality
Control analysis for the motor
and inverter you are using

mcb_getControlAnalysis Performs frequency domain
analysis for the computed gains
of PI controllers used in the
field-oriented motor control
system.

Note  This feature requires
Control System Toolbox™.

For details, type help
mcb_getControlAnalysis at
the MATLAB command prompt.

Obtain Base Speed

The function mcb_getBaseSpeed computes the base speed of the PMSM at the given supply voltage.
Base speed is the maximum motor speed at the rated voltage and rated load, outside the field-
weakening region.

When you call this function (for example, base_speed = mcb_getBaseSpeed(pmsm,inverter)),
it returns the base speed (in rpm) for the given combination of PMSM and inverter. The function
accepts the following inputs:

• PMSM parameter structure.
• Inverter parameter structure.

These equations describe the computations that the function performs:

The inverter voltage constraint is defined by computing the d-axis and q-axis voltages:

vdo = −   ωeLqiq

vqo = ωe Ldid +   λpm

vmax =  
vdc  

3   − Rsimax   ≥   vdo
2 +   vqo

2

The current limit circle defines the current constraint which can be considered as:

imax
2 =   id 

2 +   iq2

In the preceding equation, id is zero for surface PMSMs. For interior PMSMs, values of id and iq
corresponding to MTPA are considered.

Using the preceding relationships, we can compute the base speed as:

ωbase =   1
p ⋅

 vmax

Lqiq
2 + Ldid +   λpm

2

where:
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• ωe is the electrical speed corresponding to frequency of stator voltages (Radians/ sec).
• ωbase is the mechanical base speed of the motor (Radians/ sec).
• id is the d-axis current (Amperes).
• iq is the q-axis current (Amperes).
• vdo is the d-axis voltage when id is zero (Volts).
• vqo is the q-axis voltage when iq is zero (Volts).
• Ld is the d-axis winding inductance (Henry).
• Lq is the q-axis winding inductance (Henry).
• Rs is the stator phase winding resistance (Ohms).
• λpm is the permanent magnet flux linkage (Weber).
• vd is the d-axis voltage (Volts).
• vq is the q-axis voltage (Volts).
• vmax is the maximum fundamental line to neutral voltage (peak) supplied to the motor (Volts).
• vdc is the dc voltage supplied to the inverter (Volts).
• imax is the maximum phase current (peak) of the motor (Amperes).
• p is the number of motor pole pairs.

Obtain Motor Characteristics

The function mcb_getCharacteristics calculates the torque and speed characteristics of the
motor, which helps you to develop the control algorithm for the motor.

The function returns these characteristics for the given PMSM:

• Torque as opposed to Speed
• Power as opposed to Speed
• Iq as opposed to Speed
• Id as opposed to Speed

 Estimate Control Gains from Motor Parameters

3-15



Obtain Controller Gains

The function mcb.internal.SetControllerParameters computes the gains for the PI controllers
used in the field-oriented motor control systems.

You can use this command to call the function mcb.internal.SetControllerParameters:

PI_params = mcb.internal.SetControllerParameters(pmsm,inverter,PU_System,T_pwm,Ts,Ts_speed);

The function returns the gains of these PI controllers used in the FOC algorithm:

• Direct-axis (d-axis) current loop
• Quadrature-axis (q-axis) current loop
• Speed loop
• Field-weakening control loop

The function accepts these inputs:

• pmsm object
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• inverter object
• PU system params
• T_pwm
• Ts_control
• Ts_speed

The function does not plot any characteristic.

The design of compensators depends on the classical frequency response analysis applied to the
motor control systems. We used the Modulus Optimum (MO) based design for the current controllers
and the Symmetrical Optimum (SO) based design for the speed controller.

The function automatically computes the other required parameters (for example, delays, damping
factor) based on the input arguments.

You can modify the default system responses by an optional input to the function that specifies the
system delays, damping factor, and symmetrical optimum factor:

PI_params = mcb.internal.SetControllerParameters(pmsm,inverter,PU_System,T_pwm,Ts,Ts_speed,Delays);

Damping factor (ζ) defines the dynamic behavior of the standard form of a second-order system,
where 0 < ζ < 1 [1]. An underdamped system gets close to the final value more quickly than a
critically damped or an overdamped system. Among the systems that respond without oscillations, a
critically damped system shows the quickest response. An overdamped system is always slow in
responding to any inputs. This parameter has a default value of 1

2 .

Symmetrical optimum factor (a) defines the placement of the cross-over frequency at the geometric
mean of the two corner frequencies, to obtain maximum phase margin that results in optimum
damping of the speed loop, where a > 1 [2]. This parameter has a default value of 1.2.

This example explains how to customize the parameters:

% Sensor Delays
Delays.Current_Sensor = 2*Ts;           %Current Sensor Delay
Delays.Speed_Sensor = Ts;               %Speed Sensor Delay
Delays.Speed_Filter = 20e-3;            %Delay for Speed filter (LPF)

% Controller Delays
Delays.OM_damping_factor = 1/sqrt(2);   %Damping factor for current control loop
Delays.SO_factor_speed = 1.5;           %Symmetrical optimum factor 1 < x < 20

% Controller design
PI_params = mcb.internal.SetControllerParameters(pmsm,inverter,PU_System,T_pwm,Ts,Ts_speed,Delays);

Perform Control Analysis

The function mcb_getControlAnalysis performs the basic control analysis of the PMSM FOC
current control system. The function performs frequency domain analysis for the computed PI
controller gains used in the field-oriented motor control systems.

Note This function requires the Control System Toolbox.
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When you call this function (for example,
mcb_getControlAnalysis(pmsm,inverter,PU_System,PI_params,Ts,Ts_speed)), it
performs the following functions for the current control loop or subsystem:

• Transfer function for the closed-loop current control system
• Root locus
• Bode diagram
• Stability margins (PM & GM)
• Step response
• PZ map

The function plots the corresponding plots:

References
[1] Ogata, K. (2010). Modern control engineering. Prentice hall.

[2] Leonhard, W. (2001). Control of electrical drives. Springer Science & Business Media. pp. 86.

3 Estimate Control Gains from Motor Parameters

3-18



Implement Motor Speed Control by
Using Field-Oriented Control (FOC)
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4



Field-Oriented Control (FOC)
Field-Oriented Control (FOC), also known as vector control, is a technique used to control Permanent
Magnet Synchronous Motor (PMSM) and AC induction motors (ACIM). FOC provides good control
capability over the full torque and speed ranges. The FOC implementation requires transformation of
stator currents from the stationary reference frame to the rotor flux reference frame (also known as
d-q reference frame).

Speed control and torque control are the most commonly used control modes of FOC. The position
control mode is less common. Most of the traction applications use the torque control mode in which
the motor control system follows a reference torque value. In the speed control mode, the motor
controller follows a reference speed value and generates a torque reference for the torque control
that forms an inner subsystem. In the position control mode, the speed controller forms the inner
subsystem.

FOC algorithm implementation requires real time feedback of the currents and rotor position.
Measure the current and position by using sensors. You can also use sensorless techniques that use
the estimated feedback values instead of the actual sensor-based measurements.

Permanent Magnet Synchronous Motor (PMSM)
This figure shows the FOC architecture for a PMSM. For detailed set of equations and assumptions
that Motor Control Blockset uses to implement FOC of a PMSM, see “Mathematical Model of PMSM”.

AC Induction Motor (ACIM)
This figure shows the FOC architecture for an AC induction motor (ACIM). For detailed set of
equations and assumptions that Motor Control Blockset uses to implement FOC of an induction
motor, see “Mathematical Model of Induction Motor”.
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Six-Step Commutation
Six-step commutation, also known as trapezoidal commutation, is a commutation technique used to
control three-phase brushless DC (BLDC) permanent magnet motor. It controls the stator currents to
achieve a motor speed and direction of rotation.

Six-step commutation uses these conduction modes:

• 120 degree mode conducts current in only two stator phases.
• 180 degree mode conducts current in all three stator phases.

Motor Control Blockset supports 120 degree conduction mode. At a given time, this mode energizes
only two stator phases and electrically isolates the third phase from the power supply. You can use
either Hall or quadrature encoder position sensors to detect the rotor position. Motor Control
Blockset provides Six Step Commutation block that uses the Hall sequence or rotor position inputs to
determine the 60 degree sector where the rotor is present. It generates a switching sequence that
energizes the corresponding phases. As the motor rotates, the sequence switches the stator currents
every 60 degree such that the torque angle (angle between rotor d-axis and stator magnetic field)
remains 90 degrees (with a deviation of 30 degrees). Therefore, the switching signals operate
switches to control the stator currents, and therefore, control the motor speed and direction of
rotation. For more details, see Six Step Commutation.

The stator current waveform takes a trapezoidal shape.

The 120 degree conduction mode is a less complex technique that provides good speed control for the
BLDC motors. This figure shows the six-step commutation architecture for a BLDC motor.
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Run 3-Phase AC Motors in Open-Loop Control and Calibrate
ADC Offset

This example uses open-loop control (also known as scalar control or Volts/Hz control) to run a motor.
This technique varies the stator voltage and frequency to control the rotor speed without using any
feedback from the motor. You can use this technique to check the integrity of the hardware
connections. A constant speed application of open-loop control uses a fixed-frequency motor power
supply. An adjustable speed application of open-loop control needs a variable-frequency power supply
to control the rotor speed. To ensure a constant stator magnetic flux, keep the supply voltage
amplitude proportional to its frequency.

Open-loop motor control does not have the ability to consider the external conditions that can affect
the motor speed. Therefore, the control system cannot automatically correct the deviation between
the desired and the actual motor speed.

This model runs the motor by using an open-loop motor control algorithm. The model helps you get
started with Motor Control Blockset™ and verify the hardware setup by running the motor. The
target model algorithm also reads the ADC values from the current sensors and sends the values to
the host model by using serial communication.

You can use this model to:

• Check connectivity with the target.
• Check serial communication with the target.
• Verify the hardware and software environment.
• Check ADC offsets for current sensors.
• Run a new motor with an inverter and target setup for the first time.

Models

The example includes these models:

• mcb_open_loop_control_f28069M_DRV8312

• mcb_open_loop_control_f28069MLaunchPad

• mcb_open_loop_control_f28379d

You can use these models for both simulation and code generation. You can also use the open_system
command to open the Simulink® models. For example, use this command for a F28069M based
controller:

open_system('mcb_open_loop_control_f28069M_DRV8312.slx');
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For the model names that you can use for different hardware configurations, see the Required
Hardware topic in the Generate Code and Deploy Model to Target Hardware section.

Required MathWorks® Products

To simulate model:

1. For the models: mcb_open_loop_control_f28069M_DRV8312 and
mcb_open_loop_control_f28069MLaunchPad

• Motor Control Blockset™
• Fixed-Point Designer™

2. For the model: mcb_open_loop_control_f28379d

• Motor Control Blockset™

To generate code and deploy model:

1. For the models: mcb_open_loop_control_f28069M_DRV8312 and
mcb_open_loop_control_f28069MLaunchPad

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™

2. For the model: mcb_open_loop_control_f28379d

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors

 Run 3-Phase AC Motors in Open-Loop Control and Calibrate ADC Offset

4-7



• Fixed-Point Designer™ (only needed for optimized code generation)

Prerequisites

1. For BOOSTXL-DRV8323, use these steps to update the model:

• Navigate to this path in the model: /Open Loop Control/Codegen/Hardware Initialization.

• For LAUNCHXL-F28379D: Update DRV830x Enable block from GPIO124 to GPIO67.

• For LAUNCHXL-F28069M: Update DRV830x Enable block from GPIO50 to GPIO12.

2. For BOOSTXL-3PHGANINV, use these steps to update the model:

• For LAUNCHXL-F28379D: In the Configuration panel of mcb_open_loop_control_f28379d, set
Inverter Enable Logic to Active Low.

NOTE: When using BOOSTXL-3PHGANINV inverter, ensure that proper insulation is available
between bottom layer of BOOSTXL-3PHGANINV and the LAUNCHXL board.

Simulate Model

This example supports simulation. Follow these steps to simulate the model.

1. Open a model included with this example.

2. Click Run on the Simulation tab to simulate the model.

3. Click Data Inspector on the Simulation tab to view and analyze the simulation results.

Generate Code and Deploy Model to Target Hardware

This section instructs you to generate code and run the motor by using open-loop control.

The example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
model is to deploy the target model to the controller hardware board. The host model uses serial
communication to command the target Simulink® model and run the motor in a closed-loop control.

Required Hardware

This example supports these hardware configurations. You can also use the target model name to
open the model for the corresponding hardware configuration, from the MATLAB® command prompt.

• F28069M controller card + DRV8312-69M-KIT inverter:
mcb_open_loop_control_f28069M_DRV8312

For connections related to the preceding hardware configuration, see “F28069 control card
configuration” on page 7-2.

• LAUNCHXL-F28069M controller + (BOOSTXL-DRV8301 or BOOSTXL-DRV8305 or BOOSTXL-
DRV8323 or BOOSTXL-3PHGANINV) inverter: mcb_open_loop_control_f28069MLaunchPad

• LAUNCHXL-F28379D controller + (BOOSTXL-DRV8301 or BOOSTXL-DRV8305 or BOOSTXL-
DRV8323 or BOOSTXL-3PHGANINV) inverter: mcb_open_loop_control_f28379d
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To configure the model mcb_open_loop_control_f28379d, set the Inverter Enable Logic field (in
the Configuration panel of target model) to:

• Active High: To use the model with BOOSTXL-DRV8301 or BOOSTXL-DRV8305 or BOOSTXL-
DRV8323 inverter.

• Active Low: To use the model with BOOSTXL-3PHGANINV inverter.

For connections related to the preceding hardware configurations, see “LAUNCHXL-F28069M and
LAUNCHXL-F28379D Configurations” on page 7-5.

NOTE:

• This example supports any type of three-phase AC motor (PMSM or induction) and any type of
inverter attached to the supported hardware.

• Some PMSMs do not run at higher speeds, especially when the shaft is loaded. To resolve this
issue, you should apply more voltages corresponding to a given frequency. You can use these steps
to increase the applied voltages in the model:

1. Navigate to this path in the model: /Open Loop Control/Control_System/VabcCalc/.

2. Update the gain Correction_Factor_sinePWM as 20%.

3. For safety reasons, regularly monitor the motor shaft, motor current, and motor temperature.

Generate Code and Run Model to Implement Open-Loop Control

1. Simulate the target model and observe the simulation results.

2. Complete the hardware connections.

3. Open the target model for the hardware configuration that you want to use. If you want to change
the default hardware configuration settings for the target model, see “Model Configuration
Parameters” on page 2-2.

4. Update these motor parameters in the Configuration panel of the target model.

• Number of Pole Pairs
• PWM Frequency [Hz]
• Base Speed [RPM]
• Data type for control algorithm
• Inverter Enable Logic (only available in mcb_open_loop_control_f28379d target model)

5. Load a sample program to CPU2 of LAUNCHXL-F28379D, for example, a program that operates
the CPU2 blue LED by using GPIO31 (c28379D_cpu2_blink.slx), to ensure that CPU2 is not
mistakenly configured to use the board peripherals intended for CPU1.

6. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

NOTE: Ignore the warning message "Multitask data store option in the Diagnostics page of the
Configuration Parameter Dialog is none" displayed by the model advisor, by clicking the Always
Ignore button. This is part of the intended workflow.
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7. Click the host model hyperlink in the target model to open the associated host model. You can
also use the open_system command to open the host model. For example, use this command for a
F28069M based controller:

open_system('mcb_open_loop_control_host_model.slx');
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For details about the serial communication between the host and target models, see “Host-Target
Communication” on page 6-2.

8. In the Host Serial Setup block mask of the host model, select a Port name.

9. Select a target (either TI F28069M or TI F28379D) in the Configuration Panel of the host model.

10. Enter the Reference Speed value in the host model.

11. Click Run on the Simulation tab to run the host model.

12. Change the position of the Start / Stop Motor switch to On, to start running the motor.

13. After the motor is running, observe the ADC counts for the  and  currents in the Time Scope.

NOTE: This example may not allow the motor to run at full capacity. Begin running the motor at a
small speed. In addition, it is recommended to change the Reference Speed in small steps (for
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example, for a motor having a base speed of 3000 rpm, start running the motor at 500 rpm and then
increase or decrease the speed in steps of 200 rpm).

If the motor does not run, change the position of the Start / Stop Motor switch to Off, to stop the
motor and change the Reference Speed in the host model. Then, change the position of the Start /
Stop Motor switch to On, to run the motor again.

Generate Code and Run Model to Calibrate ADC Offset

1. Simulate the target model and observe the simulation results.

2. Complete the hardware connections.

3. Disconnect the motor wires for three phases from the hardware board terminals.

4. Open the target model for the hardware configuration that you want to use. If you want to change
the default hardware configuration settings for the target model, see “Model Configuration
Parameters” on page 2-2.

5. Load a sample program to CPU2 of LAUNCHXL-F28379D (for example, program that operates the
CPU2 blue LED using GPIO31) to ensure that CPU2 is not mistakenly configured to use the board
peripherals intended for CPU1.

6. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

NOTE: Ignore the warning message "Multitask data store option in the Diagnostics page of the
Configuration Parameter Dialog is none" displayed by the model advisor, by clicking the Always
Ignore button. This is part of the intended workflow.

7. Click the host model hyperlink in the target model to open the associated host model.

8. In the Host Serial Setup block mask of the host model, select a Port name.

9. Click Run on the Simulation tab to run the host model.

10. Observe the ADC counts for the  and  currents in the Time Scope. The average values of the
ADC counts are the ADC offset corrections for the currents  and . To obtain the average (median)
values of ADC counts:

• In the Scope window, navigate to Tools > Measurements and select Signal Statistics to display
the Trace Selection and Signal Statistics areas.
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• Under Trace Selection, select a signal (  or ). The characteristics of the selected signal are
displayed in the Signal Statistics pane. You can see the median value of the selected signal in the
Median field.
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For the Motor Control Blockset examples, update the computed ADC (or current) offset value in the
inverter.CtSensAOffset and inverter.CtSensBOffset variables in the model initialization script linked
to the example. For instructions, see “Estimate Control Gains from Motor Parameters” on page 3-2.
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Tune Control Parameter Gains in Hardware and Validate Plant
This example uses field-oriented control (FOC) to run a three-phase permanent magnet synchronous
motor (PMSM) in different modes of operation for plant validation. FOC algorithm implementation
needs the real-time feedback of the rotor position. This example uses a quadrature encoder sensor to
measure the rotor position. For details about FOC, see “Field-Oriented Control (FOC)” on page 4-2.

The example runs the motor in these modes:

• Stop - In this mode, the motor stops running because the inverter outputs zero volts.

• Open loop - In this mode, the controller uses open-loop control to run the motor. You can use the
Operating Mode Variables > Open-loop mode area of the host model to change the output
voltage of the inverter (in per-unit) and the rotor speed (in per-unit). Use the Monitor area to
select the speed and rotor position values to display them on the scope for monitoring.

• Torque control - In this mode, the controller uses a torque control algorithm to run the motor.
You can use the Operating Mode Variables > Motor torque control mode area of the host
model to change the  reference and  reference current values (in per-unit). You can also set the
maximum speed limit of the motor (in per-unit).

You can lock the rotor by turning the slider switch to the Pos lock position that sets the rotor position
to zero. Therefore, in this mode, the controller receives the position feedback as zero because the
motor stops running. If you turn the switch to the Unlock position, the motor runs and the controller
receives position feedback from the quadrature encoder (you can monitor this value by using the
Position_meas signal in the Monitor area of host model). You can use the scope to monitor the two
debug signals (Monitor Signal #1 and Monitor Signal #2) that you select in the Monitor area.
Therefore, you can use the slider switch to tune the torque control gain parameters.

• Speed control - In this mode, the controller uses a speed control algorithm to run the motor. You
can use the Operating Mode Variables > Motor speed control mode area of the host model to
change the Speed Reference value (in per-unit) of the rotor. You can use the scope to monitor the
two debug signals (Monitor Signal #1 and Monitor Signal #2) that you select in the Monitor area.

For information related to the per-unit system, see “Per-Unit System” on page 6-15.

To further control the motor, you can also use the Control loop gains area of the host model to
change the control parameters of the d-axis and q-axis current controllers and the speed controller.

You can use this example to run the motor in open-loop control, torque control, and speed control
modes. You can also use this example for tuning the hardware gains and validating the plant model.

Caution: Stop the motor first before transitioning from one operating mode to another.

You can select one of these operating modes in the Control area of the host model:

• Stop
• Open loop run
• Torque control
• Speed control
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Model

The example includes the model mcb_pmsm_operating_mode_f28379d.

You can use the model for both simulation and code generation. You can also use the open_system
command to open the Simulink® model:

open_system('mcb_pmsm_operating_mode_f28379d.slx');

Required MathWorks® Products

To simulate model:

• Motor Control Blockset™

To generate code and deploy model:

1. Motor Control Blockset™

2. Embedded Coder®

3. Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors

4. Fixed-Point Designer™ (only needed for optimized code generation)

Prerequisites

1. Obtain the motor parameters. We provide default motor parameters with the Simulink® model that
you can replace with the values from either the motor datasheet or other sources.
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However, if you have the motor control hardware, you can estimate the parameters for the motor that
you want to use, by using the Motor Control Blockset parameter estimation tool. For instructions, see
“Estimate Motor Parameters Using Motor Control Blockset Parameter Estimation Tool” on page 5-
2.

The parameter estimation tool updates the motorParam variable (in the MATLAB® workspace) with
the estimated motor parameters.

2. If you obtain the motor parameters from the datasheet or other sources, update the motor
parameters and inverter parameters in the model initialization script associated with the Simulink®
models. For instructions, see “Estimate Control Gains from Motor Parameters” on page 3-2.

If you use the parameter estimation tool, you can update the inverter parameters, but do not update
the motor parameters in the model initialization script. The script automatically extracts motor
parameters from the updated motorParam workspace variable.

Simulate Model

Follow these steps to simulate the model.

1. Open the target model included with this example.

2. Click Run on the Simulation tab to simulate the target model.

3. Open the mcb_pmsm_operating_mode_f28379d > Simulate Dashboard subsystem. You can
also use the open_system command to open the subsystem:

open_system('mcb_pmsm_operating_mode_f28379d/Simulate Dashboard');
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Instructions for Open-Loop Run Mode:

1. If the current operating mode is other than open-loop run, select Stop in the Control area to stop
the motor. Select Open loop run to start the motor.

2. Set the reference voltage and reference speed values (in per-unit) in the Voltage ref (PU) and
Speed ref (PU) fields available in the Operating Mode Variables > Open-loop mode area.

Instructions for Torque Control Mode:

1. If the current operating mode is other than torque control, select Stop in the Control area to stop
the motor. Select Torque control in the Control area.

2. Enter the value 0 (per-unit) in the Iq Reference field in the Operating Mode Variables > Motor
torque control mode area. In addition, set the speed limit of the motor using the Speed limit field.

3. Move the slider switch to Unlock position in the Operating Mode Variables > Motor torque
control mode area.

4. Enter the value 0.1 (per-unit) in the in the Iq Reference field (in the Operating Mode Variables
area) to start running the motor.

5. Open Simulation Data Inspector and select the Iq_ref_PU and Iq_fb_PU signals for monitoring.
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6. Follow steps 2 to 5 for Id Reference and monitor the Id_ref_PU and Id_fb_PU signals.

NOTE: The motor can reach high speeds if you run it under no load condition in this operating mode.
In addition, the motor will not meet the Iq reference current under no load condition in this operating
mode.

Instructions for Speed Control Mode:

1. If the current operating mode is other than speed control, select Stop in the Control area to stop
the motor. Select Speed control in the Control area.

2. Enter the value 0.5 (per-unit) in the Speed Reference field in the Operating Mode Variables >
Motor speed control mode area.

3. Open Simulation Data Inspector and select the Speed_ref_PU and Speed_fb_PU signals for
monitoring.

Instructions for Tuning Gain of Torque Controller:

1. If the current operating mode is other than torque control, select Stop in the Control area to stop
the motor. Select Torque control in the Control area.

2. Turn the slider switch to Pos lock position in the Operating Mode Variables > Motor torque
control mode area.

3. Enter the value 0.2 (per-unit) in the Id Reference field in the Operating Mode Variables area.

4. Open Simulation Data Inspector, select the Id_ref_PU and Id_fb_PU signals, and observe the step
response of these signals.

5. Tune the control gains Kp and Ki for the d-axis current controller. Perform step change to validate
the controller gains.

Instructions for Tuning Gain of Speed Controller:

1. If the current operating mode is other than speed control, select Stop in the Control area to stop
the motor. Select Speed control in the Control area.

2. Enter the value 0.5 (per-unit) in the Speed Reference field in the Operating Mode Variables >
Motor speed control mode area.

3. Enter the value 0.8 (per-unit) in the Speed Reference field.

4. Open Simulation Data Inspector, select the Speed_ref_PU and Speed_fb_PU signals, and observe
the speed step response.

5. Tune the control gains Kp and Ki for the speed controller. Perform step change to validate the
controller gains.

Generate Code and Deploy Model to Target Hardware

This section instructs you to generate code and run the FOC algorithm on the target hardware.

The example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
model is to deploy the target model to the controller hardware board. The host model uses serial

 Tune Control Parameter Gains in Hardware and Validate Plant

4-19



communication to command the model, run (and control) the motor in a selected operating mode, and
monitor the debug signals of the model.

Required Hardware

The example supports this hardware configuration. You can also use the target model name to open
the model for the corresponding hardware configuration, from the MATLAB® command prompt.

• LAUNCHXL-F28379D controller + BOOSTXL-DRV8305 inverter:
mcb_pmsm_operating_mode_f28379d

For connections related to the preceding hardware configuration, see “LAUNCHXL-F28069M and
LAUNCHXL-F28379D Configurations” on page 7-5.

Generate Code and Run Model on Target Hardware

1. Simulate the target model and observe the simulation results.

2. Complete the hardware connections.

3. The model automatically computes the ADC (or current) offset values. To disable this functionality
(enabled by default), update the value 0 to the variable inverter.ADCOffsetCalibEnable in the model
initialization script.

Alternatively, you can compute the ADC offset values and update it manually in the model
initialization scripts. For instructions, see “Run 3-Phase AC Motors in Open-Loop Control and
Calibrate ADC Offset” on page 4-6.

4. Compute the quadrature encoder index offset value and update it in the model initialization scripts
associated with the target model. For instructions, see “Quadrature Encoder Offset Calibration for
PMSM Motor” on page 4-76.

5. Open the target model for the hardware configuration that you want to use. If you want to change
the default hardware configuration settings for the model, see “Model Configuration Parameters” on
page 2-2.

6. To ensure that CPU2 is not mistakenly configured to use the board peripherals intended for CPU1,
load a sample program to CPU2 of LAUNCHXL-F28379D, for example, program that operates the
CPU2 blue LED by using GPIO31 (c28379D_cpu2_blink.slx).

NOTE:

• Do not directly switch between the open-loop run, torque control, and speed control operating
modes. Always stop the motor before changing the operating mode.

• Before you run the motor in speed control mode for the first time, run the motor in open-loop to
determine the quadratue encoder index. This helps to start the motor smoothly in the closed-loop
speed control mode.

Instructions for Open-Loop Run Mode:

1. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

2. Click the host model hyperlink in the target model to open the associated host model.

3. In the Host Serial Setup block mask of the host model, select a Port name.
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4. Click Run on the Simulation tab to run the host model.

5. Select Stop in the Control area to stop the motor.

6. Select Open loop run to start the motor.

7. Set the reference voltage and reference speed values (in per-unit) in the Voltage ref (PU) and
Speed ref (PU) fields available in the Operating Mode Variables > Open-loop mode area.

Instructions for Torque Control Mode:

1. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

2. Click the host model hyperlink in the target model to open the associated host model.

3. In the Host Serial Setup block mask of the host model, select a Port name.

4. Click Run on the Simulation tab to run the host model.

5. Select Stop in the Control area to stop the motor.

6. Enter the value 0 (per-unit) in the Id Ref (PU) and Iq Ref (PU) fields in the Operating Mode
Variables > Motor torque control mode area. In addition, set the speed limit of the motor using
the Speed limit (PU) field.

7. Select Torque control in the Control area.

8. Move the slider switch to Unlock position in the Operating Mode Variables > Motor torque
control mode area.

9. Select Iq_ref for Monitor Signal #1 and Iq_meas for Monitor Signal #2 in the Monitor area.

10. Enter the value 0.1 (per-unit) in the in the Iq Ref (PU) field (in the Operating Mode Variables
area) to start running the motor.

11. Open the scope in the host model and monitor the Iq_ref and Iq_meas current signals.

Note: The motor can reach high speeds if you run it under no load condition in this operating mode.
In addition, the motor will not meet the Iq reference current under no load condition in this operating
mode.

Instructions for Speed Control Mode:

1. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

2. Click the host model hyperlink in the target model to open the associated host model.

3. In the Host Serial Setup block mask of the host model, select a Port name.

4. Click Run on the Simulation tab to run the host model.

5. Select Stop in the Control area to stop the motor.

6. Enter the value 0.5 (per-unit) in the Speed Ref (PU) field in the Operating Mode Variables >
Motor speed control mode area.

7. Select Speed control in the Control area.
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8. Select Speed_ref for Monitor Signal #1 and Speed_meas for Monitor Signal #2 in the
Monitor area.

9. Open the scope in the host model and monitor the Speed_ref and Speed_meas output signals.

Instructions for Tuning Gain of Torque Controller:

1. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

2. Click the host model hyperlink in the target model to open the associated host model.

3. In the Host Serial Setup block mask of the host model, select a Port name.

4. Click Run on the Simulation tab to run the host model.

5. Select Stop in the Control area to stop the motor.

6. Select Torque control in the Control area.

7. Turn the slider switch to Pos lock position in the Operating Mode Variables > Motor torque
control mode area.

8. Select Id_ref for Monitor Signal #1 and Id_meas for Monitor Signal #2 in the Monitor area.

9. Enter the value 0.2 (per-unit) in the Id Ref (PU) field in the Operating Mode Variables area.

10. Open the scope and monitor the step response signal.

11. Tune the control gains Kp and Ki for the d-axis current controller.

Instructions for Tuning Gain of Speed Controller:

1. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

2. Click the host model hyperlink in the target model to open the associated host model.

3. In the Host Serial Setup block mask of the host model, select a Port name.

4. Click Run on the Simulation tab to run the host model.

5. Select Stop in the Control area to stop the motor.

6. Select Speed control in the Control area.

7. Select Speed_ref for Monitor Signal #1 and Speed_meas for Monitor Signal #2 in the
Monitor area.

8. Enter the value 0.5 (per-unit) in the Speed Ref (PU) field in the Operating Mode Variables >
Motor speed control mode area.

9. Open the scope and observe the reference and the measured speed values.

10. Enter the value 0.8 (per-unit) in the Speed Ref (PU) field.

11. Observe the speed step response in the scope.

12. Tune the control gains Kp and Ki for the speed controller.
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Instructions for Validating Plant Model:

1. Open the target model included with this example.

2. Click Run on the Simulation tab to simulate the target model.

3. Open the mcb_pmsm_operating_mode_f28379d > Simulate Dashboard subsystem.

4. If the current operating mode is other than speed control, select Stop in the Control area to stop
the motor. Select Speed control in the Control area.

5. Enter the value 0.2 (per-unit) in the Speed Reference field in the Operating Mode Variables >
Motor speed control mode area.

6. Enter the value 0.5 (per-unit) in the Speed Reference field.

7. Open Simulation Data Inspector, select the Speed_ref_PU and Speed_fb_PU signals, and observe
the speed step response.

8. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

9. Click the host model hyperlink in the target model to open the associated host model. You can
also use the open_system command to open the host model:

open_system('mcb_host_mode_control.slx');
%
% *10.* In the Host Serial Setup block mask of the host model, select a
% *Port name*.
%
% *11.* Click *Run* on the *Simulation* tab to run the host model.
%
% *12.* Select *Stop* in the *Control* area of the host model to ensure that
% the motor is not running.
%
% *13.* Select *Speed control* in the *Control* area.
%
% *14.* Select *Speed_ref* for *Monitor Signal #1* and *Speed_meas* for *Monitor
% Signal #2* in the *Monitor* area.
%
% *15.* Enter the value |0.2| (per-unit) in the *Speed Ref (PU)* field in the
% *Operating Mode Variables > Motor speed control mode* area.
%
% *16.* Open the scope and observe the reference and the measured speed
% values.
%
% *17.* Enter the value |0.5| (per-unit) in the *Speed Ref (PU)* field.
%
% *18.* Observe the speed step response in the scope.
%
% *19.* Compare the speed step responses obtained in steps 7 (with
% simulation) and 18 (with code generation).
%
% *NOTE:* In the *Control loop gains* area, you must enter the gain values
% that can be represented by the datatype defined in the model
% initialization script.
%
% For details about the serial communication between the host and target
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% models, see <docid:mcb_gs#mw_7d703f4b-0b29-4ec7-a42b-0b300f580ccc
% Communication between Host and Target>.
%

4 Implement Motor Speed Control by Using Field-Oriented Control (FOC)

4-24



Tune PI Controllers Using Field Oriented Control Autotuner
This example computes the gain values of the PI controllers within the speed and current controllers
by using the Field Oriented Control Autotuner block. For details about field-oriented control, see
“Field-Oriented Control (FOC)” on page 4-2.

The example supports simulation only. When you simulate the example, the model uses the crude
values of gains for the PI controllers to achieve the steady state of speed-control operation.

The model begins tuning only in the steady state. It introduces disturbances depending on the
controller goals (bandwidth and phase margin), in the controller output. The model uses the system
response to the disturbances, to calculate the optimal controller gain.

Model

The example includes the model mcb_pmsm_foc_autotuner.

You can use this model only for simulation. You can also use the open_system command to open the
Simulink® model:

open_system('mcb_pmsm_foc_autotuner.slx');

Required MathWorks® Products for Simulation

• Motor Control Blockset™
• Simulink Control Design™
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Prerequisites

1. Obtain the motor parameters. We provide default motor parameters with the Simulink® model that
you can replace with the values from either the motor datasheet or other sources.

However, if you have the motor control hardware, you can estimate the parameters for the motor that
you want to use, by using the Motor Control Blockset parameter estimation tool. For instructions, see
“Estimate Motor Parameters Using Motor Control Blockset Parameter Estimation Tool” on page 5-
2.

The parameter estimation tool updates the motorParam variable (in the MATLAB® workspace) with
the estimated motor parameters.

2. If you obtain the motor parameters from the datasheet or other sources, update the motor
parameters and inverter parameters in the model initialization script associated with the Simulink®
models. For instructions, see “Estimate Control Gains from Motor Parameters” on page 3-2.

If you use the parameter estimation tool, you can update the inverter parameters, but do not update
the motor parameters in the model initialization script. The script automatically extracts motor
parameters from the updated motorParam workspace variable.

Note: In addition to the preceding products, you also need these products to use the parameter
estimation tool:

• Embedded Coder®

• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors

Simulate and Run Model to Compute PI Controller Gains

1. Open the target model.

2. Click Run on the Simulation tab to simulate the target model.

3. Observe the computed PI controller gain values in the Display blocks available in the
PI_Params_Display_and_Logging subsystem.

4. Update any target model with these gain values so that it brings the motor to a steady-speed state
quickly.
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Field-Oriented Control of PMSM Using Hall Sensor
This example implements the field-oriented control (FOC) technique to control the speed of a three-
phase permanent magnet synchronous motor (PMSM). The FOC algorithm requires rotor position
feedback, which is obtained by a Hall sensor. For details about FOC, see “Field-Oriented Control
(FOC)” on page 4-2.

This example uses the Hall sensor to measure the rotor position. A Hall effect sensor varies its output
voltage based on the strength of the applied magnetic field. A PMSM consists of three Hall sensors
located electrically 120 degrees apart. A PMSM with this setup can provide six valid combinations of
binary states (for example, 001,010,011,100,101, and 110). The sensor provides the angular position
of the rotor in the multiples of 60 degrees, which the controller uses to compute the angular velocity.
The controller can then use the angular velocity to compute an accurate angular position of the rotor.

Models

The example includes these models:

• mcb_pmsm_foc_hall_f28069m

• mcb_pmsm_foc_hall_f28379d

You can use these models for both simulation and code generation. You can also use the open_system
command to open the Simulink® model. For example, use this command for a F28069M based
controller:

open_system('mcb_pmsm_foc_hall_f28069m.slx');
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For the model names that you can use for different hardware configurations, see the Required
Hardware topic in the Generate Code and Deploy Model to Target Hardware section.

Required MathWorks® Products

To simulate model:

1. For the model: mcb_pmsm_foc_hall_f28069m

• Motor Control Blockset™
• Fixed-Point Designer™

2. For the model: mcb_pmsm_foc_hall_f28379d

• Motor Control Blockset™

To generate code and deploy model:

1. For the model: mcb_pmsm_foc_hall_f28069m

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™

2. For the model: mcb_pmsm_foc_hall_f28379d

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™ (only needed for optimized code generation)

Prerequisites

1. Obtain the motor parameters. We provide default motor parameters with the Simulink® model that
you can replace with the values from either the motor datasheet or other sources.
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However, if you have the motor control hardware, you can estimate the parameters for the motor that
you want to use, by using the Motor Control Blockset parameter estimation tool. For instructions, see
“Estimate Motor Parameters Using Motor Control Blockset Parameter Estimation Tool” on page 5-
2.

The parameter estimation tool updates the motorParam variable (in the MATLAB® workspace) with
the estimated motor parameters.

2. If you obtain the motor parameters from the datasheet or other sources, update the motor
parameters and inverter parameters in the model initialization script associated with the Simulink®
models. For instructions, see “Estimate Control Gains from Motor Parameters” on page 3-2.

If you use the parameter estimation tool, you can update the inverter parameters, but do not update
the motor parameters in the model initialization script. The script automatically extracts motor
parameters from the updated motorParam workspace variable.

Simulate Model

This example supports simulation. Follow these steps to simulate the model.

1. Open a model included with this example.

2. To simulate the model, click Run on the Simulation tab.

3. To view and analyze the simulation results, click Data Inspector on the Simulation tab.

Generate Code and Deploy Model to Target Hardware

This section instructs you to generate code and run the FOC algorithm on the target hardware.

This example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
model is to deploy the target model to the controller hardware board. The host model uses serial
communication to command the target Simulink® model and run the motor in a closed-loop control.

Required Hardware

This example supports these hardware configurations. You can also use the target model name to
open the model for the corresponding hardware configuration, from the MATLAB® command prompt.

• F28069M controller card + DRV8312-69M-KIT inverter: mcb_pmsm_foc_hall_f28069m

For connections related to the preceding hardware configuration, see “F28069 control card
configuration” on page 7-2.

• LAUNCHXL-F28069M controller + BOOSTXL-DRV8305 inverter: mcb_pmsm_foc_hall_f28069m

• LAUNCHXL-F28379D controller + (BOOSTXL-DRV8305 or BOOSTXL-3PHGANINV) inverter:
mcb_pmsm_foc_hall_f28379d

For connections related to the preceding hardware configurations, see “LAUNCHXL-F28069M and
LAUNCHXL-F28379D Configurations” on page 7-5.

Generate Code and Run Model on Target Hardware

1. Simulate the target model and observe the simulation results.
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2. Complete the hardware connections.

3. The model automatically computes the Analog-to-Digital Converter (ADC) or current offset values.
To disable this functionality (enabled by default), update the value 0 to the variable
inverter.ADCOffsetCalibEnable in the model initialization script.

Alternatively, you can compute the ADC offset values and update it manually in the model
initialization scripts. For instructions, see “Run 3-Phase AC Motors in Open-Loop Control and
Calibrate ADC Offset” on page 4-6.

4. Compute the Hall sensor offset value and update it in the model initialization script associated with
the target model. For instructions, see “Hall Offset Calibration for PMSM Motor” on page 4-66.

5. Open the target model for the hardware configuration that you want to use. If you want to change
the default hardware configuration settings for the model, see “Model Configuration Parameters” on
page 2-2.

6. Load a sample program to CPU2 of LAUNCHXL-F28379D, for example, program that operates the
CPU2 blue LED by using GPIO31 (c28379D_cpu2_blink.slx), to ensure that CPU2 is not mistakenly
configured to use the board peripherals intended for CPU1.

7. Click Build, Deploy & Start on the Hardware tab to deploy the model to the hardware.

8. In the target model, click the host model hyperlink to open the associated host model. You can
also use the open_system command to open the host model. For example, use this command for a
F28069M based controller:

open_system('mcb_host_model_f28069m.slx');
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For details about the serial communication between the host and target models, see “Host-Target
Communication” on page 6-2.

9. In the Host Serial Setup block mask of the host model, select a Port name.

10. Update the Reference Speed value in the host model.

11. Click Run on the Simulation tab to run the host model.

12. Change the position of the Start / Stop Motor switch to On, to start running the motor.

NOTE: When you run this example on the hardware at a low Reference Speed, due to a known issue,
the PMSM may not follow the low Reference Speed.

13. Observe the debug signals from the RX subsystem, in the Time Scope of host model.

NOTE: If you are using a F28379D based controller, you can also select the debug signals that you
want to monitor.
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Field-Oriented Control of PMSM Using Quadrature Encoder
This example implements the field-oriented control (FOC) technique to control the speed of a three-
phase permanent magnet synchronous motor (PMSM). The FOC algorithm requires rotor position
feedback, which is obtained by a quadrature encoder sensor. For details about FOC, see “Field-
Oriented Control (FOC)” on page 4-2.

This example uses the quadrature encoder sensor to measure the rotor position. The quadrature
encoder sensor consists of a disk with two tracks or channels that are coded 90 electrical degrees out
of phase. This creates two pulses (A and B) that have a phase difference of 90 degrees and an index
pulse (I). Therefore, the controller uses the phase relationship between A and B channels and the
transition of channel states to determine the direction of rotation of the motor.

Models

The example includes these models:

• mcb_pmsm_foc_qep_f28069m

• mcb_pmsm_foc_qep_f28069LaunchPad

• mcb_pmsm_foc_qep_f28379d

You can use these models for both simulation and code generation. You can also use the open_system
command to open the Simulink® models. For example, use this command for a F28069M based
controller.

open_system('mcb_pmsm_foc_qep_f28069m.slx');
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For the model names that you can use for different hardware configurations, see the Required
Hardware topic in the Generate Code and Deploy Model to Target Hardware section.

Required MathWorks® Products

To simulate model:

1. For the models: mcb_pmsm_foc_qep_f28069m and mcb_pmsm_foc_qep_f28069LaunchPad

• Motor Control Blockset™
• Fixed-Point Designer™

2. For the model mcb_pmsm_foc_qep_f28379d

• Motor Control Blockset™

To generate code and deploy model:

1. For the models: mcb_pmsm_foc_qep_f28069m and mcb_pmsm_foc_qep_f28069LaunchPad

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™

2. For the model mcb_pmsm_foc_qep_f28379d

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™ (only needed for optimized code generation)
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Prerequisites

1. Obtain the motor parameters. We provide default motor parameters with the Simulink® model that
you can replace with the values from either the motor datasheet or other sources.

However, if you have the motor control hardware, you can estimate the parameters for the motor that
you want to use, by using the Motor Control Blockset parameter estimation tool. For instructions, see
“Estimate Motor Parameters Using Motor Control Blockset Parameter Estimation Tool” on page 5-
2.

The parameter estimation tool updates the motorParam variable (in the MATLAB® workspace) with
the estimated motor parameters.

2. If you obtain the motor parameters from the datasheet or other sources, update the motor
parameters and inverter parameters in the model initialization script associated with the Simulink®
models. For instructions, see “Estimate Control Gains from Motor Parameters” on page 3-2.

If you use the parameter estimation tool, you can update the inverter parameters, but do not update
the motor parameters in the model initialization script. The script automatically extracts motor
parameters from the updated motorParam workspace variable.

Simulate Model

This example supports simulation. Follow these steps to simulate the model.

1. Open a model included with this example.

2. Click Run on the Simulation tab to simulate the model.

3. Click Data Inspector on the Simulation tab to view and analyze the simulation results.

Generate Code and Deploy Model to Target Hardware

This section instructs you to generate code and run the FOC algorithm on the target hardware.

This example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
model is to deploy the target model to the controller hardware board. The host model uses serial
communication to command the target Simulink® model and run the motor in a closed-loop control.

Required Hardware

This example supports these hardware configurations. You can also use the target model name to
open the model for the corresponding hardware configuration, from the MATLAB® command prompt.

• F28069M control card + DRV8312-69M-KIT inverter: mcb_pmsm_foc_qep_f28069m

For connections related to the preceding hardware configuration, see “F28069 control card
configuration” on page 7-2.

• LAUNCHXL-F28069M controller + BOOSTXL-DRV8305 inverter:
mcb_pmsm_foc_qep_f28069LaunchPad

• LAUNCHXL-F28379D controller + (BOOSTXL-DRV8305 or BOOSTXL-3PHGANINV) inverter:
mcb_pmsm_foc_qep_f28379d
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NOTE: When using BOOSTXL-3PHGANINV inverter, ensure that proper insulation is available
between bottom layer of BOOSTXL-3PHGANINV and the LAUNCHXL board.

For connections related to the preceding hardware configurations, see “LAUNCHXL-F28069M and
LAUNCHXL-F28379D Configurations” on page 7-5.

Generate Code and Run Model on Target Hardware

1. Simulate the target model and observe the simulation results.

2. Complete the hardware connections.

3. The model automatically computes the ADC (or current) offset values. To disable this functionality
(enabled by default), update the value 0 to the variable inverter.ADCOffsetCalibEnable in the model
initialization script.

Alternatively, you can compute the ADC offset values and update it manually in the model
initialization scripts. For instructions, see “Run 3-Phase AC Motors in Open-Loop Control and
Calibrate ADC Offset” on page 4-6.

4. Compute the quadrature encoder index offset value and update it in the model initialization scripts
associated with the target model. For instructions, see “Quadrature Encoder Offset Calibration for
PMSM Motor” on page 4-76.

5. Open the target model for the hardware configuration that you want to use. If you want to change
the default hardware configuration settings for the model, see “Model Configuration Parameters” on
page 2-2.

6. Load a sample program to CPU2 of LAUNCHXL-F28379D, for example, program that operates the
CPU2 blue LED by using GPIO31 (c28379D_cpu2_blink.slx), to ensure that CPU2 is not mistakenly
configured to use the board peripherals intended for CPU1.

7. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

8. Click the host model hyperlink in the target model to open the associated host model. You can
also use the open_system command to open the host model. For example, use this command for a
F28069M based controller.

open_system('mcb_host_model_f28069m.slx');
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For details about the serial communication between the host and target models, see “Host-Target
Communication” on page 6-2.

9. In the Host Serial Setup block mask of the host model, select a Port name.

10. Update the Reference Speed value in the host model.

11. Click Run on the Simulation tab to run the host model.

12. Change the position of the Start / Stop Motor switch to On, to start running the motor.

13. Observe the debug signals from the RX subsystem, in the Time Scope of host model.

Note: If you are using a F28379D based controller, you can also select the debug signals that you
want to monitor.
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Field-Weakening Control (with MTPA) of PMSM
This example implements the field-oriented control (FOC) technique to control the torque and speed
of a three-phase permanent magnet synchronous motor (PMSM). The FOC algorithm requires rotor
position feedback, which is obtained by a quadrature encoder sensor. For details about FOC, see
“Field-Oriented Control (FOC)” on page 4-2.

Field-Weakening Control

When you use the FOC algorithm to run a motor with rated flux, the maximum speed is limited by the
stator voltages, rated current, and back emf. This speed is called the base speed. Beyond this speed,
the operation of the machine is complex because the back emf is more than the supply voltage.
However, if you set the d-axis stator current (Id) to a negative value, the rotor flux linkage reduces,
which allows the motor to run above the base speed. This operation is known as field-weakening
control of the motor.

Depending upon the connected load and rated current of the machine, the reference d-axis current
( ) in the field-weakening control also limits the reference q-axis current ( ), and therefore, limits
the torque output. Therefore, the motor operates in the constant torque region until the base speed.
It operates in the constant power region with a limited torque above the base speed, as illustrated in
the preceding figure.

The computations for the reference current  depend on the motor and inverter parameters.

Note:
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• For some surface PMSMs, (depending upon the parameters) it may not be possible to achieve
higher speeds at the rated current. To achieve higher speeds, you need to overload the motor with
maximum currents that are higher than the rated current (if the thermal conditions of the
machine are within the permissible limits).

• When you operate the motor above the base speed, we recommend that you monitor the
temperature of the motor. During motor operation, if the motor temperature rises beyond the
temperature recommended by the manufacturer, turn-off the motor for safety reasons.

• When you operate the motor above the base speed, we recommend that you increment the speed
reference in small steps, to avoid the dynamics of field weakening that can make some systems
unstable.

Maximum Torque Per Ampere (MTPA)

For the interior PMSMs, the saliency in the magnetic circuit of rotor results in higher  ratio (greater
than 1). This produces reluctance torque in the rotor (in addition to the existing electromagnetic
torque). For more information, see MTPA Control Reference.

Therefore, you can operate the machine at an optimum combination of  and , and obtain a higher

torque for the same stator current, .

This increases the efficiency of the machine, because the stator current losses are minimized. The
algorithm that you use to generate the reference  and  currents for producing maximum torque in
the machine, is called Maximum Torque Per Ampere (MTPA).
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For an Interior PMSM (IPMSM), this example computes the reference  and  currents using the
MTPA method until the base speed. For a Surface PMSM (SPMSM), the example achieves MTPA
operation by using a zero d-axis reference current, until the base speed.

To operate the motor above the base speed, this example computes the reference  and  for MTPA
and field-weakening control, depending upon the motor type. For a Surface PMSM, Constant Voltage
Constant Power (CVCP) control method is used. For an Interior PMSM, Voltage and Current Limited
Maximum Torque (VCLMT) control method is used.

For information related to MTPA Control Reference block, see MTPA Control Reference.

Target Communication

For hardware implementation, this example uses a host and a target model. The host model, running
on the host computer, communicates with the target model deployed to the hardware connected to
the motor. The host model uses serial communication to command the target model and run the
motor in a closed-loop control.

Models

This example uses multiple models for these hardware configurations:

Speed control of PMSM with field-weakening and MTPA:
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• mcb_pmsm_fwc_qep_f28069LaunchPad

• mcb_pmsm_fwc_qep_f28379d

Torque control of PMSM with MTPA:

• mcb_pmsm_mtpa_qep_f28069LaunchPad

• mcb_pmsm_mtpa_qep_f28379d

You can use these models for both simulation and code generation. You can also use the open_system
command to open the Simulink® models. For example, use this command for a F28069M based
controller:

open_system('mcb_pmsm_fwc_qep_f28069LaunchPad.slx');

Required MathWorks® Products

To simulate model:

1. For the models: mcb_pmsm_fwc_qep_f28069LaunchPad and
mcb_pmsm_mtpa_qep_f28069LaunchPad

• Motor Control Blockset™
• Fixed-Point Designer™

2. For the models: mcb_pmsm_fwc_qep_f28379d and mcb_pmsm_mtpa_qep_f28379d

• Motor Control Blockset™

To generate code and deploy model:
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1. For the models: mcb_pmsm_fwc_qep_f28069LaunchPad and
mcb_pmsm_mtpa_qep_f28069LaunchPad

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™

2. For the models: mcb_pmsm_fwc_qep_f28379d and mcb_pmsm_mtpa_qep_f28379d

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™ (only needed for optimized code generation)

Prerequisites

1. Obtain the motor parameters. We provide default motor parameters with the Simulink® model that
you can replace with the values from either the motor datasheet or other sources.

However, if you have the motor control hardware, you can estimate the parameters for the motor that
you want to use, by using the Motor Control Blockset parameter estimation tool. For instructions, see
“Estimate Motor Parameters Using Motor Control Blockset Parameter Estimation Tool” on page 5-
2.

The parameter estimation tool updates the motorParam variable (in the MATLAB® workspace) with
the estimated motor parameters.

2. If you obtain the motor parameters from the datasheet or other sources, update the motor,
inverter, and position sensor calibration parameters in the model initialization script associated with
the Simulink® models. For instructions, see “Estimate Control Gains from Motor Parameters” on
page 3-2.

If you use the parameter estimation tool, you can update the inverter and position sensor calibration
parameters, but do not update the motor parameters in the model initialization script. The script
automatically extracts motor parameters from the updated motorParam workspace variable.

Simulate (Speed Control and Torque Control) Models

This example supports simulation. Follow these steps to simulate the model.

1. Open a model included with this example.

2. Click Run on the Simulation tab to simulate the model.

3. Click Data Inspector on the Simulation tab to view and analyze the simulation results.

Analyze simulation results for Speed Control Model

The model uses the per-unit system to represent speed, currents, voltages, torque, and power. Type
PU System at the workspace to see the conversion of one per-unit value into SI units for these
quantities.
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Observe the dynamics of the system for the speed and current controllers. In addition, notice the
negative Id currents for motor operation above the base speed.

Note:

• For some surface PMSMs, (depending upon the parameters) it may not be possible to achieve
higher speeds at the rated current. To achieve higher speeds, you need to overload the motor with
maximum currents that are higher than the rated current (if the thermal conditions of the
machine are within the permissible limits).

• When you operate the motor above the base speed, we recommend that you monitor the
temperature of motor. During motor operation, if the motor temperature rises beyond the
temperature recommended by the manufacturer, turn-off the motor for safety reasons.

• When you operate the motor above the base speed, we recommend that you increment the speed
reference in small steps, to avoid the dynamics of field weakening that can make some systems
unstable.
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Analyze simulation results for Torque Control Model

Run simulation with the Id and Iq reference currents generated by these three methods:

1. Generate reference currents by using the MTPA Control Reference Block.

2. Generate the MTPA reference currents manually by using the Vector Control Reference Block.

3. Generate the Control Reference without MTPA.

The first method uses mathematical computations to determine the reference currents Id and Iq,
after assuming linear inductances.

Use the second method to manually generate the MTPA look-up tables for motors with non-linear
inductances. You can illustrate this with the Id and Iq references generated by sweeping the torque
angle between +(π/2) to -(π/2).

Use the last method to obtain the reference currents without the MTPA algorithm.

You can compare the torque and power generated by these three methods in the data inspector.
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In the preceding example, you can notice that the electrical torque generated using MTPA is 0.34PU
whereas electrical torque generated without MTPA is 0.27PU. You can also notice that with a varying
torque angle, the maximum generated torque matches the torque produced by MTPA. The negative d-
axis current indicates that the MTPA utilizes the reluctance torque for interior PMSM.

NOTE: If you are working with Surface PMSM, change the Type of motor parameter from Interior
PMSM to Surface PMSM, in the MTPA Control Reference block located at the location: "Torque
Control\MTPA_Reference\MTPA Control Reference."

Generate Code and Deploy Model to Target Hardware

This section instructs you to generate code and run the FOC algorithm on the target hardware.

This example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
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model is to deploy the target model to the controller hardware board. The host model uses serial
communication to command the target Simulink® model and run the motor in a closed-loop control.

Required Hardware

This example supports these hardware configurations. You can also use the target model name to
open the model for the corresponding hardware configuration, from the MATLAB® command prompt.

• LAUNCHXL-F28069M controller + BOOSTXL-DRV8305 inverter:
mcb_pmsm_fwc_qep_f28069LaunchPad and mcb_pmsm_mtpa_qep_f28069LaunchPad

• LAUNCHXL-F28379D controller + BOOSTXL-DRV8305 inverter: mcb_pmsm_fwc_qep_f28379d
and mcb_pmsm_mtpa_qep_f28379d

For connections related to the preceding hardware configurations, see “LAUNCHXL-F28069M and
LAUNCHXL-F28379D Configurations” on page 7-5.

Run Models to implement speed and torque control with field-weakening and MTPA

1. Simulate the model and analyze the simulation results by using the preceding section.

2. Complete the hardware connections.

3. The torque control model requires an Interior PMSM with QEP Sensor, driven by an external
dynamometer with speed control (that uses the speed control model).

4. The model automatically computes the ADC (or current) offset values. To disable this functionality
(enabled by default), update the value zero to the variable inverter.ADCOffsetCalibEnable in the
model initialization script.

Alternatively, you can compute the ADC offset values and update it manually in the model
initialization scripts. For instructions, see “Run 3-Phase AC Motors in Open-Loop Control and
Calibrate ADC Offset” on page 4-6.

5. Compute the quadrature encoder index offset value and update it in the model initialization scripts
associated with the target model. For instructions, see “Quadrature Encoder Offset Calibration for
PMSM Motor” on page 4-76.

6. Open the target model for the hardware configuration that you want to use. If you want to change
the default hardware configuration settings for the target model, see “Model Configuration
Parameters” on page 2-2.

7. Load a sample program to CPU2 of LAUNCHXL-F28379D, for example, program that operates the
CPU2 blue LED by using GPIO31 (c28379D_cpu2_blink.slx), to ensure that CPU2 is not mistakenly
configured to use the board peripherals intended for CPU1.

8. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

9. Click the host model hyperlink in the target model to open the associated host model. You can
also use the open_system command to open the host model. For example, use this command for speed
control implementation:

open_system('mcb_pmsm_fwc_host_model.slx');
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For details about the serial communication between the host and target models, see “Host-Target
Communication” on page 6-2.

10. In the Host Serial Setup block mask of the host model, select a Port name.

11. In the Speed control model, update the Reference Speed (RPM) block value. In the Torque control
model, update the current request using Imag Reference block.

12. Click Run on the Simulation tab to run the host model.

13. Change the position of the Start / Stop Motor switch to On, to start and stop running the motor.

14. Enter different reference speeds (or currents) and observe the debug signals from the RX
subsystem, in the Time Scope of host model.

Note

• If the position offset is incorrect, this example can lead to excessive currents in the motor. To
avoid this, ensure that the position offset is correctly computed and updated in the workspace
variable: pmsm.PositionOffset.

• When you operate the motor above the base speed, we recommend that you monitor the
temperature of motor. During motor operation, if the motor temperature rises beyond the
temperature recommended by the manufacturer, turn-off the motor for safety reasons.

• When you operate the motor above the base speed, we recommend that you increment the speed
reference in small steps, to avoid the dynamics of field weakening that can make some systems
unstable.
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Sensorless Field-Oriented Control of PMSM
This example implements the field-oriented control (FOC) technique to control the speed of a three-
phase permanent magnet synchronous motor (PMSM). For details about FOC, see “Field-Oriented
Control (FOC)” on page 4-2.

This example uses the sensorless position estimation technique. You can select either the sliding
mode observer or flux observer to estimate the position feedback for the FOC algorithm used in the
example.

The Sliding Mode Observer (SMO) block generates a sliding motion on the error between the
measured and estimated position. The block produces an estimated value that is closely proportional

to the measured position. The block uses stator voltages  and currents  as inputs
and estimates the electromotive force (emf) of the motor model. It uses the emf to further estimate

the rotor position and rotor speed. The Flux Observer block uses identical inputs  to
estimate the stator flux, generated torque, and the rotor position.

If you use flux observer, the example can run both PMSM and brushless DC (BLDC) motors.

The sensorless observers and algorithms have known limitations regarding motor operations beyond
the base speed. We recommend that you use the sensorless examples for operations upto base speed
only.

Models

The example includes these models:

• mcb_pmsm_foc_sensorless_f28069MLaunchPad

• mcb_pmsm_foc_sensorless_f28379d

You can use these models for both simulation and code generation. You can also use the open_system
command to open a model. For example, use this command for a F28069M based controller:

open_system('mcb_pmsm_foc_sensorless_f28069MLaunchPad.slx');
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For the model names that you can use for different hardware configurations, see the Required
Hardware topic in the Generate Code and Deploy Model to Target Hardware section.

Required MathWorks® Products

To simulate model:

1. For the model: mcb_pmsm_foc_sensorless_f28069MLaunchPad

• Motor Control Blockset™
• Fixed-Point Designer™

2. For the model: mcb_pmsm_foc_sensorless_f28379d

• Motor Control Blockset™

To generate code and deploy model:

1. For the model: mcb_pmsm_foc_sensorless_f28069MLaunchPad

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™

2. For the model: mcb_pmsm_foc_sensorless_f28379d

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™ (only needed for optimized code generation)
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Prerequisites

1. Obtain the motor parameters. We provide default motor parameters with the Simulink® model that
you can replace with the values from either the motor datasheet or other sources.

However, if you have the motor control hardware, you can estimate the parameters for the motor that
you want to use, by using the Motor Control Blockset parameter estimation tool. For instructions , see
“Estimate Motor Parameters Using Motor Control Blockset Parameter Estimation Tool” on page 5-
2.

The parameter estimation tool updates the motorParam variable (in the MATLAB® workspace) with
the estimated motor parameters.

2. If you obtain the motor parameters from the datasheet or other sources, update the motor
parameters and inverter parameters in the model initialization script associated with the Simulink®
models. For instructions, see “Estimate Control Gains from Motor Parameters” on page 3-2.

If you use the parameter estimation tool, you can update the inverter parameters, but do not update
the motor parameters in the model initialization script. The script automatically extracts motor
parameters from the updated motorParam workspace variable.

Sliding Mode Observer parameters require tuning if you are using Sliding Mode Observer with the
motor parameters estimated using the parameter estimation tool.

Simulate Model

This example supports simulation. Follow these steps to simulate the model.

1. Open a model included with this example.

2. To simulate the model, click Run on the Simulation tab.

3. To view and analyze the simulation results, click Data Inspector on the Simulation tab.

Generate Code and Deploy Model to Target Hardware

This section instructs you to generate code and run the FOC algorithm on the target hardware.

This example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
model is to deploy the target model to the controller hardware board. The host model uses serial
communication to command the target Simulink® model and run the motor in a closed-loop control.

Required Hardware

This example supports these hardware configurations. You can also use the target model name to
open the model for the corresponding hardware configuration, from the MATLAB® command prompt.

• LAUNCHXL-F28069M controller + BOOSTXL-DRV8305 inverter:
mcb_pmsm_foc_sensorless_f28069MLaunchPad

• LAUNCHXL-F28379D controller + (BOOSTXL-DRV8305 or BOOSTXL-3PHGANINV) inverter:
mcb_pmsm_foc_sensorless_f28379d

For connections related to the preceding hardware configurations, see “LAUNCHXL-F28069M and
LAUNCHXL-F28379D Configurations” on page 7-5.
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Generate Code and Run Model on Target Hardware

1. Simulate the target model and observe the simulation results.

2. Complete the hardware connections.

3. The model automatically computes the Analog-to-Digital Converter (ADC) or current offset values.
To disable this functionality (enabled by default), update the value 0 to the variable
inverter.ADCOffsetCalibEnable in the model initialization script.

Alternatively, you can compute the ADC offset values and update it manually in the model
initialization scripts. For instructions, see “Run 3-Phase AC Motors in Open-Loop Control and
Calibrate ADC Offset” on page 4-6.

4. Open the target model for the hardware configuration that you want to use. If you want to change
the default hardware configuration settings for the model, see “Model Configuration Parameters” on
page 2-2.

5. Load a sample program to CPU2 of LAUNCHXL-F28379D, for example, program that operates the
CPU2 blue LED using GPIO31 (c28379D_cpu2_blink.slx), to ensure that CPU2 is not mistakenly
configured to use the board peripherals intended for CPU1.

6. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

7. In the target model, click the host model hyperlink to open the associated host model. You can
also use the open_system command to open the host model. For example, use this command for a
F28069M based controller:

open_system('mcb_host_model_f28069m.slx');
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For details about the serial communication between the host and target models, see “Host-Target
Communication” on page 6-2.

8. In the Host Serial Setup block mask of the host model, select a Port name.

9. Update the Reference Speed value in the host model.

NOTE: Before you run the motor at the required Reference Speed (by using either Sliding Mode
Observer or Flux Observer), start running the motor at 0.1 x pmsm.N_base speed by using open-loop
control. Then transition to closed-loop control by increasing the speed to 0.25 x pmsm.N_base
(where, pmsm.N_base is the MATLAB workspace variable for base speed of the motor).

10. Click Run on the Simulation tab to run the host model.

11. Change the position of the Start / Stop Motor switch to On, to start running the motor in the
open-loop condition (by default, the motor spins at 10% of base speed).

NOTE: Do not run the motor (using this example) in the open-loop condition for a long time duration.
The motor may draw high currents and produce excessive heat.

We designed the open-loop control to run the motor with a Reference Speed that is less than or equal
to 10% of base speed.

When you run this example on the hardware at a low Reference Speed, due to a known issue, the
PMSM may not follow the low Reference Speed.
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12. Increase the motor Reference Speed beyond 10% of base speed to switch from open-loop to
closed-loop control.

NOTE: To change the motor's direction of rotation, reduce the motor Reference Speed to a value less
than 10% of the base speed. This brings the motor back to open-loop condition. Change the direction
of rotation but keep the Reference Speed magnitude as constant. Then transition to the closed-loop
condition.

13. Observe the debug signals from the RX subsystem, in the Time Scope of host model.

NOTE:

• A high reference speed and a high reference torque can affect the Sliding Mode Observer block
performance.

• If you are using a F28379D based controller, you can also select the debug signals that you want
to monitor.

Other Things to Try

You can use SoC Blockset™ to implement a sensorless closed-loop motor control application that
addresses challenges related to ADC-PWM synchronization, controller response, and studying
different PWM settings. For details, see “Integrate MCU Scheduling and Peripherals in Motor Control
Application” on page 4-132.

You can also use SoC Blockset™ to develop a sensorless real-time motor control application that
utilizes multiple processor cores to obtain design modularity, improved controller performance, and
other design goals. For details, see “Partition Motor Control for Multiprocessor MCUs” on page 4-
141.
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Use Motor Control Blockset to Generate Code for Custom
Target

This example shows how to use Motor Control Blockset™ with any processor.

The example shows you how to simulate and generate code from a system model configured for a
Texas Instruments™ C2000™ F28069M processor. The system model uses a Field-Oriented Control
(FOC) implementation that you can run on any processor. The algorithm part of the model is
separated from the driver layer by using a reference model that you can deploy on any device.

Required Products

• MATLAB®
• Simulink®
• MATLAB® Coder™
• Simulink® Coder™
• Motor Control Blockset™
• Embedded Coder®
• Fixed-Point Designer™ (only for serial communication)

Verify Algorithm Behavior by Using System Simulation

This section shows you how to verify the controller in a closed-loop system simulation.

The system model mcb_pmsm_foc_system test bench consists of the test inputs, an embedded
processor, power electronics, and motor hardware. To see the signals, use the Data Inspector button
on the Simulation tab of the Simulink toolstrip. You can use this model to test the controller and
explore its expected behavior.

Use this command to open the model.

open_system('mcb_pmsm_foc_system.slx');
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NOTE: This model supports only floating-point computations.

Run the simulation and see the logged speed reference (Speed_Reference) and measured motor
speed (Speed_Motor) signals in the data inspector.
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Model Architecture

This section explains the model architecture and includes these sub-sections:

• Data Specification

• Controller Partitioning from Test Bench

• Controller Scheduling

The model architecture facilitates system simulation and algorithmic code generation.

Data Specification

A data definition file creates the data needed for simulation and code generation. This data file is
automatically run within the InitFcn callback of the system test bench model.

edit('mcb_algorithm_workflow_data.m')

Another data file mcb_pmsm_foc_qep_f28069LaunchPad_data.m defines the motor and inverter
parameters.
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Update the motor and inverter parameters for your hardware configuration in this file. For example,
update the motor parameters in the function mcb_SetPMSMMotorParameters that is called from this
file.

Controller Partitioning from Test Bench

Within the system test bench model, the embedded processor is modeled as a combination of the
peripherals and the controller software. The block mcb_pmsm_foc_system/Embedded Processor/
Serial Receive implements the reference inputs for simulation.

open_system('mcb_pmsm_foc_system/Embedded Processor');

In this example, a separate model includes the controller software. The controller software model
contains the Speed Control and Current Control subsystems of the FOC algorithm.

open_system('mcb_pmsm_foc.slx');
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Controller Scheduling

The primary control method is field-oriented control. The controller has a low rate outer loop that
controls the speed. It also has a higher rate inner loop that controls the current. Speed Control
subsystem implements the PI controller for speed. The Current Control subsystem converts the ADC
signals (or the current feedback) to per-unit values and passes them to the core controller algorithm.
In addition, it also measures the speed and position values from the quardature encoder pulses.

The controller algorithm calculates the voltages. The voltages are then converted to a driver signal.
The speed controller outer loop executes after each instance of the time period used to run the
current control loop. You can view the variables that specify the speed and current control loop
sample times by using these commands:

fprintf('Current loop sample time = %f seconds\n', Ts)

fprintf('Speed loop sample time  = %f seconds\n', Ts_speed)

Generate C Code to Integrate Controller into Embedded Application

This section shows you how to generate and visually inspect the C code function for the controller.

The generated code consists of three generated global functions:

• void Controller_Init(void): This function should be called to perform initialization routines.

• void Current_Controller(void): This function implements the current controller and should be
called from a task running at 50e-6 seconds.

• void Speed_Controller(void): This function implements the speed controller and should be called
from a task running at 500e-6 seconds.

To specify the function prototype, see Configure C Code Generation for Model Entry-Point Functions.

 Use Motor Control Blockset to Generate Code for Custom Target

4-59

https://www.mathworks.com/help/rtw/ug/configure-c-code-generation-for-model-entry-point-functions.html


Inputs to FOC Control Algorithm:

• ExternalInputs_mcb_pmsm_foc: This is a structure with the speed reference and signal to enable
the motor.

• SensorSigs: This is an array with  ADC counts,  ADC counts, quadrature encoder position
counts, and quadrature encoder index latch.

Outputs of FOC Control Algorithm:

• PWM Duty: This is an array with the PWM Duty Cycles for three phases and the signal to enable
PWM.

• DebugSignals: This is an array of signals that you can log while executing the control algorithm.

Parameters for FOC Control Algorithm:

• PI_params: This is a structure that contains the PI gains Kp_i, Ki_i, Kp_speed, and Ki_speed.

• IsOffset, IbOffset: These are datastore variables that contain the ADC calibration offsets.

Hardware Peripheral Integration

• Hardware peripherals are integrated with the control algorithm inside the mcb_pmsm_foc_system/
Embedded Processor subsystem.

• The ADC interrupt is used to schedule the generated code. The interrupt triggers at 50e-6
seconds.

• The subsystem mcb_pmsm_foc_system/Embedded Processor/Hardware Init finds the ADC
calibration offsets and provides them to the control algorithm.

• The subsystem mcb_pmsm_foc_system/Embedded Processor/Sensor Driver Blocks implements the
ADC and Quadrature Encoder peripherals.

• The subsystem mcb_pmsm_foc_system/Embedded Processor/Serial Receive has the serial blocks
to receive user inputs from a host model when the generated code is executing on the target.

• The subsystem mcb_pmsm_foc_system/Embedded Processor/Inverter Driver Peripherals has the
PWM driver peripherals and the Serial Transmit block to send data to the host computer. All these
peripherals are used from the Texas Instruments™ C2000™ Support Package.

If you are using a custom processor, you can implement the driver logic using a custom code. You can
integrate the generated code for the control algorithm with your own driver code in your preferred
Integrated Development Environment (IDE).

Test Behavior of Generated Code

For details of the required hardware connections, see “Hardware Connections” on page 7-2.

• Find the Quadrature Encoder offset. For details, see “Quadrature Encoder Offset Calibration for
PMSM Motor” on page 4-76.

• Build and load the executable file to the target for the mcb_pmsm_foc_system model.

• Open the host model mcb_host_model_f28069m using the host model link available in the
mcb_pmsm_foc_system model.
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• Update the COM port name for the target in the Host Serial Setup block of the host model.

• Click Run in the Simulation tab to run the host model.

• Change the Motor Start / Stop switch position to On, to start running the motor.

• Change the Reference Speed and monitor the effects in the scope window.
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Field Oriented Control of PMSM Using SI Units
This example implements the Field-Oriented Control (FOC) technique to control the speed of a three-
phase Permanent Magnet Synchronous Motor (PMSM). However, instead of the per-unit
representation of quantities(for details about the per-unit system, see “Per-Unit System” on page 6-
15), the FOC algorithm in this example uses the SI units of signals to perform the computations.
These are the signals and their SI units:

• Rotor speed - Radians/ sec

• Rotor position - Radians

• Currents - Amperes

• Voltages - Volts

Field-oriented control (FOC) needs a real time feedback of the rotor position. This example uses the
quadrature encoder sensor to measure the rotor position. For details about FOC, see “Field-Oriented
Control (FOC)” on page 4-2.

Models

The example includes the model mcb_pmsm_foc_qep_f28379d_SIUnit.

You can use this model for both simulation and code generation. You can also use the open_system
command to open the Simulink® model. For example, use this command for a F28379D based
controller:

open_system('mcb_pmsm_foc_qep_f28379d_SIUnit.slx');

Required MathWorks® Products

To simulate model:
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• Motor Control Blockset™

To generate code and deploy model:

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™ (only needed for optimized code generation)

Prerequisites

1. Obtain the motor parameters. We provide default motor parameters with the Simulink® model that
you can replace with the values from either the motor datasheet or other sources.

However, if you have the motor control hardware, you can estimate the parameters for the motor that
you want to use, by using the Motor Control Blockset parameter estimation tool. For instructions, see
“Estimate Motor Parameters Using Motor Control Blockset Parameter Estimation Tool” on page 5-
2.

The parameter estimation tool updates the motorParam variable (in the MATLAB® workspace) with
the estimated motor parameters.

2. If you obtain the motor parameters from the datasheet or other sources, update the motor
parameters and inverter parameters in the model initialization script associated with the Simulink®
models. For instructions, see “Estimate Control Gains from Motor Parameters” on page 3-2.

If you use the parameter estimation tool, you can update the inverter parameters, but do not update
the motor parameters in the model initialization script. The script automatically extracts motor
parameters from the updated motorParam workspace variable.

Simulate Model

This example supports simulation. Follow these steps to simulate the model.

1. Open the model included with this example.

2. Click Run on the Simulation tab to simulate the model.

3. Click Data Inspector on the Simulation tab to view and analyze the simulation results.

Generate Code and Deploy Model to Target Hardware

This section instructs you to generate code and run the FOC algorithm on the target hardware.

The example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
model is to deploy the target model to the controller hardware board. The host model uses serial
communication to command the target model and run the motor in a closed-loop control.

Required Hardware

The example supports this hardware configuration. You can also use the target model name to open
the model for the corresponding hardware configuration, from the MATLAB® command prompt.
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• LAUNCHXL-F28379D controller + BOOSTXL-DRV8305 inverter:
mcb_pmsm_foc_qep_f28379d_SIUnit

For connections related to the preceding hardware configuration, see “LAUNCHXL-F28069M and
LAUNCHXL-F28379D Configurations” on page 7-5.

Generate Code and Run Model on Target Hardware

1. Simulate the target model and observe the simulation results.

2. Complete the hardware connections.

3. The model automatically computes the ADC (or current) offset values. To disable this functionality
(enabled by default), update the value 0 to the variable inverter.ADCOffsetCalibEnable in the model
initialization script.

Alternatively, you can compute the ADC offset values and update it manually in the model
initialization scripts. For instructions, see “Run 3-Phase AC Motors in Open-Loop Control and
Calibrate ADC Offset” on page 4-6.

4. Compute the quadrature encoder index offset value and update it in the model initialization scripts
associated with the target model. For instructions, see “Quadrature Encoder Offset Calibration for
PMSM Motor” on page 4-76.

5. Open the target model. If you want to change the default hardware configuration settings for the
model, see “Model Configuration Parameters” on page 2-2.

6. Load a sample program to CPU2 of LAUNCHXL-F28379D, for example, program that operates the
CPU2 blue LED by using GPIO31 (c28379D_cpu2_blink.slx), to ensure that CPU2 is not mistakenly
configured to use the board peripherals intended for CPU1.

7. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

8. Click the host model hyperlink in the target model to open the associated host model. You can
also use the open_system command to open the host model. For example, use this command for a
F28069M based controller:

open_system('mcb_pmsm_SIUnit_host_model.slx');
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For details about the serial communication between the host and target models, see “Host-Target
Communication” on page 6-2.

9. In the Host Serial Setup block mask of the host model, select a Port name.

10. Update the Reference Speed value in the host model.

11. Click Run on the Simulation tab to run the host model.

12. Change the position of the Start / Stop Motor switch to On, to start running the motor.

13. Observe the debug signals from the RX subsystem, in the Time Scope of host model.
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Hall Offset Calibration for PMSM Motor
This example calculates the offset between the rotor direct axis (d-axis) and position detected by the
Hall sensor. The field-oriented control (FOC) algorithm needs this position offset to run the
permanent magnet synchronous motor (PMSM) correctly. To compute the offset, the target model
runs the motor in the open-loop condition. The model uses a constant  (voltage along the stator's d-
axis) and a zero  (voltage along the stator's q-axis) to run the motor (at a low constant speed) by
using a position or ramp generator. When the position or ramp value reaches zero, the corresponding
rotor position is the offset value for the Hall sensors.

The control algorithm (available in the field-oriented control and parameter estimation examples)
uses this offset value to compute an accurate position of d-axis of the rotor. The controller needs this
offset to optimally run the PMSM.

Models

This example includes these models:

• mcb_pmsm_hall_offset_f28069m

• mcb_pmsm_hall_offset_f28379d

You can use these models only for code generation. You can also use the open_system command to
open the Simulink® models. For example, use this command for a F28069M based controller:

open_system('mcb_pmsm_hall_offset_f28069m.slx');

For the model names that you can use for different hardware configurations, see the Required
Hardware topic in the Generate Code and Deploy Model to Target Hardware section.

Required MathWorks® Products

To generate code and deploy model:
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1. For the model: mcb_pmsm_hall_offset_f28069m

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™

2. For the model: mcb_pmsm_hall_offset_f28379d

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™ (only needed for optimized code generation)

Generate Code and Deploy Model to Target Hardware

This section instructs you to generate code and run the motor by using open-loop control.

This example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
model is to deploy the target model to the controller hardware board.

The host model uses serial communication to command the target model and run the motor in an
open-loop configuration. You can use the host model to control the motor rotations and validate
direction of rotation of the motor. The Incorrect motor direction LED in the host model turns red to
indicate that the motor is running in the opposite direction. When the LED turns red, you must
reverse the motor phase connections to change the direction of rotation. The host model displays the
calculated offset value.

Required Hardware

This example supports these hardware configurations. You can also use the target model name to
open the model for the corresponding hardware configuration, from the MATLAB® command prompt.

• F28069M controller card + DRV8312-69M-KIT inverter: mcb_pmsm_hall_offset_f28069m

For connections related to the preceding hardware configuration, see “F28069 control card
configuration” on page 7-2.

• LAUNCHXL-F28379D controller + (BOOSTXL-DRV8305 or BOOSTXL-3PHGANINV) inverter:
mcb_pmsm_hall_offset_f28379d

To configure the model mcb_pmsm_hall_offset_f28379d, set the Inverter Enable Logic field (in
the Configuration panel of target model) to:

• Active High: To use the model with BOOSTXL-DRV8305 inverter.
• Active Low: To use the model with BOOSTXL-3PHGANINV inverter.

For connections related to the preceding hardware configuration, see “LAUNCHXL-F28069M and
LAUNCHXL-F28379D Configurations” on page 7-5.

Generate Code and Run Model on Target Hardware

1. Complete the hardware connections.
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2. Open the target model for the hardware configuration that you want to use. If you want to change
the default hardware configuration settings for the target model, see “Model Configuration
Parameters” on page 2-2.

3. Update the motor parameters in the Configuration panel of the target model.

• Number of Pole Pairs
• PWM Frequency [Hz]
• Data type for control algorithm
• Vd Ref in Per Unit voltage

4. Load a sample program to CPU2 of LAUNCHXL-F28379D, for example, program that operates the
CPU2 blue LED by using GPIO31 (c28379D_cpu2_blink.slx), to ensure that CPU2 is not mistakenly
configured to use the board peripherals intended for CPU1.

5. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

6. Click the host model hyperlink in the target model to open the associated host model. You can
also use the open_system command to open the host model. For example, use this command for a
F28069M based controller:

open_system('mcb_pmsm_host_offsetComputation_f28069m.slx');
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For details about the serial communication between the host and target models, see “Host-Target
Communication” on page 6-2.

You can use the Scope in the host model to monitor the rotor position and offset values.

7. In the Host Serial Setup block mask of the host model, select a Port name.

8. Click Run on the Simulation tab to run the host model. The motor runs and calibration begins
when you start simulation. After the calibration process is complete, simulation ends and the motor
stops automatically.

9. See the Calibration Status section to know the status of the calibration process:
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• The Calibration in progress LED turns orange when the motor starts running. Notice the rotor
position and the variation in the offset value in the Scope (the position signal indicates a ramp
signal with an amplitude between 0 and 1). After the calibration process is complete, the LED
turns grey.

• The Calibration complete LED turns green when the calibration process is complete. Then the
Calibration Output field displays the computed offset value.

• The Incorrect motor direction LED turns red if the motor runs in the opposite direction. Then
the Calibration Output field displays the value "NaN." Turn off the DC power supply (24V)
and reverse the motor phase connections from ABC to CBA. Repeat steps 5 to 8 and check if the
Calibration complete LED is green. Verify that the Calibration Output field displays the offset
value.

Note: To immediately stop the motor, click the Emergency Motor Stop button.

This example does not support simulation. The example automatically saves the computed offset
value in the PositionOffset variable available in the base workspace.

For examples that implement FOC using a Hall sensor, update the computed offset in the
pmsm.PositionOffset parameter in the model initialization script linked to the example. For
instructions, see “Estimate Control Gains from Motor Parameters” on page 3-2.
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Monitor Resolver Using Serial Communication
This example operates the resolver sensor to measure the rotor position. The resolver consists of two
orthogonally placed stator windings placed around the resolver rotor winding. After you mount the
resolver sensor over a PMSM, the resolver rotor winding rotates along with the shaft of the running
motor. The controller provides a fixed frequency alternating excitation signal to the resolver rotor
winding. When the resolver rotor rotates, the resolver stator windings produce output (secondary
sine and cosine) signals that are modulated with the sine and cosine of the shaft angle or position.
After receiving the secondary signals, the controller samples and normalizes them.
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Models

The example includes the model mcb_resolver_f28069m.

You can use this model only for code generation. You can also use the open_system command to open
the Simulink® model. For example, use this command for a F28069M based controller:

open_system('mcb_resolver_f28069m.slx');
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Required MathWorks® Products

For the model: mcb_resolver_f28069m

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™

Prerequisite

We provide default inverter parameters with the target model. If you want to change the default
values, you can update the inverter parameters in the model initialization script associated with the
Simulink® model. For instructions, see “Estimate Control Gains from Motor Parameters” on page 3-2.

Generate Code and Deploy Model to Target Hardware

This section instructs you to generate code and run the FOC algorithm on the target hardware.

The example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
model is to deploy the target model to the controller hardware board. The controller in the target
model uses the Resolver Decoder block to process the sampled and normalized secondary sine and
cosine signals to obtain the shaft (or motor) position. The host model uses serial communication to
command the target model and obtain the computed shaft angle from the controller. You can observe
the computed shaft position in the Time Scope block of the host model.
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Required Hardware

The example supports this hardware configuration. You can also use the target model name to open
the model for the corresponding hardware configuration, from the MATLAB® command prompt.

• LAUNCHXL-F28069M controller + BOOSTXL-DRV8305 inverter: mcb_resolver_f28069m

For connections related to the preceding hardware configuration, see “LAUNCHXL-F28069M and
LAUNCHXL-F28379D Configurations” on page 7-5.

Generate Code and Run Model on Target Hardware

1. Complete the hardware connections and open the target model mcb_resolver_f28069m.

2. Load a sample program to CPU2 of LAUNCHXL-F28379D, for example, program that operates the
CPU2 blue LED by using GPIO31 (c28379D_cpu2_blink.slx), to ensure that CPU2 is not mistakenly
configured to use the board peripherals intended for CPU1.

3. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

4. Click the host model hyperlink in the target model to open the associated host model. You can
also use the open_system command to open the host model. For example, use this command for the
F28069M based controller:

open_system('mcb_resolver_host_read.slx');
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For details about the serial communication between the host and target models, see “Host-Target
Communication” on page 6-2.

5. In the Serial Receive and Serial Configuration block masks of the host model, select a
Communication port value.

6. If you want to change the default baud rate (in the host and target models), use the Serial
Configuration block mask in the models to select a different Baud rate value.

7. Click Run on the Simulation tab to run the host model.

8. Open the Time Scope block in the host model.

9. Rotate the resolver shaft and observe the computed shaft position signal in the Time Scope block.
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Quadrature Encoder Offset Calibration for PMSM Motor
This example calculates the offset between the d-axis of the rotor and encoder index pulse position as
detected by the quadrature encoder sensor. The control algorithm (available in the field-oriented
control and parameter estimation examples) uses this offset value to compute an accurate and
precise position of the d-axis of rotor. The controller needs this position to implement the field-
oriented control (FOC) correctly in the rotor flux reference frame (d-q reference frame), and
therefore, run the permanent magnet synchronous motor (PMSM) correctly.

Models

The example includes these models:

• mcb_pmsm_qep_offset_f28069m

• mcb_pmsm_qep_offset_f28069mLaunchPad

• mcb_pmsm_qep_offset_f28379d

You can use these models only for code generation. You can also use the open_system command to
open the Simulink® models. For example, use this command for a F28069M based controller:

open_system('mcb_pmsm_qep_offset_f28069m.slx');

For the model names that you can use for different hardware configurations, see the Required
Hardware topic in the Generate Code and Deploy Model to Target Hardware section.

Required MathWorks® Products

To generate code and deploy model:
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1. For the models: mcb_pmsm_qep_offset_f28069m and
mcb_pmsm_qep_offset_f28069mLaunchPad

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™

2. For the model: mcb_pmsm_qep_offset_f28379d

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™ (only needed for optimized code generation)

Generate Code and Deploy Model to Target Hardware

This section instructs you to generate code and run the motor by using open-loop control.

The example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
model is to deploy the target model to the controller hardware board.

The host model uses serial communication to command the target model and run the motor in an
open-loop configuration. You can use the host model to control the motor rotations and validate the
direction of rotation of motor. The Incorrect motor direction LED in the host model turns red to
indicate that the motor is running in the opposite direction. When the LED turns red, you must
reverse the motor phase connections (from ABC to CBA) to change the direction of rotation. The host
model displays the calculated offset value.

Required Hardware

This example supports these hardware configurations. You can also use the target model name to
open the model for the corresponding hardware configuration, from the MATLAB® command prompt.

• F28069M controller card + DRV8312-69M-KIT inverter: mcb_pmsm_qep_offset_f28069m

For connections related to the preceding hardware configuration, see “F28069 control card
configuration” on page 7-2.

• LAUNCHXL-F28069M controller + BOOSTXL-DRV8305 inverter:
mcb_pmsm_qep_offset_f28069mLaunchPad

• LAUNCHXL-F28379D controller + (BOOSTXL-3PHGANINV or BOOSTXL-DRV8305) inverter:
mcb_pmsm_qep_offset_f28379d

To configure the model mcb_pmsm_qep_offset_f28379d, set the Inverter Enable Logic field (in
the Configuration panel of target model) to:

• Active High: To use the model with BOOSTXL-DRV8305 inverter.
• Active Low: To use the model with BOOSTXL-3PHGANINV inverter.

NOTE: When using BOOSTXL-3PHGANINV inverter, ensure that proper insulation is available
between bottom layer of BOOSTXL-3PHGANINV and the LAUNCHXL board.
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For connections related to the preceding hardware configurations, see “LAUNCHXL-F28069M and
LAUNCHXL-F28379D Configurations” on page 7-5.

Generate Code and Run Model on Target Hardware

1. Complete the hardware connections.

2. Open the target model for the hardware configuration that you want to use. If you want to change
the default hardware configuration settings for the target model, see “Model Configuration
Parameters” on page 2-2.

3. Update the motor parameters in the Configuration panel of the target model.

• Number of Pole Pairs
• QEP Slits
• PWM Frequency [Hz]
• Data type for control algorithm
• Vd Ref in Per Unit voltage

3. Load a sample program to CPU2 of LAUNCHXL-F28379D, for example, program that operates the
CPU2 blue LED by using GPIO31 (c28379D_cpu2_blink.slx), to ensure that CPU2 is not mistakenly
configured to use the board peripherals intended for CPU1.

4. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

5. Click the host model hyperlink in the target model to open the associated host model. You can
also use the open_system command to open the host model. For example, use this command for a
F28069M based controller:

open_system('mcb_pmsm_host_offsetComputation_f28069m.slx');
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For details about the serial communication between the host and target models, see “Host-Target
Communication” on page 6-2.

You can use the Scope in the host model to monitor the rotor position and offset values.

6. In the Host Serial Setup block mask of the host model, select a Port name.

7. Click Run on the Simulation tab to run the host model. The motor runs and calibration begins
when you start simulation. After the calibration process is complete, simulation ends and the motor
stops automatically.

9. See the Calibration Status section to know the status of the calibration process:

• The Calibration in progress LED turns orange when the motor starts running. Notice the rotor
position and the variation in the offset value in the Scope (the position signal indicates a ramp
signal with an amplitude between 0 and 1). After the calibration process is complete, the LED
turns grey.

• The Calibration complete LED turns green when the calibration process is complete. Then the
Calibration Output field displays the computed offset value.

• The Incorrect motor direction LED turns red if the motor runs in the opposite direction. Then
the Calibration Output field displays the value "NaN." Turn off the DC power supply (24V)
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and reverse the motor phase connections from ABC to CBA. Repeat steps 5 to 8 and check if the
Calibration complete LED is green. Verify that the Calibration Output field displays the offset
value.

Note: To immediately stop the motor, click the Emergency Motor Stop button.

This example does not support simulation. The example automatically saves the computed offset
value in the PositionOffset variable available in the base workspace.

For examples that implement FOC using a quadrature encoder sensor, update the computed
quadrature encoder offset value in the pmsm.PositionOffset parameter in the model initialization
script linked to the example. For instructions, see “Estimate Control Gains from Motor Parameters”
on page 3-2.
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Model Switching Dynamics in Inverter Using Simscape
Electrical

This example uses field-oriented control (FOC) to control the speed of a three-phase permanent
magnet synchronous motor (PMSM). It gives you the option to use these Simscape Electrical blocks
as an alternative to the Average Value Inverter block in Motor Control Blockset™:

• Converter (Three-Phase)
• Ideal Semiconductor Switch

The example also gives you the option to use the PMSM block from Simscape™ Electrical™ as an
alternative to the Surface Mount PMSM block from Motor Control Blockset™. These Simscape™
Electrical™ blocks enable you to generate high-fidelity simulations.

Field-oriented control (FOC) needs a real time feedback of the rotor position. This example uses the
quadrature encoder sensor to measure the rotor position. For details about FOC, see “Field-Oriented
Control (FOC)” on page 4-2.

You can use this example to simulate the target model by using different inverters and monitor the
feedback current for each inverter. You can also generate the code and use the host model along with
the target model.

Models

The example includes the model mcb_ee_pmsm_foc.

You can use this model for both simulation and code generation. You can also use the open_system
command to open the Simulink® model. For example, use this command for a F28379D based
controller:

open_system('mcb_ee_pmsm_foc.slx');
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Required MathWorks® Products

To simulate model:

• Motor Control Blockset™
• Simscape™ Electrical™

To generate code and deploy model:

• Motor Control Blockset™
• Simscape™ Electrical™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™ (only needed for optimized code generation)

Prerequisites

1. Obtain the motor parameters. We provide default motor parameters with the Simulink® model that
you can replace with the values from either the motor datasheet or other sources.

However, if you have the motor control hardware, you can estimate the parameters for the motor that
you want to use, by using the Motor Control Blockset parameter estimation tool. For instructions, see
“Estimate Motor Parameters Using Motor Control Blockset Parameter Estimation Tool” on page 5-
2.

The parameter estimation tool updates the motorParam variable (in the MATLAB® workspace) with
the estimated motor parameters.

2. If you obtain the motor parameters from the datasheet or other sources, update the motor
parameters and inverter parameters in the model initialization script associated with the Simulink®
models. For instructions, see “Estimate Control Gains from Motor Parameters” on page 3-2.

If you use the parameter estimation tool, you can update the inverter parameters, but do not update
the motor parameters in the model initialization script. The script automatically extracts motor
parameters from the updated motorParam workspace variable.

Simulate Model

This example supports simulation. Follow these steps to simulate the model.

1. Open the target model mcb_ee_pmsm_foc.

2. Select one of these options in the InverterSelected radio group in the target model:

• Motor Control Blockset average inverter - Select this option to use the Average Inverter and
Surface Mount PMSM blocks.

• Simscape Electrical 3 phase converter - Select this option to use the Converter (Three-Phase)
and PMSM blocks.

• Simscape Electrical Modular Multilevel converter - Select this option to use the Ideal
Semiconductor Switch and PMSM blocks.

3. Select an option from the InverterSelected radio group and click Run on the Simulation tab to
simulate the target model.
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4. On the target model, click Data Inspector on the Simulation tab to view results from the three
simulation runs.

This image shows the simulation results for  phase current:

These images show the comparison of rotor speed,  current,  phase current, and rotor position
for the three inverter types:
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These images show the comparison of PWM modulation waveforms for the three inverter types:
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Generate Code and Deploy Model to Target Hardware

This section instructs you to generate code and run the FOC algorithm on the target hardware.

The example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
model is to deploy the target model to the controller hardware board. The host model uses serial
communication to command the target Simulink® model and run the motor in a closed-loop control.

Required Hardware

The example supports this hardware configuration. You can also use the target model name to open
the model for the corresponding hardware configuration, from the MATLAB® command prompt.

• LAUNCHXL-F28379D controller + BOOSTXL-DRV8305 inverter: mcb_ee_pmsm_foc
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For connections related to the preceding hardware configuration, see “LAUNCHXL-F28069M and
LAUNCHXL-F28379D Configurations” on page 7-5.

Generate Code and Run Model on Target Hardware

1. Simulate the target model and observe the simulation results.

2. Complete the hardware connections.

3. The model automatically computes the ADC (or current) offset values. To disable this functionality
(enabled by default), update the value 0 to the variable inverter.ADCOffsetCalibEnable in the model
initialization script.

Alternatively, you can compute the ADC offset values and update it manually in the model
initialization scripts. For instructions, see “Run 3-Phase AC Motors in Open-Loop Control and
Calibrate ADC Offset” on page 4-6.

4. Compute the quadrature encoder index offset value and update it in the model initialization scripts
associated with the target model. For instructions, see “Quadrature Encoder Offset Calibration for
PMSM Motor” on page 4-76.

5. Open the target model. If you want to change the default hardware configuration settings for the
model, see “Model Configuration Parameters” on page 2-2.

6. To ensure that CPU2 is not mistakenly configured to use the board peripherals intended for CPU1,
load a sample program to CPU2 of LAUNCHXL-F28379D, for example, a program that operates the
CPU2 blue LED by using GPIO31 (c28379D_cpu2_blink.slx).

7. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

8. Click the host model hyperlink in the target model to open the associated host model. You can
also use the open_system command to open the host model. For example, use this command for a
F28379D based controller:

open_system('mcb_pmsm_foc_host_model_f28379d.slx');
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For details about the serial communication between the host and target models, see “Host-Target
Communication” on page 6-2.

9. In the Host Serial Setup block mask of the host model, select a Port name.

10. Update the Reference Speed value in the host model.

11. Click Run on the Simulation tab to run the host model.

12. Change the position of the Start / Stop Motor switch to On, to start running the motor.

13. Observe the debug signals from the RX subsystem, in the Time Scope and Display blocks of the
host model.

Note: In the host model, you can also select the debug signals that you want to monitor.

Other Things to Try

You can also use SoC Blockset™ to implement a closed-loop motor control application that addresses
challenges related to ADC-PWM synchronization, controller response, and studying different PWM
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settings. You can use Simscape™ Electrical™ to implement high fidelity inverter simulation. For
details, see “Integrate MCU Scheduling and Peripherals in Motor Control Application” on page 4-132.
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Control PMSM Loaded with Dual Motor (Dyno)
This example uses field-oriented control (FOC) to control two three-phase permanent magnet
synchronous motors (PMSM) coupled in a dyno setup. Motor 1 runs in the closed-loop speed control
mode. Motor 2 runs in the torque control mode and loads Motor 1 because they are mechanically
coupled. You can use this example to test a motor in different load conditions.

The example simulates two motors that are connected back-to-back. You can use a different speed
reference for Motor 1 and a different torque reference for Motor 2 (derived from the magnitude and
electrical position of the Motor 2 reference stator current). Motor 1 runs at the reference speed for
the load conditions provided by Motor 2 (with a different torque reference).

These equations describe the computation of d-axis and q-axis components of the Motor 2 reference
stator current.

where:

•  is the d-axis component of the Motor 2 reference stator current.

•
 is the q-axis component of the Motor 2 reference stator current.

•
 is the magnitude of the Motor 2 reference stator current.

•  is the electrical position of the Motor 2 reference stator current.

The example runs in the controller hardware board. You can input the speed reference for Motor 1
and current reference for Motor 2 using a host model. The host model uses serial communication to
communicate with the controller hardware board.

Current control loops in Motor 1 and Motor 2 control algorithms are offset by Ts/2, where Ts is the
control-loop execution rate.

Models

The example includes the model mcb_pmsm_foc_f28379d_dyno.

You can use this model for both simulation and code generation. You can also use the open_system
command to open the Simulink® model. For example, use this command for a F28379D based
controller:

open_system('mcb_pmsm_foc_f28379d_dyno.slx');
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Required MathWorks® Products

To simulate model:

• Motor Control Blockset™

To generate code and deploy model:

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™ (only needed for optimized code generation)

Prerequisites

1. Obtain the motor parameters for both Motor 1 and Motor 2. We provide default motor parameters
with the Simulink® model that you can replace with the values from either the motor datasheet or
other sources.

However, if you have the motor control hardware, you can estimate the parameters for the motor that
you want to use, by using the Motor Control Blockset™ parameter estimation tool. For instructions,
see “Estimate Motor Parameters Using Motor Control Blockset Parameter Estimation Tool” on page
5-2.

2. Update the motor parameters (that you obtained from the datasheet, other sources, or parameter
estimation tool) and inverter parameters in the model initialization script associated with the
Simulink® model. For instructions, see “Estimate Control Gains from Motor Parameters” on page 3-2.

For this example, update the motor parameters for both the motors in the model initialization script.

Simulate Model

This example supports simulation. Follow these steps to simulate the model.
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1. Open a model included with this example.

2. Click Run on the Simulation tab to simulate the model.

3. Click Data Inspector on the Simulation tab to view and analyze the simulation results.

4. Input a different speed reference for Motor 1 and a different current reference (load) for Motor 2.
Observe the measured speed and other logged signals in the Data Inspector.

Generate Code and Deploy Model to Target Hardware

This section instructs you to generate code and run the FOC algorithm on the target hardware.

The example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
model is to deploy the target model to the controller hardware board. The host model uses serial
communication to command the target Simulink® model and run the motor in a closed-loop control.

Required Hardware

The example supports this hardware configuration. You can also use the target model name to open
the model for the corresponding hardware configuration, from the MATLAB® command prompt.

• LAUNCHXL-F28379D controller + 2 BOOSTXL-DRV8305 inverters: mcb_pmsm_foc_f28379d_dyno

• LAUNCHXL-F28379D controller + 2 BOOSTXL-3PHGANINV inverters:
mcb_pmsm_foc_f28379d_dyno

For connections related to the preceding hardware configuration, see “Instructions for Dyno (Dual
Motor) Setup” on page 7-9.

Generate Code and Run Model on Target Hardware

1. Simulate the target model and observe the simulation results.

2. Complete the hardware connections.

3. The model automatically computes the ADC (or current) offset values. To disable this functionality
(enabled by default), update the value 0 to the variable inverter.ADCOffsetCalibEnable in the model
initialization script.

Alternatively, you can compute the ADC offset values and update it manually in the model
initialization scripts. For instructions, see “Run 3-Phase AC Motors in Open-Loop Control and
Calibrate ADC Offset” on page 4-6.

4. Compute the quadrature encoder index offset value and update it in the model initialization scripts
associated with the target model. For instructions, see “Quadrature Encoder Offset Calibration for
PMSM Motor” on page 4-76.

For this example, update the QEP offset values in the pmsm_motor1.PositionOffset and
pmsm_motor2.PositionOffset variables in initialization script.

5. Open the target model. If you want to change the default hardware configuration settings for the
model, see “Model Configuration Parameters” on page 2-2.
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6. To ensure that CPU2 is not mistakenly configured to use the board peripherals intended for CPU1,
load a sample program to CPU2 of LAUNCHXL-F28379D, for example, a program that operates the
CPU2 blue LED by using GPIO31 (c28379D_cpu2_blink.slx).

7. Click Build, Deploy & Start on the Hardware tab to deploy the model to the hardware.

8. Click the host model hyperlink in the target model to open the associated host model. You can
also use the open_system command to open the host model:

open_system('mcb_pmsm_foc_host_model_dyno.slx');

9. In the Host Serial Setup block mask of the host model, select a Port name.

10. Click Run on the Simulation tab to run the host model.
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11. Change the position of the Start / Stop Motor 1 switch to On, to start running the motor.

12. Update the Motor 1 - Reference Speed (RPM), Motor 2 - Imag Ref (A), and Motor 2 - Imag
Pos (deg) in the host model.

Note: Be cautious when using values other than 90 or 270 degrees in the Motor 2 - Imag Pos (deg)
field. These values generate current along the d-axis that creates a magnetizing effect. Excess
current along the d-axis can create saturation and can damage the motor magnets.

13. Select the debug signals that you want to monitor, to observe them in the Time Scope block of
host model.

Other Things to Try

You can also use SoC Blockset™ to develop a real-time motor control application for a dual motor
setup that utilizes multiple processor cores to obtain design modularity, improved controller
performance, and other design goals. For details, see “Partition Motor Control for Multiprocessor
MCUs” on page 4-141.
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Field-Oriented Control of Induction Motor Using Speed Sensor
This example implements the field-oriented control (FOC) technique to control the speed of a three-
phase AC induction motor (ACIM). The FOC algorithm requires rotor speed feedback, which is
obtained in this example by using a quadrature encoder sensor. For details about FOC, see “Field-
Oriented Control (FOC)” on page 4-2.

This example uses the quadrature encoder sensor to measure the rotor speed. The quadrature
encoder sensor consists of a disk with two tracks or channels that are coded 90 electrical degrees out
of phase. This creates two pulses (A and B) that have a phase difference of 90 degrees and an index
pulse (I). Therefore, the controller uses the phase relationship between A and B channels and the
transition of channel states to determine the direction of rotation of the motor.

Model

The example includes the model mcb_acim_foc_qep_f28379d.

You can use this model for simulation and code generation. You can also use the open_system
command to open the Simulink® model.

open_system('mcb_acim_foc_qep_f28379d.slx');
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For details on the supported hardware configuration, see the Required Hardware section under
Generate Code and Deploy Model to Target Hardware.

Required MathWorks® Products

To simulate model:

• Motor Control Blockset™

To generate code and deploy model:

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™ (needed only for optimized code generation)

Prerequisites

1. Obtain the motor parameters. We provide the default motor parameters with the Simulink® model
that you can replace with values from either the motor datasheet or other sources.

2. If you obtain the motor parameters from the datasheet or other sources, update the motor and
inverter parameters in the model initialization script associated with the Simulink® models. For
instructions, see “Estimate Control Gains from Motor Parameters” on page 3-2.

3. The initialization script also computes the derived parameters. For example, total leakage factor,
rated flux, rated torque, stator and rotor inductances of the induction motor.

Simulate Model

This example supports simulation. Follow these steps to simulate the model.

1. Open the model included with this example.
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2. Click Run on the Simulation tab to simulate the model.

3. Click Data Inspector on the Simulation tab to view and analyze the simulation results.

Generate Code and Deploy Model to Target Hardware

This section instructs you on how to generate code and run the FOC algorithm on the target
hardware.

This example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
model is to deploy the target model to the controller hardware board. The host model uses serial
communication to command the target Simulink® model and run the motor in closed-loop control.

Required Hardware

This example supports the following hardware configuration. You can also use the target model name
to open the model for the corresponding hardware configuration from the MATLAB® command
prompt.

• LAUNCHXL-F28379D controller + BOOSTXL-DRV8305 inverter: mcb_acim_foc_qep_f28379d

For connections related to the preceding hardware configuration, see “LAUNCHXL-F28069M and
LAUNCHXL-F28379D Configurations” on page 7-5.

Generate Code and Run Model on Target Hardware

1. Simulate the target model and observe the simulation results.

2. Complete the hardware connections.

3. The model automatically computes the ADC (or current) offset values. To disable this functionality
(enabled by default), update the value 0 to the variable inverter.ADCOffsetCalibEnable in the model
initialization script.

Alternatively, you can compute the ADC offset values and update them manually in the model
initialization scripts. For instructions, see “Run 3-Phase AC Motors in Open-Loop Control and
Calibrate ADC Offset” on page 4-6.

4. Open the target model. If you want to change the default hardware configuration settings in the
model, see “Model Configuration Parameters” on page 2-2.

5. Load a sample program to CPU2 of the LAUNCHXL-F28379D, for example program that operates
the CPU2 blue LED, by using the GPIO31 pin (c28379D_cpu2_blink.slx), to ensure that CPU2 is not
mistakenly configured to use the board peripherals intended for CPU1.

6. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

7. Click the host model hyperlink in the target model to open the associated host model. You can
also use the open_system command to open the host model.

open_system('mcb_acim_foc_host_model.slx');
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For details about the serial communication between the host and target models, see “Host-Target
Communication” on page 6-2.

8. In the Host Serial Setup block mask of the host model, select a Port name.

9. Update the Reference Speed value in the host model.

10. In the Debug signals section, select a signal that you want to monitor.

11. Click Run on the Simulation tab to run the host model.

12. Change the position of the Start / Stop Motor switch to On to start running the motor.

13. Observe the debug signals from the RX subsystem in the SelectedSignals time scope of the host
model.

NOTE: This example depends on the positive speed feedback for the positive rotation of the space
vectors. If the motor does not run, try these steps to resolve the issue:

• Try interchanging any two motor phase connections.

• Modify and use the example “Run 3-Phase AC Motors in Open-Loop Control and Calibrate ADC
Offset” on page 4-6 with a speed feedback and confirm the positive direction of rotation for a
positive reference speed.

See Also

• Field-Oriented Control of Induction Motors with Simulink and Motor Control Blockset
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Sensorless Field-Oriented Control of Induction Motor
This example uses sensorless position estimation to implement the field-oriented control (FOC)
technique to control the speed of a three-phase AC induction motor (ACIM). For details about FOC,
see “Field-Oriented Control (FOC)” on page 4-2.

This example uses rotor Flux Observer block to estimate the position of rotor flux.

The block uses stator voltages  and currents  as inputs and estimates the rotor flux,
generated torque, and the rotor flux position.

The sensorless observers and algorithms have known limitations regarding motor operations beyond
the base speed. We recommend that you use the sensorless examples for operations upto base speed
only.

Model

The example includes the model mcb_acim_foc_sensorless_f28379d.

You can use this model for both simulation and code generation. You can also use the open_system
command to open the Simulink® model.

open_system('mcb_acim_foc_sensorless_f28379d.slx');

For details on the supported hardware configuration, see the Required Hardware section under
Generate Code and Deploy Model to Target Hardware.

Required MathWorks® Products

To simulate model:

• Motor Control Blockset™

To generate code and deploy model:
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• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™ (needed only for optimized code generation)

Prerequisites

1. Obtain the motor parameters. We provide the default motor parameters with the Simulink® model
that you can replace with the values from either the motor datasheet or other sources.

2. If you obtain the motor parameters from the datasheet or other sources, update the motor and
inverter parameters in the model initialization script associated with the Simulink® models. For
instructions, see “Estimate Control Gains from Motor Parameters” on page 3-2.

3. The initialization script also computes the derived parameters. For example, total leakage factor,
rated flux, rated torque, stator and rotor inductances of the induction motor.

Simulate Model

This example supports simulation. Follow these steps to simulate the model.

1. Open the model included with this example.

2. Click Run on the Simulation tab to simulate the model.

3. Click Data Inspector on the Simulation tab to view and analyze the simulation results.

Generate Code and Deploy Model to Target Hardware

This section instructs you on how to generate code and run the FOC algorithm on the target
hardware.

This example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
model is to deploy the target model to the controller hardware board. The host model uses serial
communication to command the target Simulink® model and run the motor in closed-loop control.

Required Hardware

The example supports this hardware configuration. You can also use the target model name to open
the model for the corresponding hardware configuration from the MATLAB® command prompt.

• LAUNCHXL-F28379D controller + BOOSTXL-DRV8305 inverter: mcb_acim_foc_qep_f28379d

For connections related to this hardware configuration, see “LAUNCHXL-F28069M and LAUNCHXL-
F28379D Configurations” on page 7-5.

Generate Code and Run Model on Target Hardware

1. Simulate the target model and observe the simulation results.

2. Complete the hardware connections.
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3. The model automatically computes the Analog-to-Digital Converter (ADC) or current offset values.
To disable this functionality (enabled by default), update the value 0 to the variable
inverter.ADCOffsetCalibEnable in the model initialization script.

Alternatively, you can compute the ADC offset values and update them manually in the model
initialization scripts. For instructions, see “Run 3-Phase AC Motors in Open-Loop Control and
Calibrate ADC Offset” on page 4-6.

4. Open the target model. If you want to change the default hardware configuration settings in the
model, see “Model Configuration Parameters” on page 2-2.

5. Load a sample program to CPU2 of the LAUNCHXL-F28379D, for example program that operates
the CPU2 blue LED, using the GPIO31 pin (c28379D_cpu2_blink.slx), to ensure that CPU2 is not
mistakenly configured to use the board peripherals intended for CPU1.

6. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

7. In the target model, click the host model hyperlink to open the associated host model. You can
also use the open_system command to open the host model.

open_system('mcb_acim_foc_host_model.slx');
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For details about the serial communication between the host and target models, see “Host-Target
Communication” on page 6-2.

8. In the Host Serial Setup block mask of the host model, select a Port name.

9. Update the Reference Speed value in the host model.

10. In the Debug signals section, select a signal that you want to monitor.

11. Click Run on the Simulation tab to run the host model.

12. Change the position of the Start / Stop Motor switch to On, to start running the motor in the
open-loop condition (by default, the motor spins at 10% of the base speed).

Note: Do not run the motor (using this example) in the open-loop condition for long. The motor may
draw high currents and produce excessive heat.

We designed the open-loop control to run the motor with a Reference Speed that is less than or equal
to 10% of base speed.

13. Increase the motor Reference Speed beyond 10% of the base speed to switch from open-loop to
closed-loop control.

NOTE: To change the motor's direction of rotation, reduce the motor Reference Speed to a value less
than 10% of the base speed. This brings the motor back to the open-loop condition. Change the
direction of rotation, but keep the Reference Speed magnitude constant. Then transition to the
closed-loop condition.

14. Observe the debug signals from the RX subsystem in the SelectedSignals time scope of the host
model.
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NOTE: The Flux Observer block is designed to work with PMSM but its output is modified to work
with induction motor. For custom motors, update the Offset_Correction block (in Current Control/
Input Scaling/Calculate position and speed subsystem) to adjust the delay in the position estimation.
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Tune PI Controllers Using Field Oriented Control Autotuner
Block on Real-Time Systems

This example computes the gain values of proportional-integral (PI) controllers within the speed and
current controllers by using the Field Oriented Control Autotuner block. For details about field-
oriented control, see “Field-Oriented Control (FOC)” on page 4-2.

This model supports both simulation and code generation. When you run the model, it uses the simple
values of gains for the PI controllers to achieve the steady state of the speed-control operation.

The model begins tuning only in the steady state. It introduces disturbances in the controller output
depending on the controller goals (bandwidth and phase margin). The model uses the system
response to disturbances to calculate the optimal controller gain.

Model

The example includes the model mcb_pmsm_foc_autotuner_speedgoat.

You can use this model for both simulation and code generation. You can use the open_system
command to open the Simulink® model.

open_system('mcb_pmsm_foc_autotuner_speedgoat.slx');

For details on the supported hardware configuration, see the Required Hardware section under
Generate Code and Deploy Model to Target Hardware.

Required MathWorks® Products

• Motor Control Blockset™
• Simulink Control Design™
• Simulink Real-Time™
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• Speedgoat Library

Prerequisites

1. The motor parameters available in the example model are for the motor that comes with the
Speedgoat Electric Motor Control Kit. You can modify these parameters for any other motor by
replacing them with values from either the motor datasheet or other sources.

2. If you obtain the motor parameters from the datasheet or other sources, update the motor and
inverter parameters in the model initialization script associated with the Simulink® models. For
instructions, see “Model Initialization Script” on page 3-3.

Simulate Model

This example supports simulation. Follow these steps to simulate the model.

1. Open the model included with this example.

2. Check the reference speed profile configured in the signal builder (available in
mcb_pmsm_foc_autotuner_speedgoat/System Inputs/Speed Reference).

3. Check and update the FOC Autotuner parameters in the Field Oriented Control Autotuner block
mask (available in the Control Algorithms/FOC_AutoTuner subsystem). For details about the Field
Oriented Control Autotuner block, see Field Oriented Control Autotuner.

4. Check and update the simple gain values in the model initialization script associated with the
model.

5. Click Run on the Simulation tab to simulate the model.

6. Verify that the motor reaches steady state operation for at least half of the rated speed using the
simple gain values that you entered. The model begins field-oriented control (FOC) tuning (using the
Field Oriented Control Autotuner block) at the seventeenth second.

7. After tuning completes, observe the computed PI controller gain values in the Display PI Params
block available in the Control Algorithms subsystem.

8. Observe the system response with the newly computed PI parameters by using the Simulation Data
Inspector.

For more details, see “Tune PI Controllers Using Field Oriented Control Autotuner” on page 4-25.

Generate Code and Deploy Model to Target Hardware

This section instructs you on how to generate code and run the FOC algorithm on the target
hardware.

Required Hardware

This example supports Speedgoat Electric Motor Control Kit that includes these components:

• Three-phase inverter rated for 48 V and 20 A from Speedgoat

• 100 W three-phase brushless DC motor from Maxon Motor

• Quadrature encoder with 4096 impulses
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• 150 W 254 V DC power supply

NOTE: Contact Speedgoat for the bit stream file that is valid for your hardware.

For more details about Speedgoat Electric Motor Control Kit, see Electric Motor Control Kit.

For details about Speedgoat hardware setup, see Speedgoat Software Configuration Guide.

Generate Code and Run Model on Target Hardware

1. Simulate the model and verify that you are obtaining the desired controller response.

2. Complete the hardware connections for the Speedgoat Electric Motor Control Kit.

• Calibrate current offset

1. In the model, set Operating Mode to Current Offset Calibration.

2. In the Real-Time tab on the Simulink toolstrip, click Build Model in the Run on Target drop-
down menu to build the model.

NOTE: Do not click Run on Target because this example model does not support real-time execution
in external mode.

3. Navigate to the folder where Simulink built the model. Double click the file
mcb_pmsm_foc_autotuner_speedgoat.mldatx to open the Simulink Real-Time Application dialog box.
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4. In the Simulink Real-Time Application dialog box, select the target computer to which you are
connected. Click OK to load the application file to the hardware.

5. Enter these commands (in the same order) at the MATLAB command prompt to execute the loaded
application on the hardware.

• tg = slrealtime;
• tg.start;

6. After the model runs successfully, use Data Inspector on the Simulation tab to see the logged
signals. The stabilized Iab_offset signals are the current offsets.

7. Update the current offset values in the inverter.CtSensAOffset and inverter.CtSensBOffset
variables available in the model initialization script associated with the Simulink model.
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• Run motor in open-loop control

1. In the model, set Operating Mode to Open Loop Speed Control.

2. In the Real-Time tab on the Simulink toolstrip, click Build Model in the Run on Target drop-
down menu to build the model.

3. Navigate to the folder where Simulink built the model. Double click the file
mcb_pmsm_foc_autotuner_speedgoat.mldatx to open the Simulink Real-Time Application dialog box.

4. In the Simulink Real-Time Application dialog box, select the target computer to which you are
connected. Click OK to load the application file to the hardware.

5. Enter these commands (in the same order) at the MATLAB command prompt to execute the loaded
application on the hardware.

• tg = slrealtime;
• tg.start;

6. After the model executes, use Data Inspector on the Simulation tab to see the logged signals.
Verify that speed feedback (Speed_fb) follows the reference speed (Speed_Ref) signal.
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For example, verify that the positive reference speed has a positive speed feedback, and the position
signal (Pos_PU) has a positive ramp.

If there is a mismatch in the sign of the reference speed and speed feedback signals, change the A
leads B parameter (of the Inverter and Plant model/SpeedGoatDrivers/Condition Encoder block)
either from 0 to 1 or from 1 to 0. Then follow steps 2 to 6 in this section to execute the model again
on the hardware.

NOTE: In the Open Loop Speed Control mode, the motor speed is limited between 500 rpm and 1200
rpm.

• Run motor in closed-loop control

1. In the model, set Operating Mode to Closed Loop Speed Control.
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2. Set the FOC Autotuner button on the model to Disable to disable the field-oriented control (FOC)
Autotuner.

3. In the Real-Time tab on the Simulink toolstrip, click Build Model in the Run on Target drop-
down menu to build the model.

4. Navigate to the folder where Simulink built the model. Double-click the file
mcb_pmsm_foc_autotuner_speedgoat.mldatx to open the Simulink Real-Time Application dialog box.

5. In the Simulink Real-Time Application dialog box, select the target computer to which you are
connected. Click OK to load the application file to the hardware.

6. Enter these commands (in the same order) at the MATLAB command prompt to execute the loaded
application on the hardware and run the motor.

• tg = slrealtime;
• tg.start;

The motor runs in closed-loop control at a speed that is configured in the signal builder.
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7. Verify that the motor reaches steady state operation because the FOC Autotuner will not work if
the motor speed is unstable.

If the motor fails to reach the steady state, change the PI parameters manually in the model
initialization script (associated with the model), until the motor speed stabilizes to half the base speed
of the motor.

NOTE: When tuning the PI parameters in the model initialization script, the motor may show a slow
speed response.

8. If the motor reaches a stable speed, follow the steps to run FOC Autotuner.

• Run FOC Autotuner
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1. Set the FOC Autotuner button on the model to Enable to enable the field-oriented control
autotuner.

2. Verify if Operating Mode is set to Closed Loop Speed Control.

3. Check and update the FOC Autotuner parameters (such as autotuner trigger timing and controller
target) in the Field Oriented Control Autotuner block mask (available inside Control Algorithms/
FOC_AutoTuner subsystem). For details about the Field Oriented Control Autotuner block, see Field
Oriented Control Autotuner.

4. In the Real-Time tab on the Simulink toolstrip, click Build Model in the Run on Target drop-
down menu to build the model.

5. Navigate to the folder where Simulink built the model. Double click the file
mcb_pmsm_foc_autotuner_speedgoat.mldatx to open the Simulink Real-Time Application dialog box.

6. In the Simulink Real-Time Application dialog box, select the target computer to which you are
connected. Click OK to load the application file to the hardware.

7. Enter these commands (in the same order) at the MATLAB command prompt to execute the loaded
application on the hardware and run the motor.

• tg = slrealtime;
• tg.start;

The model begins field-oriented control (FOC) tuning (using the Field Oriented Control Autotuner
block) at the seventeenth second after model execution begins on the hardware. It logs the PI
controller gain values (kp_Id, ki_Id, kp_Iq, ki_Iq, kp_speed, ki_speed) in the Simulation Data
Inspector.

8. Observe and compare the system response with the PI parameters before tuning and after tuning
in the Simulation Data Inspector.
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9. If the system response after tuning is satisfactory, update the gain values in the model initialization
script associated with the model. For consecutive model executions, you can disable the FOC tuning
using the FOC Autotuner button in the model and continue with the closed-loop testing using the new
PI parameters.

NOTE: Do not reconfigure or change the reference speed value in the signal builder such that the
reference speed changes during the tuning process.
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Six-Step Commutation of BLDC Motor Using Sensor Feedback
This example uses 120-degree conduction mode to implement the six-step commutation technique to
control speed and direction of rotation of a three-phase brushless DC (BLDC) motor. The example
uses the switching sequence generated by the Six Step Commutation block to control three-phase
stator voltages, and therefore, control the rotor speed and direction. For more details about this
block, see Six Step Commutation.

The six-step commutation algorithm requires a Hall sequence or a rotor position feedback value
(which is obtained from either a quadrature encoder or a Hall sensor).

The quadrature encoder sensor consists of a disk with two tracks or channels that are coded 90
electrical degrees out of phase. This creates two pulses (A and B) that have a phase difference of 90
degrees and an index pulse (I). The controller uses the phase relationship between the A and B
channels and the transition of channel states to determine the speed, position, and direction of
rotation of the motor.

A Hall effect sensor varies its output voltage based on the strength of the applied magnetic field.
According to the standard configuration, a BLDC motor consists of three Hall sensors located
electrically 120 degrees apart. A BLDC with the standard Hall placement (where the sensors are
placed electrically 120 degrees apart) can provide six valid combinations of binary states: for
example, 001,010,011,100,101, and 110. The sensor provides the angular position of the rotor in
degrees in the multiples of 60, which the controller uses to determine the 60-degree sector where the
rotor is present.

The controller controls the motor by using the Hall sequence or the rotor position. It energizes the
next two phases of the stator winding, so that the rotor always maintains a torque angle (angle
between rotor d-axis and stator magnetic field) of 90 degrees with a deviation of 30 degrees.

Models

The example includes these models:
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• mcb_bldc_sixstep_f28069mLaunchPad

• mcb_bldc_sixstep_f28379d

You can use these models for both simulation and code generation. To open a Simulink® model, you
can also use the open_system command at the MATLAB command prompt. For example, use this
command for a F28379D based controller:

open_system('mcb_bldc_sixstep_f28379d.slx');

For details of the supported hardware configuration, see Required Hardware in the Generate Code
and Deploy Model to Target Hardware section.

Required MathWorks® Products

To simulate model:

• Motor Control Blockset™

To generate code and deploy model:

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™ (only needed for optimized code generation)

Prerequisites

1. Obtain the motor parameters. We provide default motor parameters with the Simulink model that
you can replace with values from either the motor datasheet or other sources.

However, if you have the motor control hardware, you can estimate the parameters for the motor that
you want to use by using the Motor Control Blockset parameter estimation tool. For instructions, see
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“Estimate Motor Parameters Using Motor Control Blockset Parameter Estimation Tool” on page 5-
2.

The parameter estimation tool updates the motorParam variable (in the MATLAB® workspace) with
the estimated motor parameters.

2. If you obtain the motor parameters from a motor datasheet or from other sources, update the
motor parameters and the inverter parameters in the model initialization script associated with the
Simulink models. For instructions, see “Estimate Control Gains from Motor Parameters” on page 3-2.

If you use the parameter estimation tool, you can update the inverter parameters, but do not update
the motor parameters in the model initialization script. The script automatically extracts the motor
parameters from the updated motorParam workspace variable.

Simulate Model

This example supports simulation. Follow these steps to simulate the model.

1. Open the model included with this example.

2. Select either the QEP or the Hall Speed_Feedback radio button in the model.

3. Click Run on the Simulation tab to simulate the model.

4. Click Data Inspector on the Simulation tab to view and analyze the simulation results.

Generate Code and Deploy Model to Target Hardware

This section shows you how to generate code and run the FOC algorithm on the target hardware.

This example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
model is to deploy the target model to the controller hardware board. The host model uses serial
communication to command the target Simulink model and run the motor in a closed-loop control.

Required Hardware

The example supports these hardware configurations. You can also use the target model name to
open the model for the corresponding hardware configuration, from the MATLAB® command prompt.

• LAUNCHXL-F28069M controller + BOOSTXL-DRV8305 inverter:
mcb_bldc_sixstep_f28069mLaunchPad

• LAUNCHXL-F28379D controller + BOOSTXL-DRV8305 inverter: mcb_bldc_sixstep_f28379d

For connections related to these hardware configurations, see “LAUNCHXL-F28069M and
LAUNCHXL-F28379D Configurations” on page 7-5.

Generate Code and Run Model on Target Hardware

1. Simulate the target model and observe the simulation results.

2. Complete the hardware connections.

3. The model computes the ADC (or current) offset values by default. To disable this functionality,
update the value 0 to the variable inverter.ADCOffsetCalibEnable in the model initialization script.
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Alternatively, you can compute the ADC offset values and update them manually in the model
initialization script. For instructions, see “Run 3-Phase AC Motors in Open-Loop Control and Calibrate
ADC Offset” on page 4-6.

4. If you are using a quadrature encoder, compute the quadrature encoder index offset value and
update it in the model initialization script associated with the target model. For instructions, see
“Quadrature Encoder Offset Calibration for PMSM Motor” on page 4-76.

5. If you are using a Hall sensor, compute the Hall sequence value and update it in the
bldc.hallsequence variable in the model initialization script associated with the target model. For
instructions, see “Hall Sensor Sequence Calibration of BLDC Motor” on page 4-122.

6. Open the target model. If you want to change the default hardware configuration settings for the
model, see “Model Configuration Parameters” on page 2-2.

7. Select either the QEP or the Hall Speed_Feedback radio button in the target model.

8. Load a sample program to CPU2 of LAUNCHXL-F28379D. For example, you can use the program
that operates the CPU2 blue LED by using GPIO31 (c28379D_cpu2_blink.slx), and ensure that CPU2
is not mistakenly configured to use the board peripherals intended for CPU1.

9. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

10. Click the host model hyperlink in the target model to open the associated host model. You can
also use the open_system command to open the host model. Use this command for a F28379D based
controller.

open_system('mcb_bldc_host_model_f28379d.slx');

For on the serial communication between the host and target models, see “Host-Target
Communication” on page 6-2.
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11. In the Host Serial Setup block mask in the host model, select a Port name.

12. Update the reference speed value in the Reference Speed (RPM) field in the host model.

13. In the host model, select the debug signals that you want to monitor.

14. Click Run on the Simulation tab to run the host model.

15. Change the position of the Start / Stop Motor switch to On, to start running the motor.

16. Observe the debug signals from the RX subsystem, in the Scope and Display blocks in the host
model.
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Hall Sensor Sequence Calibration of BLDC Motor
This example calculates the Hall sensor sequence with respect to position zero of the rotor in open-
loop control.

A Hall effect sensor varies its output voltage based on the strength of the applied magnetic field.
According to the standard configuration, a brushless DC (BLDC) consists of three Hall sensors
located electrically 120 degrees apart. A BLDC motor with the standard Hall placement (where the
sensors are placed electrically 120 degrees apart) can provide six valid combinations of binary states:
for example, 001,010,011,100,101, and 110. The sensor provides the angular position of the rotor in
degrees in the multiples of 60, which the controller uses to determine the 60-degree sector where the
rotor is present.

The target model runs the motor at a low speed (10 RPM) in open loop and performs V/f control on
the motor. At this speed, the d-axis of the rotor closely aligns with the rotating magnetic field of the
stator.

When the rotor reaches the open-loop position zero, it aligns with the phase a-axis of the stator. At
this position (corresponding to a Hall state), the six-step commutation algorithm energizes the next
two phases of the stator winding, so that the rotor always maintains a torque angle (angle between
rotor d-axis and stator magnetic field) of 90 degrees with a deviation of 30 degrees.

The Hall sequence calibration algorithm drives the motor over a full mechanical revolution and
computes the Hall sensor sequence with respect to position zero of the rotor in open-loop control.

Note: This example works for all motor-phase or Hall sensor connections.
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Models

The example includes these models:

• mcb_hall_calibration_f28069mLaunchPad

• mcb_hall_calibration_f28379d.

You can use these models only for code generation. To open a Simulink® model, you can also use the
open_system command at the MATLAB® command prompt. For example, use this command for a
F28379D based controller:

open_system('mcb_hall_calibration_f28379d.slx');
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For details on the supported hardware configuration, see Required Hardware in the Generate Code
and Deploy Model to Target Hardware section.

Required MathWorks® Products

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™ (only needed for optimized code generation)

Generate Code and Deploy Model to Target Hardware

This section shows you how to generate code and run the motor by using open-loop control.

This example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
model is to deploy the target model to the controller hardware board.

The host model uses serial communication to command the target model and run the motor in an
open-loop configuration by using V/f control. The host model displays the calculated Hall sensor
sequence.

Required Hardware

The example supports these hardware configurations. You can also use the target model name to
open the model for the corresponding hardware configuration, from the MATLAB® command prompt.

• LAUNCHXL-F28069M controller + BOOSTXL-DRV8305 inverter:
mcb_hall_calibration_f28069mLaunchPad

• LAUNCHXL-F28379D controller + BOOSTXL-DRV8305 inverter: mcb_hall_calibration_f28379d
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For connections related to these hardware configurations, see “LAUNCHXL-F28069M and
LAUNCHXL-F28379D Configurations” on page 7-5.

Generate Code and Run Model on Target Hardware

1. Complete the hardware connections.

2. Open the target model for the hardware configuration that you want to use. If you want to change
the default hardware configuration settings for the target model, see “Model Configuration
Parameters” on page 2-2.

3. Update these motor parameters in the Configuration panel of the target model.

• Number of pole pairs
• PWM frequency [Hz]
• Data type for control algorithm
• Motor base speed
• Vd Ref in per-unit voltage

4. Load a sample program to CPU2 of LAUNCHXL-F28379D. For example, you can use the program
that operates the CPU2 blue LED by using GPIO31 (c28379D_cpu2_blink.slx), and ensures that CPU2
is not mistakenly configured to use the board peripherals intended for CPU1.

5. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

6. Click the host model hyperlink in the target model to open the associated host model. You can
also use the open_system command to open the host model. Use this command for a F28379D based
controller:

open_system('mcb_hall_calibration_host_f28379d.slx');
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For details on serial communication between the host and target models, see “Host-Target
Communication” on page 6-2.

You can use the Scope in the host model to monitor the open-loop rotor position and Hall sequence
values.

7. In the Host Serial Setup block mask in the host model, select a Port name.

8. Click Run on the Simulation tab to run the host model and start Hall sequence calibration for six-
step commutation control. The motor runs and calibration begins when you start simulation. After the
calibration process is complete, simulation ends and the motor stops automatically.

Note: If the motor does not start or rotate smoothly, increase the value of the Vd Ref in Per Unit
voltage field (maximum value is 1) in the Configuration panel. However, if the motor draws high
current, reduce this value.

As a convention, six-step commutation control uses a forward direction of rotation that is identical to
the direction of rotation used during Hall sequence calibration. To change the forward direction
convention, interchange the motor phase wires, perform Hall sequence calibration again, and then
run the motor by using six-step commutation control.
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9. See these LEDs on the host model to know the status of calibration process:

• The Calibration in progress LED turns orange when the motor starts running. Notice the rotor
position and the variation in the Hall sequence value in the Scope (the position signal indicates a
ramp signal with an amplitude between 0 and 1). After the calibration process is complete, this
LED turns grey.

• The Calibration complete LED turns green when the calibration process is complete. Then the
Calibration Output field displays the computed Hall sequence value.

Note: This example does not support simulation.

To immediately stop the motor during an emergency, click the Emergency Motor Stop button.

For examples that use six-step commutation using a Hall sensor, update the computed Hall sequence
value in the bldc.hallsequence variable in the model initialization script linked to the example. For
instructions, see “Estimate Control Gains from Motor Parameters” on page 3-2.
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Position Control of PMSM Using Quadrature Encoder
This example implements the field-oriented control (FOC) technique to control the position of a three-
phase permanent magnet synchronous motor (PMSM). The FOC algorithm requires rotor position
feedback, which it obtains from a quadrature encoder sensor.

You can use this example to implement position control applications by using closed-loop FOC. The
example drives the motor to reach the input reference-position value. You can also configure the
maximum number of rotations (in either direction) for the motor in the model initialization script.

For details about closed-loop FOC, see “Field-Oriented Control (FOC)” on page 4-2 and “Closed-Loop
Motor Control” on page 6-9.

Model

The example includes the mcb_pmsm_PosCtrl_f28379d model.

You can use this model for both simulation and code generation. You can also open the Simulink®
model using this command at the MATLAB® Command Window.

open_system('mcb_pmsm_PosCtrl_f28379d.slx');
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For details about the supported hardware configuration, see the Required Hardware topic in the
Generate Code and Deploy Model to Target Hardware section.

Required MathWorks® Products

To simulate model:

• Motor Control Blockset™

To generate code and deploy model:

• Motor Control Blockset™
• Embedded Coder®
• Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors
• Fixed-Point Designer™ (only needed for optimized code generation)

Prerequisites

1. Obtain the motor parameters. The Simulink® model uses default parameters that you can replace
with values from either the motor datasheet or other sources.

However, if you have the motor control hardware, you can estimate the parameters for the motor that
you want to use by using the Motor Control Blockset parameter estimation tool. For instructions, see
“Estimate Motor Parameters Using Motor Control Blockset Parameter Estimation Tool” on page 5-
2. The parameter estimation tool updates the motorParam variable (in the MATLAB® workspace)
with the estimated motor parameters.

2. Update motor parameters. If you obtain the motor parameters from the datasheet or from other
sources, update the motor and inverter parameters in the model initialization script associated with
the Simulink® model. For instructions, see “Estimate Control Gains from Motor Parameters” on page
3-2.

If you use the parameter estimation tool, you can update the inverter parameters, but do not update
the motor parameters in the model initialization script. The script automatically extracts the motor
parameters from the updated motorParam workspace variable.

Simulate Model

This example supports simulation. Follow these steps to simulate the model.

1. Open the model included with this example.

2. Click Run on the Simulation tab to simulate the model.

3. Click Data Inspector in the Review Results section to view and analyze the simulation results.

Generate Code and Deploy Model to Target Hardware

This section shows how to generate code and run the FOC algorithm on the target hardware.

This example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. Before you can run the host model
on the host computer, deploy the target model to the controller hardware board. The host model uses
serial communication to command the target Simulink® model and run the motor in closed-loop
control.
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Required Hardware

The example supports this hardware configuration. You can also use the target model name to open
the model from the MATLAB® command prompt.

LAUNCHXL-F28379D controller + (BOOSTXL-DRV8305 or BOOSTXL-3PHGANINV) inverter:
mcb_pmsm_PosCtrl_f28379d

Note: When using the BOOSTXL-3PHGANINV inverter, ensure that you have proper insulation
between the bottom layer of BOOSTXL-3PHGANINV and the LAUNCHXL board.

For connections related to this hardware configuration, see “LAUNCHXL-F28069M and LAUNCHXL-
F28379D Configurations” on page 7-5.

Generate Code and Run Model on Target Hardware

1. Simulate the target model and observe the simulation results.

2. Complete the hardware connections.

3. The model by default computes the ADC offset values for phase current measurement. To disable
this functionality, update the value of the inverter.ADCOffsetCalibEnable variable in the model
initialization script to 0.

Alternatively, you can compute the ADC offset values and update them manually in the model
initialization script. For instructions, see “Run 3-Phase AC Motors in Open-Loop Control and Calibrate
ADC Offset” on page 4-6.

4. Compute the quadrature encoder index offset value and update it in the model initialization script
associated with the target model. For instructions, see “Quadrature Encoder Offset Calibration for
PMSM Motor” on page 4-76.

5. Open the target model. If you want to change the default hardware configuration settings for the
model, see “Model Configuration Parameters” on page 2-2.

6. Load a sample program to CPU2 of the LAUNCHXL-F28379D board. For example, load the
program that operates the CPU2 blue LED by using GPIO31 (c28379D_cpu2_blink.slx). This ensures
that CPU2 is not mistakenly configured to use the board peripherals intended for CPU1.

7. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

8. Click the host model hyperlink in the target model to open the associated host model. You can
also use the open_system command to open the host model.

open_system('mcb_pmsm_host_model_PosCtrl.slx');
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For details on serial communication between the host and target models, see “Host-Target
Communication” on page 6-2.

9. In the dialog of the Host Serial Setup block in the host model, select a Port name.

10. Update the Reference Position [Degrees] value in the host model. By default, the maximum
number of rotations (in either the positive or negative direction) is five. You can change this value by
setting the PosCtrlPosLimit variable in the model initialization script. You can open this script by
using the hyperlink named Init script in the target model.

Maximum rotation limit (degrees) = PosCtrlPosLimit x 360

Note: You cannot control the speed of rotation of the motor, but you can limit it by setting the
PosCtrlSpeedLimit variable (in per-units). For details about the per-unit system, see “Per-Unit
System” on page 6-15.

11. Click Run on the Simulation tab to run the host model.

12. Change the position of the Start / Stop Motor switch to Start, to start running the motor.

13. Observe the debug signals from the RX subsystem, in the Time Scope of host model. You can
select the debug signals that you want to monitor in the Scope signals section of the host model.

• Speed Control - Display speed reference and speed feedback signals in the scope.

• Id Control - Display Id reference and Id feedback signals in the scope.

• Iq Control - Display Iq reference and Iq feedback signals in the scope.

• Ia & Ib - Display Ia and Ib current signals in the scope.

• Position Control - Display position reference and position feedback signals in the scope.
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Integrate MCU Scheduling and Peripherals in Motor Control
Application

This example shows how to identify and resolve issues with respect to peripheral settings and task
scheduling early during development.

The following are typical challenges associated with MCU peripherals and scheduling:

• ADC-PWM synchronization to achieve current sensing at mid point of PWM period
• Incorporate sensor delays to achieve the desired controller response for the closed loop system
• Studying different PWM settings while designing special algorithms

This example shows how to use SoC Blockset to address these challenges for a motor control closed-
loop application in simulation and verify on hardware by deploying on to the TI Delfino F28379D
LaunchPad.

Required hardware:

• TI Delfino F28379D LaunchPad or TI Delfino F2837xD based board
• BOOSTXL-DRV8305EVM motor driver board
• Teknic M-2310P-LN-04K PMSM motor

Model Structure
open_system('soc_pmsm_singlecpu_foc');
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Open the soc_pmsm_singlecpu_foc model. This model simulates single CPU motor controller,
contained in soc_pmsm_singlecpu_ref model, for a Permanent magnet synchronous motor inverter
system. Controller senses the outputs from the plant using ADC Interface (SoC Blockset) and actuates
using PWM Interface (SoC Blockset) that drives the inverter. Algorithm blocks from Motor Control
Blockset™ is used in this example.

ADC Acquisition Time

ADC hardware contains a sample and hold circuit to sense the analog inputs. To ensure complete
ADC measurement, the minimum acquisition time must be selected to account for the combined
effects of input circuit and the capacitor in the sample and hold circuit.

Open ADC Interface block and change the default acquisition time to 100ns. Run the simulation and
view the results in Simulation Data Inspector and observe there is a distortion in current waveforms.
The low acquisition time resulted in ADC measurements not reaching their true value. As a result, the
controller reacts by generating a relative duty cycle causing variations in current drawn by the motor.
These figures show the reaction to the incorrect ADC measurement and overdraw in the phase A
current channel, with phase A current in blue and phase B current in orange. The simulated speed
feedback shows significant oscillations during open loop to closed loop transition, which in real world
will halt the motor.

To fix this issue, open ADC Interface blocks change and change acquisition time to a larger value,
320ns. This value is the minimum ADC acquistion time recommended in Table 5-42 of the TI Delfino
F28379D LaunchPad data sheet. Run the simulation and view the results in Simulation Data
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Inspector. This figure shows the accurately sampled ADC values and the controller tracking the
reference value as expected.

Verify simulation results against hardware by deploying the model to the TI Delfino F28379D
LaunchPad. On the System on Chip tab, click Configure, Build, & Deploy to open the SoC Builder
(SoC Blockset) tool.

In the SoC Builder tool, on Peripheral Configuration tool, set ADC > SOCx acquisition window
cycles parameter to 13 ADC clock ticks for the ADC B and C modules. The ADC acquisition clock
ticks parameter must be set to the simulation time value, set in the ADC Interface block, multiplied
by the ADC clock frequency. You can get the ADC clock frequency from the model hardware settings.
Open the soc_pmsm_singlecpu_ref model. On the System on Chip tab, click Hardware Settings to
open the Configuration Parameters window. In the Hardware Implementation > Target
hardware resources > ADC_x section, you can see the ADC clock frequency in MHz parameter
value. This figure shows the ADC Interface block setting for simulation and peripheral app setting for
deployment. Use same setting in simulation and codegen to ensure expected behavior.
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On Select Build Action page, to monitor data from hardware select Build and load for
External mode. This figure shows the data from hardware with accurately sampled ADC values and
the controller tracking the reference value as expected.
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ADC-PWM Synchronization

The BOOSTXL-DRV8305EVM motor driver has a 3-phase inverter built using 6 power MOSFETS. This
motor driver board uses a low-side shunt resistor to sense motor currents. The Current sense circuit
amplifies the voltage drop across the shunt. This setup ensures low power dissipation, since the
current only flows through the shunt when the bottom switches are on and away from PWM
commutation noise. This figure shows the low-side shunt resistor circuit in BOOSTXL-DRV8305EVM
motor drive.

For correct operation, current sensing must occur during the mid point of the PWM period when
ADCs trigger. Specifically, the PWM counter must be at the maximum value when the bottom switches
are active in the Up-Down counter mode. Current sampling at a different instance results in a
measured currents of zero.

To analyze this case, switch the model to high fidelity inverter simulation mode. Change the plant
variant to use detailed MOSFET based 3-phase inverter to replicate BOOSTXL-DRV8305EVM.

set_param('soc_pmsm_singlecpu_foc/Inverter and Motor/Average or Switching',...
'LabelModeActivechoice','SwitchingInverter');

Change the Output mode parameter of PWM Interface (SoC Blockset) to Switching and connect 6
PWMs to the Mux block.
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set_param('soc_pmsm_singlecpu_foc/PWM Channel/PWM Interface', 'OutSigMode', 'Switching');
set_param('soc_pmsm_singlecpu_foc/PWM Channel/PWM Interface1', 'OutSigMode','Switching');
set_param('soc_pmsm_singlecpu_foc/PWM Channel/PWM Interface2', 'OutSigMode', 'Switching');

Delete existing connection between PWM Interface block and Mux.

h = get_param('soc_pmsm_singlecpu_foc/PWM Channel/Mux','LineHandles');
delete_line(h.Inport);

As a last step, connect 6 PWM outputs to Mux.

set_param('soc_pmsm_singlecpu_foc/PWM Channel/Mux','Inputs','6');

add_line('soc_pmsm_singlecpu_foc/PWM Channel', ...
{'PWM Interface/1', 'PWM Interface/2', 'PWM Interface1/1',...
'PWM Interface1/2', 'PWM Interface2/1', 'PWM Interface2/2'}, ...
{'Mux/1','Mux/2','Mux/3','Mux/4','Mux/5','Mux/6'}, 'autorouting', 'smart');

Open the PWM Interface blocks and set Event trigger mode to End of PWM period. Run the
simulation and view the results in Simulation Data Inspector. In the figure, phase A and phase B
currents are approximately zero current. This results in a loss of feedback and no actuation in the
control loop. Select Enable task simulation in Task Manager block to simulate and visualize
tasks in Simulation Data Inspector.
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To fix this issue, change the Event trigger mode to Mid point of PWM period, equivalent to the
PWM internal counter being at a maximum. Run the simulation and view the results in Simulation
Data Inspector.

Deploy the model on to the TI Delfino F28379D LaunchPad using the SoC Builder (SoC Blockset) tool.
In the SoC Builder tool, on Peripheral configuration tool, set PWM event condition to Counter
equals to period. Use same setting in simulation and codegen to ensure expected behavior. This
figure shows the PWM Interface block setting for simulation and the Peripheral Configuration tool
setting for deployment.
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This figure shows the data from simulation and hardware with correct ADC-PWM synchronization and
the controller tracking the reference value as expected.

 Integrate MCU Scheduling and Peripherals in Motor Control Application

4-139



See Also

• “Get Started with SoC Blocks on MCUs” (SoC Blockset)
• “Partition Motor Control for Multiprocessor MCUs” on page 4-141

Copyright 2020-2021 The MathWorks, Inc.
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Partition Motor Control for Multiprocessor MCUs
This example shows how to partition real-time motor control application on to multiple processors to
achieve design modularity and improved control performance.

Many MCUs provide multiple processor cores. These additional cores can be leveraged to achieve a
variety of design goals:

• Divide the application into real-time tasks, such as control laws, and non-real time tasks, such as
external communication, diagnostics, or machine learning

• Partition the control algorithm to run on multiple CPUs to achieve higher loop rate
• Run the same application in multiple CPUs for safety critical applications

This example shows how to partition motor control application across two CPUs of the TI Delfino
F28379D to achieve higher sampling time/PWM frequency.

Required hardware:

• TI Delfino F28379D LaunchPad or TI Delfino F2837xD based board
• BOOSTXL-DRV8305EVM motor driver board
• Teknic M-2310P-LN-04K PMSM motor

Partition Motor Control Algorithm

Open the soc_pmsm_singlecpu_foc model. This model simulates a single CPU motor controller,
contained in the soc_pmsm_singlecpu_ref model, for a permanent magnet synchronous machine
(PMSM).
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We partition the control algorithm by executing current control on CPU2, and speed control and
position estimation on CPU1 respectively. Data transfer between the CPU's are handled by
Interprocess Data Channel block. For more information see “Interprocess Data Communication via
Dedicated Hardware Peripheral” (SoC Blockset).

Open the soc_pmsm_dualcpu_foc model.

open_system('soc_pmsm_dualcpu_foc');
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On the System on Chip tab, click Hardware Settings to open the Configuration Parameters
window. In the Hardware Implementation tab, the Processing Unit parameter is configured to
"None" indicating it is the top-level system model.

Open the soc_pmsm_cpu1_ref model and open the soc_pmsm_cpu2_ref model to view algorithms
configured for each CPU. Model references contained within the system model are configured to run
on c28xCPU1 (CPU1) and c28xCPU2 (CPU2).

On the Simulation tab, click 'Play' to simulate the model. Open the Simulation Data Inspector and
view signals. This figure shows results from the single and dual CPU models in simulation and
deployment.
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Performance Improvement with Concurrent Execution

Using both CPUs to execute control algorithms allows us to achieve higher controller bandwidth. In
the original single CPU model, the control algorithm takes just over 25us to execute. To provide a
safety margin, single CPU model uses a PWM frequency of 20kHz, equivalent to 50us period.

After partitioning, the CPU1 and CPU2 execution times reduce to less than 20us. Allowing the PWM
frequency to be increase to 40kHz. In the mcb_pmsm_foc_sensorless_f28379d_data.m script,
set PWM_frequency to 40e3 and run the script to configure the model to the new PWM frequency.
With faster sampling of currents, controller gains can then be tuned to achieve faster response times.

Deploy the model to the TI Delfino F28379D LaunchPad using the SoC Builder (SoC Blockset) tool. To
open the tool, on the System on Chip tab, click Configure, Build, & Deploy, and follow the guided
steps.

This figure shows the controller response from simulation and deployment at 25us current loop with
40kHz PWM frequency compared with 50us current loop at 20kHz frequency. As expected, the rise
time in speed improves with faster current loop by approximately 50 percent.
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Speed response is oscillatory because of sensorless algorithm, for more information see “Sensorless
Field-Oriented Control of PMSM” on page 4-49

For higher simulation granulairty, set the PWM Interface block output to Switching Mode and change
the plant model variant to use the MOSFET simulation.

See Also

• “Get Started with SoC Blocks on MCUs” (SoC Blockset)
• “Integrate MCU Scheduling and Peripherals in Motor Control Application” on page 4-132

Copyright 2020-2021 The MathWorks, Inc.
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Frequency Response Estimation of PMSM Using Field-Oriented
Control

This example performs frequency response estimation (FRE) of a plant model running a three-phase
permanent magnet synchronous motor (PMSM). When you either simulate or run the model on the
target hardware, it runs tests to estimate the frequency response as seen by each PI controller (also
known as raw FRE data) and plots the FRE data to provide a graphical representation of the plant
model dynamics.

When the motor runs in a steady state, the online Frequency Response Estimator block that is
connected to each PI control loop (Id current, Iq current, and speed) sequentially perturbs the PI
controller output and estimates the frequency response of the plant model as seen by each PI
controller. You can use the frequency response of the plant to estimate the PI controller gains.

The model uses the field-oriented control (FOC) technique to control the PMSM. The FOC algorithm
requires rotor position feedback, which is obtained by a quadrature encoder sensor. For details about
FOC, see “Field-Oriented Control (FOC)” on page 4-2.

Models

The example includes the model (target model) mcb_pmsm_freq_est_f28379d.

You can use this model for both simulation and code generation. You can also use the open_system
command to open the model.

open_system('mcb_pmsm_freq_est_f28379d.slx');
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For details regarding the supported hardware configuration, see the Required Hardware topic in the
Generate Code and Deploy Model to Target Hardware section.

Required MathWorks® Products

To simulate model:

• Motor Control Blockset™

• Simulink Control Design™

To generate code and deploy model:

1. Motor Control Blockset™

2. Embedded Coder®

3. Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors

4. Simulink Control Design™

Prerequisites

1. Obtain the motor parameters. We provide default motor parameters with the Simulink® model that
you can replace with the values from either the motor datasheet or other sources.

However, if you have the motor control hardware, you can estimate the parameters for the motor that
you want to use, by using the Motor Control Blockset parameter estimation tool. For instructions, see
“Estimate Motor Parameters Using Motor Control Blockset Parameter Estimation Tool” on page 5-
2.

The parameter estimation tool updates the motorParam variable (in the MATLAB® workspace) with
the estimated motor parameters.
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2. If you obtain the motor parameters from the datasheet or other sources, update the motor
parameters and inverter parameters in the model initialization script associated with the Simulink®
models. For instructions, see “Estimate Control Gains from Motor Parameters” on page 3-2.

If you use the parameter estimation tool, you can update the inverter parameters, but do not update
the motor parameters in the model initialization script. The script automatically extracts motor
parameters from the updated motorParam workspace variable.

Simulate Model

This example supports simulation. Follow these steps to simulate the model.

1. Open the target model included with this example.

2. Click Run on the Simulation tab to simulate the model.

3. Click Data Inspector on the Simulation tab to view and analyze the simulation results.

4. On the target model, click the Plot freq response hyperlink to plot the frequency response data of
the plant model (sys_sim_id, sys_sim_iq, and sys_sim_spd variables in the workspace) that the
speed control loop and the current control loops measure.

Generate Code and Deploy Model to Target Hardware

This section instructs you to generate code, run the FOC algorithm on the target hardware, start
frequency response estimation, and plot the FRE data.

This example uses a host and a target model. The host model is a user interface to the controller
hardware board. You can run the host model on the host computer. The prerequisite to use the host
model is to deploy the target model to the controller hardware board. The host model uses serial
communication to command the target Simulink® model and run the motor in a closed-loop control.

Required Hardware

This example supports this hardware configuration. You can also use the target model name to open
the model from the MATLAB® command prompt.

• LAUNCHXL-F28379D controller + (BOOSTXL-DRV8305 or BOOSTXL-3PHGANINV) inverter:
mcb_pmsm_freq_est_f28379d

NOTE: When using the BOOSTXL-3PHGANINV inverter, ensure that proper insulation is available
between bottom layer of BOOSTXL-3PHGANINV and the LAUNCHXL board.

For connections related to the preceding hardware configurations, see “LAUNCHXL-F28069M and
LAUNCHXL-F28379D Configurations” on page 7-5.

Generate Code and Run Model on Target Hardware

1. Simulate the target model and observe the simulation results.

2. Complete the hardware connections.

3. The model automatically computes the ADC (or current) offset values. To disable this functionality
(enabled by default), update the value 0 to the variable inverter.ADCOffsetCalibEnable in the
model initialization script.
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Alternatively, you can compute the ADC offset values and update it manually in the model
initialization scripts. For instructions, see “Run 3-Phase AC Motors in Open-Loop Control and
Calibrate ADC Offset” on page 4-6.

4. Compute the quadrature encoder index offset value and update it in the pmsm.PositionOffset
variable available in the model initialization script associated with the target model. For instructions,
see “Quadrature Encoder Offset Calibration for PMSM Motor” on page 4-76.

5. Open the target model for the hardware configuration that you want to use. If you want to change
the default hardware configuration settings for the model, see “Model Configuration Parameters” on
page 2-2.

6. Load a sample program to CPU2 of LAUNCHXL-F28379D, for example, program that operates the
CPU2 blue LED by using GPIO31 (c28379D_cpu2_blink.slx), to ensure that CPU2 is not
mistakenly configured to use the board peripherals intended for CPU1.

7. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

8. Click the host model hyperlink in the target model to open the associated host model. You can
also use the open_system command to open the host model.

open_system('mcb_pmsm_freq_host_f28379d.slx');
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For details about the serial communication between the host and target models, see “Host-Target
Communication” on page 6-2.

9. In the Host Serial Setup block mask of the host model, select a Port name.

10. Change the position of the Start / Stop Motor switch to On, to start running the motor.

11. Update the Reference Speed value in the host model.
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12. Select the debug signal that you want to monitor in the Debug signals section of the host model.
Observe these signals in the SelectedSignals time scope.

13. Click the FRE Trigger button to start the FRE process on the target hardware.

14. Select Position & Raw FRE data in the Debug signals section of the host model to start
receiving the raw FRE data from the target hardware. The FRE Status LED turns amber to indicate
that the host model is receiving raw FRE data from the target hardware.

NOTE: The LED shows the correct status only when you select Position & Raw FRE data in the
Debug signals section. Otherwise, the LED remains grey.

15. Check the status of the FRE Status LED on the host model. The LED turns green after the host
model receives all the raw FRE data from the target hardware.

16. Click the FRE Plot button to plot the raw FRE data received from the target hardware.

17. On the host model, click Stop on the Simulation tab to stop the simulation.

18. Click the compare hyperlink in the host model to plot the raw FRE data generated during
simulation and hardware run together and compare them.

For an accurate comparison, we recommend that you use the same reference speed during simulation
and when running the example on the target hardware.
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NOTE:

• To stop the FRE process any time, click the FRE Abort button.

• To stop the motor immediately, turn the Start / Stop Motor switch Off.

Configure Frequency Response Estimator Block

Configure these parameters in the Frequency Response Estimator block (from Simulink Control
Design™ toolbox) mask:

• Sample time (Ts) - Enter a block sample time that is identical to that of the PI controller.

• Frequencies - Enter an array of frequencies at which the block perturbs the PI controller output to
estimate the frequency response of the plant. This field uses the (single data type) workspace
variable fre.i_freq to store the array of perturbation signal frequencies.
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NOTE: By default, the model uses an array size of fifteen. However, you can configure the array size.

The start/stop signal value of 1 that started the FRE experiment should change to 0 only after the
perturbations and tests for all the frequencies are complete and the FRE experiment ends.

• Amplitudes - Enter the amplitude of the perturbation signals that the block applies to the PI
controller output to estimate the frequency response of the plant. This field uses the (single data
type) workspace variable fre.i_amp to store the common amplitude value of the perturbation
signals.

A high amplitude produces disturbances when the motor runs. An amplitude that is too low results in
an inaccurate FRE.

For more details about the Frequency Response Estimator block, see Frequency Response Estimator
(Simulink Control Design).

Frequency Response Estimator Block Output

The Frequency Response Estimator block (connected to each PI controller) performs an FRE
experiment by perturbing the PI controller output using the sequence of frequencies stored in
fre.i_freq.

For each perturbation signal (represented by a frequency) the block estimates the plant frequency
response in the form of a complex number. Therefore, block uses the array of frequencies to generate
an array of complex numbers (raw FRE data).

The generated sequence of complex numbers contains the information related to gain and phase
delay.

Controlling FRE Experiments

The State Machine Control subsystem algorithm enables the three Frequency Response Estimator
blocks one at a time (and therefore, runs the three FRE experiments) in this order by using the start/
stop input port of the Frequency Response Estimator block:

1. FRE block connected to Id control loop

2. FRE block connected to Iq control loop

3. FRE block connected to speed control loop

The state machine control ensures that the time interval between the start and stop signals is greater
than or equal to the FRE experiment length (as displayed by the Frequency Response Estimator block
dialog). Therefore, if you change the perturbation signal frequencies, ensure that the state machine
control sends the stop signal only after the FRE experiment ends.

For more details about the Frequency Response Estimator block, see Frequency Response Estimator
(Simulink Control Design).

Plot Frequency Response After Simulation

After the simulation ends, the target model stores the frequency response (or the raw FRE data) in
these workspace variables:

• out.Idfreqdata- raw FRE data for the Id current PI controller.
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• out.Iqfreqdata - raw FRE data for the Iq current PI controller.

• out.Spdfreqdata - raw FRE data for the speed PI controller.

When you click the Plot freq response hyperlink on the target model, it plots the frequency
response for the three PI controllers.

The target model uses these commands to plot the frequency responses as seen by the three PI
controllers:

Frequency response of Id current PI controller:
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sys_sim_id = frd(out.Idfreqdata,fre.i_freq*2*pi);

bode(sys_sim_id);

Frequency response of Iq current PI controller:

sys_sim_iq = frd(out.Iqfreqdata,fre.i_freq*2*pi);

bode(sys_sim_iq);

Frequency response of speed PI controller:

sys_sim_spd = frd(out.Spdfreqdata,fre.spd_freq*2*pi);

bodeplot(sys_sim_spd);

For more information about these commands, see these files:

• mcb_pmsm_freq_est_plot.m

• mcb_pmsm_freq_host_est_plot.m

Send Raw FRE Data to Host Model

When running the target model on the hardware, it transfers the raw FRE data continuously to the
host model.

The target model splits the entire sequence of the complex numbers (or raw FRE data) from each
FRE block into real and imaginary arrays and adds headers to separate them. It uses this format to
send the raw FRE data from each FRE block to the host model by using serial communication.

Plot Frequency Response When Using Target Hardware

After receiving the message from the target hardware, the host model decrypts the message and
stores the array of complex numbers (raw FRE data) in these workspace variables:
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• IdfreqData - raw FRE data for the Id current PI controller.

• IqfreData - raw FRE data for the Iq current PI controller.

• SpdfreqData - raw FRE data for the speed PI controller.

When you click the FRE Plot button, the host model plots the frequency response for the three PI
controllers.

The host model uses these commands to plot the frequency responses observed for the three PI
controllers:

Frequency response of Id current PI controller:

sys_hw_id=frd(IdFreqData.signals.values,fre.i_freq*2*pi);
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bode(sys_hw_id);

Frequency response of Iq current PI controller:

sys_hw_iq=frd(IqFreqData.signals.values,fre.i_freq*2*pi);

bode(sys_hw_iq);

Frequency response of speed PI controller:

sys_hw_spd=frd(SpdFreqData.signals.values,fre.spd_freq*2*pi);

bode(sys_hw_spd);

For more information about these commands, see these files:

• mcb_pmsm_freq_est_plot.m

• mcb_pmsm_freq_host_est_plot.m

Tuning PI Controller Gains

These steps describe how to tune and determine the gains for the Id current, Iq current, and speed PI
controllers:

1. Navigate to Simulink tool strip > Apps and open the PID Tuner app.

2. In the PID Tuner tab, select PI for Type, Parallel for Form, and Frequency for Domain.

3. In the PID Tuner tab, select Plant > Import.
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4. In the Import Linear System window, select sys_sim_id and click Import to import the FRE data
for the Id PI controller.

5. Select Add Plot > Bode > Open-loop to open the open-loop bode plot for the Id PI controller.
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6. Use the Tuning Tools section in the PID Tuner tab to tune the bandwidth and phase margin and
observe the results in the open-loop and plant bode plots.
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7. After completing tuning click Show Parameters to display the tuned controller parameters Kp
and Ki for the Id current PI controller.
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8. Repeat steps 3 to 7 by selecting sys_sim_iq in the Import Linear System window to obtain the
tuned parameters Kp and Ki for the Iq PI controller.

9. Update the Kp and Ki gain values for both Id and Iq current PI controllers in the initialization
script of the example model mcb_pmsm_freq_est_f28379d.slx. For instructions, see “Estimate
Control Gains from Motor Parameters” on page 3-2.

10. Perform the frequency response estimation again using the updated PI controller gains by either
simulating the example or running it on the target hardware.

11. Perform steps 3 to 7 by selecting sys_sim_spd in the Import Linear System window to obtain
the tuned parameters Kp and Ki for the speed PI controller.

See Also

• “PID Controller Tuning in Simulink” (Simulink Control Design)

Other Things to Try

You can try estimating the transfer functions and state-space models from the FRE data by using
these functions from the System Identification Toolbox™:

• ssest

• tfest
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MATLAB Project for FOC of PMSM with Quadrature Encoder
This MATLAB® project provides a motor control example model that uses field-oriented control
(FOC) to run a three-phase permanent magnet synchronous motor (PMSM) in different modes of
operation. Implementing the FOC algorithm needs real-time rotor position feedback. This example
uses a quadrature encoder sensor to measure the rotor position. For details about FOC, see “Field-
Oriented Control (FOC)” on page 4-2.

The example can run a motor in these modes:

• StandBy - In this mode, the motor stops running because the inverter outputs zero volts.

• Calibration - In this mode, the example calibrates the ADC (or current) offset and the quadrature
encoder offset (offset between the d-axis of the rotor and the encoder index pulse position as
detected by the quadrature encoder sensor).

• Open Loop Speed Control - In this mode, the example controls the rotor speed by running the
motor in the open-loop control.

• Closed Loop Torque Control - In this mode, the example controls the torque output of the motor
by running it in the closed-loop control.

• Closed Loop Speed Control - In this mode, the example controls the rotor speed by running the
motor in the closed-loop control.

Note: When running the example model on the hardware, we recommend that you stop the motor (by
switching to the StandBy mode) before transitioning from one operating mode to another.

Open MATLAB Project

Use one of these methods to open the MATLAB project to follow this workflow:

1. Click Open Example.

2. Run the command mcb_QEPWorkflowDemoStart at the command prompt.

Model

The MATLAB project includes the model mcb_qep_workflow.

This model (also called target model) automatically opens when you open the MATLAB project. You
can also use the Project window to open this model available in the model folder.
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Required MathWorks® Products

To simulate model:

• Motor Control Blockset™

• Stateflow®

To generate code and deploy model:

1. Motor Control Blockset™

2. Embedded Coder®

3. Embedded Coder® Support Package for Texas Instruments™ C2000™ Processors

4. Fixed-Point Designer™ (only needed for optimized code generation)

5. Stateflow®

Prerequisites

1. Obtain the motor and inverter parameters. The MATLAB project uses default motor and inverter
parameters that you can replace with values from either the motor and inverter datasheets or from
other sources.
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• You can estimate the parameters for the motor that you want to use with the motor control
hardware, by using the Motor Control Blockset parameter estimation tool. For instructions, see
“Estimate Motor Parameters Using Motor Control Blockset Parameter Estimation Tool” on page 5-
2.

The parameter estimation tool updates the motorParam variable (in the MATLAB® workspace) with
the estimated motor parameters.

2. Update the motor and inverter parameters in the mcb_qep_data.m parameter script associated
with the MATLAB project. This script automatically opens when you open the MATLAB project. You
can also use the Project window to open this script from the utils folder.

3. Click Run on the Editor tab to run the parameter script and update the script parameters in the
data dictionary. The data dictionary file (pmsm_qep_data.sldd) is available inside the data folder in
the Project window.

Note: When you simulate the target model or run it on the hardware, if you change any parameter
value in the parameter script, you must run the parameter script to update the data dictionary.

Simulate Model

Follow these steps to simulate the target model.

1. Open the target model included in the MATLAB project.

2. Turn the Stop-Start slider switch available in the Simulation Dashboard area to the Start
position to allow the model to simulate and run the motor.

During simulation, you can turn the switch to the Stop position anytime to immediately stop the
motor.

3. Click Run on the Simulation tab to simulate the model.

Open Loop Speed Control mode

1. Select Open Loop Speed Control in the Simulation Dashboard > Operating Modes area of
the target model.

2. Enter the values in the Reference Speed [RPM] and Load Torque [Nm] fields.

Note: In the open-loop mode, the motor runs only if the load torque value is either zero or a very
small value. If you use a high load torque value, the motor can stop.

Closed Loop Torque Control mode

1. Select Closed Loop Torque Control in the Simulation Dashboard > Operating Modes area of
the target model.

2. Enter the reference torque value in the Reference Torque [Nm] field.

3. You can simulate the locked rotor situation by moving the Rotor Lock slider switch to On position.

When you move the switch to Off position, the rotor rotates freely within a maximum speed limit that
is defined by the variable data.pmsm.wLimit_TorqueMode in the mcb_qep_data.m parameter
script.
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Note: The Rotor Lock slider switch is applicable only when performing simulation in this operating
mode. It has no effect during the other modes.

Closed Loop Speed Control mode

1. Select Closed Loop Speed Control in the Simulation Dashboard > Operating Modes area of
the target model.

2. Enter the values in the Reference Speed [RPM] and Load Torque [Nm] fields.

NOTE:

• In the closed-loop mode, the motor runs only if the load torque value is less than or equal to the
rated torque of the motor. If you use a higher load torque, the motor starts running in the opposite
direction.

• When you simulate the target model, the calibration operating mode produces an invalid
simulation output because this mode is designed to calibrate the hardware setup.

When simulating this example, you can observe the measured speed and torque values in the
Measured Torque [Nm] and Measured Speed [RPM] fields in the Simulation Dashboard area.

Generate Code and Deploy Model to Target Hardware

This section shows you how to generate code and run the FOC algorithm on the target hardware.

In addition to the target model, the MATLAB project uses a host model. The host model, which is a
user interface to the controller hardware board, runs on the host computer. To use the host model,
first deploy the target model to the controller hardware board. The host model uses serial
communication to command the model, run (and control) the motor in the selected operating mode,
and collect and display the calibration output, and debug signals from the controller.

Required Hardware

The example supports this hardware configuration.

• LAUNCHXL-F28379D controller + (BOOSTXL-DRV8305 or BOOSTXL-3PHGANINV) inverter

You can select one of these inverters by setting the mcb_SetInverterParameters argument in the
parameter script file (mcb_qep_data.m) to one of these values:

• BoostXL-DRV8305

• BOOSTXL-3PhGaNInv

For connections related to this hardware configuration, see “LAUNCHXL-F28069M and LAUNCHXL-
F28379D Configurations” on page 7-5.

Generate Code and Run Model on Target Hardware

1. Simulate the target model and observe the simulation results.

2. Complete the hardware connections.

3. Open the target model. If you want to change the default hardware configuration settings for the
model, see “Model Configuration Parameters” on page 2-2.
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4. To ensure that CPU2 is not configured to use the board peripherals intended for CPU1, load a
sample program to CPU2 of LAUNCHXL-F28379D, for example, program that operates the CPU2 blue
LED by using GPIO31 (c28379D_cpu2_blink.slx).

5. Click Build, Deploy & Start on the Hardware tab to deploy the target model to the hardware.

6. Click the host model hyperlink in the target model to open the associated host model.

7. Turn the Stop-Start slider switch in the Control Dashboard area to the Start position to allow
the model to run the motor.

When running the motor using the target hardware, turn the switch to the Stop position anytime to
immediately stop the motor.

8. In the Host Serial Setup block mask of the host model, select a Port name.

9. Click Run on the Simulation tab to run the host model.

Note: Always stop the motor (by using the StandBy mode) before changing the operating mode.

Instructions for Calibration mode

1. Select StandBy in the Control Dashboard > Operating Modes area of the host model to stop
the motor.

2. Select Calibration in the Control Dashboard > Operating Modes area of the host model.

The controller runs the motor and performs ADC (or current) offset and quadrature encoder offset
calibration and updates these offset parameters in the data dictionary file (pmsm_qep_data.sldd):
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• pmsm.PositionOffset

• inverter.CtSensAOffset

• inverter.CtSensBOffset

The host model also displays the offset values in these fields available in the Calibration Output
area:

• Position Offset

• Current Sensor Offset A

• Current Offset B

3. Update these offset parameters in the parameter script file (mcb_qep_data.m) before you run the
parameter script:

• data.pmsm.PositionOffset

• data.inverter.CtSensAOffset

• data.inverter.CtSensBOffset

Note: Update the parameter script immediately to avoid losing these offset values. MATLAB project
rewrites the data dictionary (with the existing parameter script values) every time you run the
parameter script.

For details about these parameters, see “Estimate Control Gains from Motor Parameters” on page 3-
2.

4. After the calibration completes, the offset parameters are erased if you reset the target hardware.
Click Build, Deploy & Start on the Hardware tab to program the target hardware with the
calibrated offset parameters.

Instructions for Open Loop Speed Control mode

1. Select StandBy in the Control Dashboard > Operating Modes area of the host model to stop
the motor.

2. Select Open Loop Speed Control in the Control Dashboard > Operating Modes area of the
host model.

The controller runs the motor in the open-loop control.

3. You can change the default reference speed value by using the Reference Speed [RPM] in the
Control Dashboard > Speed Control area of the host model.

Note:

• Be cautious when providing a reference speed. The motor may not run optimally at all speeds. We
recommend that you use a low speed initially and increase it gradually.

• In the open-loop mode, the motor runs only if the load is either zero or negligible. If you use a
higher load, the motor stops running.
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• You do not need to calibrate the ADC (or current) and quadrature encoder sensor when you run
the motor in open-loop control.

Instructions for Closed Loop Speed Control mode

1. Run the motor in the open-loop configuration to validate the hardware setup. Follow the steps
described in the Instructions for Open Loop Speed Control mode section.

2. Perform ADC (or current) offset and quadrature encoder offset calibration. Follow the steps
described in the Instructions for Calibration mode section.

3. Select StandBy in the Control Dashboard > Operating Modes area of the host model to stop
the motor.

4. Select Closed Loop Speed Control in the Control Dashboard > Operating Modes area of the
host model.

The controller runs the motor in the closed-loop control and controls the rotor speed.

5. You can change the default reference speed value by using the Reference Speed [RPM] in the
Control Dashboard > Speed Control area of the host model.

Note: In the closed-loop mode, the motor runs only if the load torque is less than or equal to the
rated load of the motor. If you use a higher load torque, the motor stops running.

Instructions for Closed Loop Torque Control mode

1. Run the motor in the open-loop configuration to validate the hardware setup. Follow the steps
described in the Instructions for Open Loop Speed Control mode section.

2. Perform the ADC (or current) offset and quadrature encoder offset calibration if you have not done
so earlier. Follow the steps described in the Instructions for Calibration mode section.

3. Select StandBy in the Control Dashboard > Operating Modes area of the host model to stop
the motor.

4. Select Closed Loop Torque Control in the Control Dashboard > Operating Modes area of the
host model.

The controller runs the motor in the closed-loop configuration and controls the torque of the motor.

5. You can change the default reference torque value by using the Reference Torque [Nm] in the
Control Dashboard > Speed Control area of the host model.

You can configure the maximum speed limit of the motor in the closed loop torque control mode using
the variable data.pmsm.wLimit_TorqueMode in the mcb_qep_data.m parameter script.

When running the motor using the target hardware in these operating modes, you can select the
debug signals (in the Scope signals area) that you want to monitor in the SelectedSignals time
scope.
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Estimate Motor Parameters Using Motor Control Blockset
Parameter Estimation Tool

Motor Control Blockset provides a parameter estimation tool that estimates the motor parameters
accurately. Use the estimated motor parameters to simulate the motor model and design the control
system. Therefore, the simulation response with the estimated parameters for the motor model is
close to the behavior of the motor under test.

The parameter estimation tool determines these motor parameters for a Permanent Magnet
Synchronous Motor:

Motor parameters Units
Phase resistance (Rs) Ohm
d and q axis inductances (Ld and Lq) Henry
Back-EMF constant (Ke) Vpk_LL/krpm

(where Vpk_LL is the peak voltage line-to-line
measurement)

Motor inertia (J) Kg.m^2
Friction constant (F) N.m.s

The parameter estimation tool accepts the minimum required inputs, runs tests on the target
hardware, and displays the estimated parameters.

Prerequisites
The parameter estimation tool needs the motor position as detected by either a quadrature encoder, a
Hall sensor, or a sensorless flux observer. To detect the motor position correctly by using a position
sensor, you need to calibrate the quadrature encoder or Hall sensor attached to the motor under test.

• Ensure that the PMSM is in no-load condition.

If you are using Hall sensors:

• Ensure that the PMSM has Hall sensors.
• Calibrate the Hall sensor offset. For instructions, see “Hall Offset Calibration for PMSM Motor” on

page 4-66.

If you are using a quadrature encoder sensor:

• Ensure that the PMSM has a quadrature encoder sensor.
• Calibrate the quadrature encoder offset. For instructions, see “Quadrature Encoder Offset

Calibration for PMSM Motor” on page 4-76.

Note If you set the Sensor Selection field in the host model to Sensorless, you can skip the
position sensor calibration step.
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Supported Hardware
This example supports only these hardware configurations:

Texas Instruments™ F28069M control card configuration:

• F28069M control card
• DRV8312-69M-KIT inverter
• A PMSM with a Hall or a quadrature encoder sensor
• DC power supply

Note The DRV8312-69M-KIT board has a known issue in the board's power supply section. Due to
this limitation, the board does not support all Hall sensor types. For example, it does not support the
Hall sensor of Teknic M-2310P motor.

Texas Instruments LAUNCHXL-F28379D configuration:

• LAUNCHXL-F28379D controller
• BOOSTXL-DRV8305 inverter
• A PMSM with a Hall or a quadrature encoder sensor
• DC power supply

Required MathWorks Products
To run parameter estimation, you need these products:

• Motor Control Blockset
• Fixed-Point Toolbox™

Only to build the target models, you need these optional products:

• Embedded Coder®

• Embedded Coder Support Package for Texas Instruments C2000™ Processors

Prepare Hardware
For the F28069M control card configuration:

1 Connect the F28069M control card to J1 of DRV8312-69M-KIT inverter board.
2 Connect the motor three phases to MOA, MOB, and MOC on the inverter board.
3 Connect the DC power supply to PVDDIN on the inverter board.
4 If you are using a Hall sensor, connect the Hall sensor encoder output to J10 on the inverter

board.
5 If you are using a quadrature encoder sensor, connect the quadrature encoder pins (G, I, A, 5V, B)

to J4 on the inverter board.

For the LAUNCHXL-F28379D configuration:
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1 Attach the inverter board to the controller board such that J1, J2 of BOOSTXL aligns with J1, J2 of
LAUNCHXL.

2 Connect the motor three phases to MOTA, MOTB, and MOTC on the BOOSTXL inverter board.
3 Connect the DC power supply to PVDD and GND on the BOOSTXL inverter board.
4 If you are using a Hall sensor, connect the Hall sensor output to QEP_B (configured as eCAP) on

LAUNCHXL.
5 If you are using a quadrature encoder sensor, connect the quadrature encoder pins (G, I, A, 5V, B)

to QEP_A on the LAUNCHXL controller board.

For more details regarding these connections, see “Hardware Connections” on page 7-2.

For more details regarding the model settings, see “Model Configuration Parameters” on page 2-2.

For LAUNCHXL-F28379D, load a sample program to CPU2, for example, program that operates the
CPU2 blue LED using GPIO31 (c28379D_cpu2_blink.slx) to ensure that CPU2 is not mistakenly
configured to use the board peripherals intended for CPU1.

Parameter Estimation Tool
The parameter estimation tool includes a target model and a host model. The models communicate
with each other by using a serial communication interface. For more details, see “Host-Target
Communication” on page 6-2.

Enter the system details about the motor under test in the host model. The target model uses an
algorithm to perform tests on the motor and estimate the motor parameters. The host model starts
these tests and displays the estimated parameters.

Prepare Workspace
To open the parameter estimation host model, enter this command:

open_system('mcb_param_est_host_read.slx');
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Enter these details in the host model to prepare the workspace:

• Select Board — Select the target hardware and inverter combination.
• Communication Port — Specify the serial port that you want to configure. Select an available

port from the list. For more details, see “Find Communication Port” on page 6-4.
• Required Inputs — Enter the motor specification data. You can obtain these values either from

the motor datasheet or from the motor nameplate.

• Input DC Voltage — The DC supply voltage for the inverter (Volts).
• Nominal Current — The rated current of the motor (Ampere).
• Nominal Speed — The rated speed of the motor (RPM).
• Pole Pairs — The number of pole pairs of the motor.
• Nominal Voltage — The rated voltage of the motor (Volts).
• Position Offset — The position (Hall or quadrature encoder) sensor offset value (per-unit

position) (see “Hall Offset Calibration for PMSM Motor” on page 4-66, “Quadrature Encoder
Offset Calibration for PMSM Motor” on page 4-76, and “Per-Unit System” on page 6-15).

• Sensor Selection - The type of position sensor that you are using. You can select one of these
values:

• QEP — Select this option if you are using the quadrature encoder sensor attached to your
motor.

• HALL — Select this option if you are using the Hall sensors available in your motor.
• Sensorless — Select this option if you want to use the Flux Observer sensorless position

estimation block instead of a position sensor. For details about this block, see Flux
Observer.
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• Total QEP Slits — The number of slits available in the quadrature encoder sensor. By default,
this field has a value 1000.

Note When updating Required Inputs, consider these limitations:

• The rated speed of the motor must be less than 25000 RPM.
• The tests protect the hardware from over-current faults. However, to ensure that these faults do

not occur, keep the motor's rated current (entered in Nominal Current field) less than the
maximum current supported by the inverter.

• If you have an SMPS-based DC power supply unit, set a safe current limit on the power supply for
safety reasons.

Deploy Target Models
Before starting the tests by using the parameter estimation tool, you should download the binary files
(.hex/ .out) generated by the target model into the target hardware. There are two workflows to
download the binary files:

Workflow 1: Build and Deploy Target Model:

Use this workflow to generate and deploy the code for the target model. Ensure that you press Ctrl
+D to update the workspace with the required input details from the host model.

Click one of these hyperlinks in the parameter estimation host model to open the target model (for
the hardware that you are using):

• For F28069M-based controller attached to either Hall or quadrature encoder sensor:

mcb_param_est_f28069_DRV8312
• For F28069M-based controller that uses the sensorless Flux Observer block:

mcb_param_est_sensorless_f28069_DRV8312
• For F28379D-based controller attached to either Hall or quadrature encoder sensor:

mcb_param_est_f28379D_DRV8305
• For F28379D-based controller that uses the sensorless Flux Observer block:

mcb_param_est_sensorless_f28379D_DRV8305

Click Build, Deploy & Start in the Hardware tab to deploy the target model to the hardware.

Note Ignore the warning message Multitask data store option in the Diagnostics
page of the Configuration Parameter Dialog is none displayed by the model advisor, by
clicking the Always Ignore button. This is part of the intended workflow.
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Workflow 2: Manually Download Target Model:

Use this workflow to deploy the binary files (.hex/ .out) of the target model manually by using a
third party tool (the workflow does not need code-generation). This workflow is only valid for Teknic
M-2310P motor.

• Locate the binary files (.hex/ .out) at these locations:

• <matlabroot>\toolbox\mcb\mcbexamples\mcb_param_est_f28069_DRV8312.out
• <matlabroot>\toolbox\mcb\mcbexamples\mcb_param_est_f28379D_DRV8305.out

• Open a third-party tool to deploy the binary files (.hex/ .out).
• Download and run the binary files (.hex/ .out) on the target hardware.

Estimate Motor Parameters
Use the following steps to run the Motor Control Blockset parameter estimation tool:

1 Ensure that you deploy the binary files (.hex/ .out) generated from the target model, to the
target hardware and update the required details in the host model.

2 In the host model, click Run in the Simulation tab to run the parameter estimation tests.
3 The parameter estimation process takes less than a minute to perform the tests. You can ignore

the beep sound produced during the tests.
4 The host model displays the estimated motor parameters after successfully completing the tests.

The tool uses the following algorithm to estimate parameters:

• Motor resistance (R) - The tool uses Ohm's law to estimate this value.
• Motor inductance (Ld and Lq) - The tool uses frequency injection method to estimate these values.
• Back EMF (Ke) - The tool measures the currents and voltages and uses the electric motor equation

to estimate this value.
• Permanent magnet flux (λ) - The tool uses the estimated back EMF constant to estimate this value.
• Friction constant (B) - The tool estimates this value by using the torque equation for a motor

running at a constant speed.
• Inertia (J) - The tool estimates this value by using retardation test.
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• Rated Torque - The tool estimates this value by using the estimated value of permanent magnetic
flux of the motor.

When the parameter estimation tests complete, the Test Status LED turns green.

If the tests are interrupted, the Test Status LED turns red. When the LED turns red, run the host
model again to rerun the parameter estimation tests.

During an emergency, you can manually turn the Run-Stop slider switch to Stop position to stop the
parameter estimation tests. In addition, the model interrupts the parameter estimation tests and
turns these LEDs red to protect the hardware from the following faults:

1 Over-current fault (this fault occurs when actual current drawn from the power supply is more
than the Nominal Current value mentioned in the Required Inputs section of the host model)

2 Under-voltage fault (this fault occurs when input DC voltage drops below 80% of the Input DC
Voltage value mentioned in the Required Inputs section of the host model)

3 Serial communication fault

Save Estimated Parameters
You can export the estimated motor parameters and further use them for the simulation and control
system design.

To export, click Save Parameters to save the estimated parameters into a MAT (.mat) file.

To view the saved parameters, load the MAT (.mat) file in the MATLAB workspace. MATLAB saves
the parameters in a structure named motorParam in the workspace.
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Click Open Model to create a new Simulink model with a PMSM motor block. The motor block uses
the motorParam structure variables from the MATLAB workspace.
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Concepts

• “Host-Target Communication” on page 6-2
• “Open-Loop and Closed-Loop Control” on page 6-8
• “Current Sensor ADC Offset and Position Sensor Calibration” on page 6-12
• “Per-Unit System” on page 6-15
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Host-Target Communication
Motor Control Blockset uses a communication interface between the host model and the target model
to control the motor and observe feedback.

Host Model
The host model is a user interface for the controller hardware board. Run the host model on the host
computer. Before you run the host model on the host computer, make sure to deploy the target model
on the controller hardware board.

The host model commands, controls, and exchanges data with the target hardware. You can perform
these operations using the host model available in the Motor Control Blockset:

• Find the serial communication port (COM port) in the host system. For more details, see Find
Communication Port section in this page.

• Configure the serial port and baud rate by using the Serial Setup block.
• Start or stop the motor.
• Specify the motor speed.
• View the debug or output signals that the host receives from the target by using the Time Scope

and Display blocks.

Target Model
The target model runs on the controller hardware board. Deploy the target model to the embedded
target hardware that controls the motor. The target model communicates with the host model to
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receive commands from the user (for example, the command to start or stop the motor). Some
common operations that a target model available in Motor Control Blockset performs:

• Serial communication with the host model to receive user commands and exchange binary data.
• Read data from the position and current sensors attached to the motor and inverter.
• Control motor speed and torque by running the control algorithms and processing the feedback.
• Generate duty cycle inputs for the inverter.
• Enable fast serial data monitoring for debugging the signals.

Serial Communication Blocks
The host and target models interact by using these Motor Control Blockset blocks that enable serial
communication:

• Host Serial Receive
• Host Serial Setup
• Host Serial Transmit

Using these blocks you can monitor, control, and customize the motor operation in real time. For
example, you can view the debug signals, stop or start the motor, and change the motor speed
without repeated deployment of the target model.

Fast Serial Data Monitoring
The Motor Control Blockset example models use the fast serial data monitoring algorithm, which
performs control and diagnostic operations through the host model. This algorithm enables you to
observe data from the target device at the same rate as the execution sample time (for example,
PWM frequency of 20kHz). This, in turn, helps in diagnostics and analysis of transients.

Evaluation boards often provide serial communication over USB connections that enable fast serial
transfers. The models running on the Texas Instruments LaunchPad hardware boards send signals
like Ia and Ib currents over the serial interface. Use the host model to receive these signals on your
host computer. The Motor Control Blockset examples implementing Field Oriented Control (FOC)
algorithm for the F28379D LaunchPad use mcb_pmsm_foc_host_model_f28379d.slx. Examples
that implement the FOC algorithm for the F28069M targets, use
mcb_pmsm_foc_host_model_f28069m.slx. The Motor Control Blockset also provides other host
models for the application-based examples.

Selecting COM port and baud rate

Select the appropriate COM port that matches your board in the Serial Setup block of the host model.
Adjust the baud rate for your board:

Texas Instruments LaunchPad Baud Rate
F28027 LaunchPad 3.75e6
F28069 LaunchPad 5.625e6
F28377S LaunchPad 12e6
F28379D LaunchPad 12e6
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After you deploy the target model on the target device, run the host model and observe the debug
signals update at 20 kHz, on the time scope. You can use the same technique to monitor other signals
on other processors.

Note SCI_A is usually connected to the FTDI chip that allows serial transfers over USB on the
LaunchPad boards, docking stations, and ISO control cards.

Find Communication Port
Use these steps to find the serial communication port in the Device Manager of Windows PC, after
you connect the target hardware to your system:

1 Open Device Manager on your Windows PC.
2 Look for an entry under Ports (COM & LPT) titled USB Serial Port (COMX), where X is a

number. You can note down this number to configure the serial setup block in the host model.
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If you face difficulty in finding the COM port, follow these steps to determine the COM port:

1 Open Device Manager on your Windows PC.
2 Look for an entry under Ports (COM & LPT) titled USB Serial Port (COMX), where X is a

number. If there are multiple COM ports, you can disconnect and reconnect the C2000 board and
observe the updates in Device Manager to determine the COM port.

3 Alternatively, follow these steps to determine the correct port name for the connected target
hardware:

a Right-click a communication port and click Properties.
b In the Details tab, select Hardware Ids property.
c If the port indicates the following IDs, the communication port belongs to the connected TI’s

C2000™ controller hardware board:
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• VID: 0403
• PID: A6D0

4 If you do not see or find the right port in Ports (COM & LPT), navigate to Texas Instruments
Debug Probes and follow these steps:

a Right-click XDS100 Class Auxiliary Port Properties and select Properties. Navigate to
Advanced tab and select Load VCP.

b Right-click XDS100 Class Debug Port Properties and select Properties. Navigate to
Advanced tab and clear Load VCP.

c Disconnect and reconnect the USB cable to the system and observe the updates in Device
Manager to determine the COM port. The system now displays the COM port that belongs to
the connected TI’s C2000 controller hardware board.

Tip VCP stands for Virtual COM Port (for devices that support serial over USB communication).

5 If Texas Instruments Debug Probes do not appear in the Device Manager, expand Universal
Serial Bus controllers in the Device Manager and follow these steps:
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a Right-click TI XDS 100 Channel B and select Properties. Navigate to Advanced tab and
select Load VCP.

b Right-click TI XDS 100 Channel A and select Properties. Navigate to Advanced tab and
clear Load VCP.

c Disconnect and reconnect the USB cable to the system and observe the updates in Device
Manager to determine the COM port. The system now displays the COM port that belongs to
the connected TI’s C2000 controller hardware board.

6 If Device Manager does not detect the target hardware, follow these steps:

a Check that the target hardware is connected to the system.
b Check if the device drivers are installed correctly. Generally, device drivers are installed with

the Code Composer Studio™(CCS). Check if the CCS software is installed on your system.
Alternatively, try re-installing the device drivers suggested by Texas Instruments.

c Check if the serial connection cable is intact.
d If the problem persists, try connecting the hardware to another system and check if Device

Manager detects the hardware.
e If you still face the problem, the target hardware may be faulty.
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Open-Loop and Closed-Loop Control
This section describes the open-loop and closed loop motor control techniques.

Open-Loop Motor Control
Open-loop control (also known as scalar control or Volts/Hz control) is a popular motor control
technique that you can use to run any AC motor. This is a simple technique that does not need any
feedback from the motor. To keep the stator magnetic flux constant, we keep the supply voltage
amplitude proportional to its frequency.

This figure shows an open-loop control system. The power circuit consists of a PWM voltage fed
inverter supplied by a DC source. The system does not use any feedback signal for control
implementation. It uses the reference speed to determine the frequency of the stator voltages. The
system computes the voltage magnitude as proportional to the ratio of rated voltage and rated
frequency (commonly known as Volts/Hz ratio), so that the flux remains constant.

λm ∝   Vs fs

where:

1 λm is the rated flux of the motor in Wb.
2 Vs is the stator voltage of the AC motor in Volts.
3 fs is the frequency of the stator voltage of the AC motor in Hz.

In an open-loop system, the speed for an AC motor is expressed as:

Speed(rpm) =  
60 × fs

p

where:
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• Speed(rpm) is the mechanical speed of the AC motor in rpm.
• fs is the frequency of the stator voltage and currents of the AC motor in Hz.
• p is the number of pole pairs of the motor.

You can use the preceding expression to determine the frequency of reference voltages for a required
speed (for a given machine).

f ref =   p × RPMref
60

Use this frequency to generate PWM reference voltages for the inverter. Compute the magnitude of
voltages by maintaining Volts/Hz ratio as:

Vref =  
Vrated
frated

f ref

When using the per-unit system representation, the open-loop control system considers Vrated as the
base quantity, which usually corresponds to 1PU or 100% duty cycle. Depending on the modulation
technique (either Sinusoidal PWM or Space Vector PWM), you may need an additional gain ( 2

3  for

sinusoidal PWM). At lower speeds, the system needs a minimum boost voltage (15% or 25% of the
rated voltage) to overcome the effect of the stator resistance voltage drop.

You can use open-loop control in applications where dynamic response is not a concern, and a cost-
effective solution is required. Open-loop motor control does not have the ability to consider external
conditions that can affect the motor speed. Therefore the control system cannot automatically correct
the deviation between the desired and the actual motor speeds.

Note Scalar control implementation does not consider compensating voltage drop due to stator
resistance and field weakening.

Closed-Loop Motor Control
Closed-loop control takes the system feedback into consideration for control. Closed-loop control of
the motor considers the feedback of motor signals like current and position. The control system uses
the feedback signals to regulate the voltage (applied to the motor) to keep the motor response at a
reference value.
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Field-Oriented Control (FOC) (or vector control) is a popular closed-loop system that is used in motor
control applications. The FOC technique is used to implement closed-loop torque, speed, and position
control of motors. This technique also provides good control capability over the full torque and speed
ranges. The FOC implementation needs transformation of stator currents from the stationary
reference frame to the rotor flux reference frame.

Speed control and torque control are the commonly used control modes in FOC. The position control
mode is less commonly used. Most traction applications use the torque control mode in which the
motor control system follows a reference torque value. In the speed control mode, the motor
controller follows a reference speed value and generates a torque reference for torque control that
forms an inner subsystem. Whereas, in the position control mode, the speed controller forms the
inner subsystem.

You need real-time feedback of the current and rotor position to implement the FOC algorithm. You
can use sensors to measure the current and the rotor position. You can also use sensorless techniques
that use estimated feedback values instead of the actual sensor-based measurements.

Closed-loop control uses the real-time position and stator current feedback to tune the speed
controller and the current controller and change the duty cycles of the inverter. This ensures that the
corrected three-phase voltage supply (that runs the motor) corrects the motor feedback deviation
from the desired value.

Open-Loop to Closed-Loop Transitions
Some applications require the motor to start using an open-loop control. Once the motor achieves the
minimum required stability in open-loop control, the control system shifts to closed-loop.

In a quadrature encoder-based position sensing system, the motor starts up in open-loop and
transitions to closed-loop once the index pulse is detected.
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In sensorless position control, the motor starts running at 10% of the base speed in the open-loop.
After the reference switch goes beyond 10% of the base speed, the control system transitions from
open-loop to closed-loop.

To ensure smooth transition from open-loop to closed-loop, the PI controllers reset and start from the
same initial condition as the open-loop outputs.
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Current Sensor ADC Offset and Position Sensor Calibration
This section explains about analog to digital controller (ADC) and position sensor offset calibration.

Current Sensor ADC Offset Calibration
In an inverter, signal conditioning for the current sensor introduces an offset voltage in the ADC input
to measure both positive and negative current. This offset value is different for each target hardware
because it depends on the tolerances of the components in the signal sensing and conditioning
circuit. It is recommend that you measure the current sensor ADC offset for the target hardware.
Current sensor ADC offset is represented in ADC counts that correspond to zero ampere current.

See the example “Run 3-Phase AC Motors in Open-Loop Control and Calibrate ADC Offset” on page 4-
6 to manually measure the ADC offset value. In the Motor Control Blockset examples, update the
measured value in the inverter.CtSensAOffset and inverter.CtSensBOffset variables in the
model initialization script. By default, the script updates the inverter.CtSensAOffset and
inverter.CtSensBOffset variables with the default values.

The examples in Motor Control Blockset calculate the current sensor ADC offset in the hardware
initialization subsystem. In the model initialization script, when you set
inverter.ADCOffsetCalibEnable = 1, the script enables the current sensor offset calibration in
the target hardware during initialization. In the hardware initialization subsystem, ADC channels
read the input current multiple times and averages them. The current controller uses this averaged
ADC offset value. In the model initialization script, when you set
inverter.ADCOffsetCalibEnable = 0, the script disables the current sensor offset calibration
and uses the values from the initialization script.

Note Always measure the current sensor ADC offset when the motor is not running. It is
recommended that you unplug the electric wires connected to the motor.

Position Sensor Offset Calibration for Quadrature Encoder and Hall
Sensor
The controller requires the position sensor offset computation to determine accurate real-time
feedback of the rotor position and implement the Field-Oriented Control (FOC) algorithm correctly. It
is recommended that you use the examples for offset calibration to compute the position offset before
running any other example that uses FOC.

Hall sensor offset is the angle between the d-axis of the rotor and the position detected by the Hall
sensor. You can use the offset to correct and compute an accurate position of the d-axis of the rotor.

Quadrature encoder sensor offset is the angle between the d-axis of the rotor and the encoder index
pulse position detected by the quadrature encoder.

Motor Control Blockset offers examples like “Quadrature Encoder Offset Calibration for PMSM
Motor” on page 4-76 and “Hall Offset Calibration for PMSM Motor” on page 4-66 to obtain the
accurate rotor position for implementing the control algorithm. The offset computation examples use
a unique algorithm along with open-loop control to compute the position offsets of the position
sensors (Hall or quadrature encoder). Open-loop control (also known as scalar control or volt/Hz
control) is a popular motor control technique that can be used to run any AC motor. This is a simple
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technique that does not need any feedback from the motor. To ensure a constant stator magnetic flux,
keep the supply voltage amplitude proportional to its frequency. This figure shows an overview of the
open-loop control. See “Open-Loop and Closed-Loop Control” on page 6-8 for more details.

By using this algorithm, the offset calibration examples detect the position offset in this manner:

• Check if the motor is in a no-load condition.
• Start and run the motor in open-loop at a very low speed (for example, 60rpm). At a low speed, the

rotor d-axis closely aligns with the rotating magnetic field of the stator.
• Measure the feedback position of the available position sensor (Hall or quadrature encoder).
• Compare the open-loop position with feedback position and check that the phase-sequence is

correct. If required, correct the motor phase-sequence.
• Compute the Hall sensor position offset by obtaining the difference between the open-loop

position and feedback position.
• Run the motor in the open-loop for few cycles and stop the motor. Ensure that the encoder index

pulse is detected at least once. Lock the rotor in the d-axis. The quadrature encoder position offset
is identical to the position feedback. This outputs the quadrature encoder mechanical offset
position.

 Current Sensor ADC Offset and Position Sensor Calibration
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This figure shows the comparison of open-loop position from the control algorithm along with the
actual position of the motor. The figure also shows the feedback from the position sensor. The position
offset, which is the difference between the open-loop position and feedback position from the sensor,
is computed by the algorithm provided in the offset calibration models.

• Update the measured offset in the pmsm.PositionOffset variable in the model initialization
script of the examples.

• For parameter estimation, update the measured Hall offset in the Hall Offset field of the
mcb_param_est_host_read model.

Note The “Hall Offset Calibration for PMSM Motor” on page 4-66 example outputs the electrical
position offset. Whereas, the “Quadrature Encoder Offset Calibration for PMSM Motor” on page 4-76
example outputs the mechanical position offset.

For steps to compute the offsets, see these examples:

“Quadrature Encoder Offset Calibration for PMSM Motor” on page 4-76

“Hall Offset Calibration for PMSM Motor” on page 4-66

“Run 3-Phase AC Motors in Open-Loop Control and Calibrate ADC Offset” on page 4-6
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Per-Unit System
Motor Control Blockset uses these International System of Units (SI):

Quantity Unit Symbol
Voltage volt V
Current ampere A
Speed radians per second

revolutions per minute

rad/s

rpm
Torque newton-meter N.m
Power watt W

Note The SI Unit for speed is rad/s. However, most manufacturers use rpm as the unit to specify the
rotational speed of the motors. Motor Control Blockset prefers rpm as the unit of rotational speed
over rad/s. However, you can use either value based on your preference.

Per-Unit System
The per-unit (PU) system is commonly used in electrical engineering to express the values of
quantities like voltage, current, power, and so on. It is used for transformers and AC machines for
power system analysis. Embedded systems engineers also use this system for optimized code-
generation and scalability, especially when working with fixed-point targets.

For a given quantity (such as voltage, current, power, speed, and torque), the PU system expresses a
value in terms of a base quantity:

quantity expressed in PU = quantity expressed in SI units
base value

Generally, most systems select the nominal values of the system as the base values. Sometimes, a
system may also select the maximum measurable value as the base value. After you establish the base
values, all signals are represented in PU with respect to the selected base value.

For example, in a motor control system, if the selected base value of the current is 10A, then the PU
representation of a 2A current is expressed as (2/10) PU = 0.2 PU.

Similarly,

quantity expressed in SI units = quantity expressed in PU × base value

For example, the SI unit representation of 0.2 PU = (0.2 x base value) = (0.2 x 10) A.

Per-Unit System and Motor Control Blockset
Motor Control Blockset uses these conventions to define the base values for voltage, current, speed,
torque, and power.

 Per-Unit System
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Quantity Representation Convention
Base voltage Vbase This is the maximum phase

voltage supplied by the inverter.

Generally, for Space Vector
PWM, it is
PU_System.V_base = 
inverter.V_dc

3

 .

For Sinusoidal PWM, it is
PU_System.V_base = 
inverter.V_dc

2

.

Base current Ibase This is the maximum current
that can be measured by the
current sensing circuit of the
inverter.

Generally, but not necessarily, it
is Imax of the inverter.

PU_System.I_base = inverter.I_max
Base speed Nbase This is the nominal (or rated)

speed of the motor. This is also
the maximum speed that the
motor can achieve at the
nominal voltage and nominal
load without a field-weakening
operation.

Base torque Tbase This torque is mathematically
derived from the base current.
Physically, the motor may or
may not be able to produce this
torque.

Generally, it is
PU_System.T_base = 32
× pmsm.p × pmsm.FluxPM

× PU_System.I_base

.
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Quantity Representation Convention
Base power Pbase This is the power derived by the

base voltage and base current.

Generally, it is
PU_System.P_base = 32
× PU_System.V_base

× PU_System.I_base

.

where:

• Vdc is the DC voltage that you provide to the inverter.
• Imax is the maximum current measured by the ADCs connected to the current sensors of the

inverter.
• p is the number of pole pairs available in the PMSM.
• FluxPM is the permanent magnet flux linkage of the PMSM.
• pmsm is the MATLAB workspace parameter structure that saves the motor variables.
• inverter is the MATLAB workspace parameter structure that saves the inverter variables.
• PU_System is the MATLAB workspace parameter structure that saves the PU system variables.

For the voltage and current values, you can generally consider the peak value of the nominal
sinusoidal voltage (or current) as 1PU. Therefore, the base values used for voltage and current are
the RMS values multiplied by 2, or the peak value measured between phase-neutral.

You can simplify your calculations by using the PU system. Motor Control Blockset uses these base
value definitions for the PU-system-related conversions performed by the algorithms used in the
toolbox examples. The toolbox stores the PU-system-related variables in a structure called
PU_System in the MATLAB workspace.

Why Use Per-Unit System Instead of Standard SI Units
Per-unit representation of signals has many advantages over the SI units. This technique:

• Improves the computational efficiency of code execution, and therefore is a preferred system for
fixed-point targets.

• Creates a scalable control algorithm that can be used across many systems.

 Per-Unit System
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Hardware Connections
Motor Control Blockset supports the following hardware configurations:

1 F28069 control card configuration
2 LAUNCHXL-F28069M configuration
3 LAUNCHXL-F28379D configuration
4 C2000 MCU Resolver Eval Kit [R2]

F28069 control card configuration
The configuration includes the following hardware components:

• Texas Instruments DRV8312-69M-KIT inverter board
• Texas Instruments F28069 microcontroller control card
• Motor BLY171D (supports both Hall and quadrature encoder sensors)
• Motor BLY172S (supports Hall sensor)
• Quadrature encoder
• DC power supply

Note Due to auxiliary power supply related hardware issues, the DRV8312-69M-KIT does not support
the position sensors connected to some motors (for example, Teknic M-2310P motor).

The following steps describe the hardware connections for the F28069 control card configuration:

1 Connect the F28069 control card to J1 of DRV8312-69M-KIT inverter board.
2 Connect the motor three phases, to MOA, MOB, and MOC on the inverter board.
3 Connect the DC power supply (24V) to PVDDIN on the inverter board.

Warning Be careful when connecting PVDD and GND to the positive and negative connections of the
DC power supply. A reverse connection can damage the hardware components.
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The following step describes about interfacing the quadrature encoder sensor:

• Connect the quadrature encoder pins (G, I, A, 5V, B) to J4 on the inverter board.

To implement position-sensing by using Hall sensor, use a motor that has inbuilt Hall sensors (for
example, BLY171D and BLY172S). The following steps describe the steps to interface the Hall sensor:

• Connect the Hall sensor encoder output to J10 on the inverter board.

 Hardware Connections
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We recommend the following jumper settings for DRV8312-69M-KIT inverter board when working
with Motor Control Blockset. You can customize these settings depending on the application
requirements. For more information about these settings, see the device user guide available on
Texas Instruments website.

• JP1 – VR1
• JP2 – ON
• JP3 – OFF
• JP4 – OFF
• JP5 – OFF
• M1 – H
• J2 – OFF
• J3 – OFF
• RSTA – MCU
• RSTB - MCU
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• RSTC - MCU

LAUNCHXL-F28069M and LAUNCHXL-F28379D Configurations
The LAUNCHXL-F28069M configuration includes the following hardware components:

• LAUNCHXL-F28069M controller
• BOOSTXL-DRV8305 (supported inverter)
• Teknic motor M-2310P (supports both Hall and quadrature encoder sensors)
• Motor BLY171D (supports both Hall and quadrature encoder sensors)
• Motor BLY172S (supports Hall sensor)
• DC power supply

The LAUNCHXL-F28379D configuration includes the following hardware components:

• LAUNCHXL-F28379D controller
• BOOSTXL-DRV8305 and BOOSTXL-3PHGANINV (supported inverters)
• Teknic motor M-2310P (supports both Hall and quadrature encoder sensors)
• Motor BLY171D (supports both Hall and quadrature encoder sensors)
• Motor BLY172S (supports Hall sensor)
• DC power supply

The following steps describe the hardware connections for the LAUNCHXL-F28069M and
LAUNCHXL-F28379D configurations:

1 Attach the BOOSTXL inverter board to J1, J2, J3, J4 on the LAUNCHXL controller board.

Note Attach the inverter board to the controller board such that J1, J2 of BOOSTXL aligns with
J1, J2 of LAUNCHXL.

2 Connect the motor three phases, to MOTA, MOTB, and MOTC on the BOOSTXL inverter board.
3 Connect the DC power supply (24V) to PVDD and GND on the BOOSTXL inverter board.

Warning Be careful when connecting PVDD and GND to the positive and negative connections of the
DC power supply. A reverse connection can damage the hardware components.
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The following step describes about interfacing the quadrature encoder sensor:

• Connect the quadrature encoder pins (G, I, A, 5V, B) to QEP_A on the LAUNCHXL controller
board.

To implement position-sensing by using Hall sensor, use a motor that has inbuilt Hall sensors (for
example, Teknic motor M-2310P, BLY171D and BLY172S). The following steps describe the steps to
interface the Hall sensor:

• Connect the Hall sensor encoder output to a GPIO port that is configured as eCAP, on the
LAUNCHXL controller board.
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We recommend the following jumper settings for the LAUNCHXL inverter boards when working with
Motor Control Blockset. You can customize these settings depending on the application requirements.
For more information about these settings, see the device user guide available on Texas Instruments
website.

For LAUNCHXL-F28069M controller

• JP1 – ON
• JP2 – ON
• JP3 – ON
• JP4 – ON
• JP5 – ON
• JP6 – OFF
• JP7 – ON

For LAUNCHXL-F28379D controller

• JP1 – ON
• JP2 – ON
• JP3 – ON
• JP4 – ON
• JP5 – ON
• JP6 – OFF
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Instructions for Dyno (Dual Motor) Setup

1 Connect the three phases of Motor1 and Motor2, to MOTA, MOTB, and MOTC on the
corresponding BOOSTXL inverter boards.

2 Attach the BOOSTXL inverter board (connected to Motor1) to J1, J2, J3, J4 on the LAUNCHXL
controller board.

Note Attach the inverter board to the controller board such that J1, J2 of BOOSTXL aligns with
J1, J2 of LAUNCHXL.

3 Attach the BOOSTXL inverter board (connected to Motor2) to J5, J6, J7, J8 on the LAUNCHXL
controller board.

Note Attach the inverter board to the controller board such that J1, J2 of BOOSTXL aligns with
J5, J6 of LAUNCHXL.

4 Connect the DC power supply (24V) to PVDD and GND on both BOOSTXL inverter boards.

Note Connect the PVDD and GND on the BOOSTXL boards (for MOTOR1 and MOTOR2) to the
same power supply. When one motor consumes power, the second motor generates power. If you
connect both motors to the same power supply, the power generated by one motor is consumed
by the other motor. The DC power supply delivers power only for the losses.

5 Connect the quadrature encoder pins of Motor1 (G, I, A, 5V, B) to QEP_A on the LAUNCHXL
controller board.

6 Connect the quadrature encoder pins of Motor2 (G, I, A, 5V, B) to QEP_B on the LAUNCHXL
controller board.

Warning Be careful when connecting PVDD and GND to the positive and negative connections of the
DC power supply. A reverse connection can damage the hardware components.
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TMDSRSLVR C2000 Resolver to Digital Conversion Kit
The TMDSRSLVR C2000 Resolver to Digital Conversion Kit configuration includes the following
hardware components:

• LAUNCHXL-F28069M controller
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• BOOSTXL-DRV8305 (supported inverter)
• DC power supply
• TMDSRSLVR C2000 Resolver to Digital Conversion Kit (Resolver Eval Kit [R2])
• Resolver encoder

The following steps describe the hardware connections for the TMDSRSLVR board:

1 Connect DC power supply (15V) to J2 on the TMDSRSLVR board.
2 Connect the resolver output pins for sine wave to pins 1, 2 of J10 on the TMDSRSLVR board.
3 Connect the resolver output pins for cosine wave to pins 3, 4 of J10 on the TMDSRSLVR board.
4 Connect the resolver input pins to the PWM_dither and PWM_SINE pins of J10 on the

TMDSRSLVR board.

The following step describes the hardware connection for the LAUNCHXL-F28069M controller board:

• Connect the LAUNCHXL-F28069M controller board to a computer via USB port.

The following steps describe the hardware connections between the MCU Resolver Eval Kit [R2] and
LAUNCHXL-F28069M controller boards:

1 Connect the COS(T2) pin on the TMDSRSLVR board to pin 24 of J3 on the LAUNCHXL-F28069M
controller board.

2 Connect the SIN(T8) pin on the TMDSRSLVR board to pin 29 of J3 on the LAUNCHXL-F28069M
controller board.

3 Connect the GPIO2 pin on the TMDSRSLVR board to pin 38 of J4 on the LAUNCHXL-F28069M
controller board.

 Hardware Connections

7-11




	Product Overview
	Model Configuration Parameters
	Model Configuration Parameters
	Solver Configuration
	ADC Interface Configuration
	PWM Interface Configuration
	Hall Sensor Interface Configuration
	Quadrature Encoder Interface Configuration
	Serial Communication Interface Configuration


	Estimate Control Gains from Motor Parameters
	Estimate Control Gains from Motor Parameters
	Field-Oriented Control Autotuner
	Simulink Control Design
	Model Initialization Script


	Implement Motor Speed Control by Using Field-Oriented Control (FOC)
	Field-Oriented Control (FOC)
	Permanent Magnet Synchronous Motor (PMSM)
	AC Induction Motor (ACIM)

	Six-Step Commutation
	Run 3-Phase AC Motors in Open-Loop Control and Calibrate ADC Offset
	Tune Control Parameter Gains in Hardware and Validate Plant
	Tune PI Controllers Using Field Oriented Control Autotuner
	Field-Oriented Control of PMSM Using Hall Sensor
	Field-Oriented Control of PMSM Using Quadrature Encoder
	Field-Weakening Control (with MTPA) of PMSM
	Sensorless Field-Oriented Control of PMSM
	Use Motor Control Blockset to Generate Code for Custom Target
	Field Oriented Control of PMSM Using SI Units
	Hall Offset Calibration for PMSM Motor
	Monitor Resolver Using Serial Communication
	Quadrature Encoder Offset Calibration for PMSM Motor
	Model Switching Dynamics in Inverter Using Simscape Electrical
	Control PMSM Loaded with Dual Motor (Dyno)
	Field-Oriented Control of Induction Motor Using Speed Sensor
	Sensorless Field-Oriented Control of Induction Motor
	Tune PI Controllers Using Field Oriented Control Autotuner Block on Real-Time Systems
	Six-Step Commutation of BLDC Motor Using Sensor Feedback
	Hall Sensor Sequence Calibration of BLDC Motor
	Position Control of PMSM Using Quadrature Encoder
	Integrate MCU Scheduling and Peripherals in Motor Control Application
	Partition Motor Control for Multiprocessor MCUs
	Frequency Response Estimation of PMSM Using Field-Oriented Control
	MATLAB Project for FOC of PMSM with Quadrature Encoder

	Estimate Motor Parameters Using Motor Control Blockset Parameter Estimation Tool
	Estimate Motor Parameters Using Motor Control Blockset Parameter Estimation Tool
	Prerequisites
	Supported Hardware
	Required MathWorks Products
	Prepare Hardware
	Parameter Estimation Tool
	Prepare Workspace
	Deploy Target Models
	Estimate Motor Parameters
	Save Estimated Parameters


	Concepts
	Host-Target Communication
	Host Model
	Target Model
	Serial Communication Blocks
	Fast Serial Data Monitoring
	Find Communication Port

	Open-Loop and Closed-Loop Control
	Open-Loop Motor Control
	Closed-Loop Motor Control
	Open-Loop to Closed-Loop Transitions

	Current Sensor ADC Offset and Position Sensor Calibration
	Current Sensor ADC Offset Calibration
	Position Sensor Offset Calibration for Quadrature Encoder and Hall Sensor

	Per-Unit System
	Per-Unit System
	Per-Unit System and Motor Control Blockset
	Why Use Per-Unit System Instead of Standard SI Units


	Hardware Connections
	Hardware Connections
	F28069 control card configuration
	LAUNCHXL-F28069M and LAUNCHXL-F28379D Configurations
	TMDSRSLVR C2000 Resolver to Digital Conversion Kit



